Talk:Mods/Creating mods/Setting up the MCP workspace

From Minecraft Wiki
Jump to: navigation, search

"NOTE, THIS DOES NOT WORK FOR CURRENT VERSION OF MINECRAFT!!!"

This is an almost useless notation. It should read : "NOTE, THIS DOES NOT WORK FOR CURRENT VERSION OF MINECRAFT!!!" (Version XX.YY) Mstram (talk) 19:48, 8 November 2014 (UTC)

Update Please[edit]

Ok, could someone please update this for the most recent version. It goes well until about step five. There is no options, force update button, bin, or resource folder.

Check out Pahimar's video: Let's Mod with Pahimar! Episode 6: Dev Environment 3 0 GufNZ (c: 02:52, 7 August 2013 (UTC)
PS: you forgot to sign your post with ~~~~



"After downloading, drag the "minecraft_server.jar" into the "jars" folder."

not in the "jars/bin"? –Preceding unsigned comment was added by 87.152.182.117 (Talk|Contribs) 17:32, 28 August 2012 (UTC). Please sign your posts with ~~~~

Nope. "jars/bin" contains client files. minecraft_server.jar goes straight in "jars". --Krenair (talkcontribs) 17:35, 28 August 2012 (UTC)

ok i have done this before, and it worked fine until i ran eclipse for the second time and it stopped working. i wiped EVERYTHING and followed all the instructions again but now whenever i try to decompile the following error message is displayed:

"!! Missing client jar file. Aborting !!
"!! Missing server jar file. Aborting !!"

this is displayed whenever i try and decompile, but i have downloaded the minecraft_server.jar file from the mimecraft website and followed everything the instructions said Mario64325 18:46, 5 December 2012 (UTC)

You need to have the jar files in the correct locations:
mcp/jars/minecraft_server.jar
mcp/jars/bin/minecraft.jar
If they aren't there, MCP won't be able to find them. -- Orthotope 19:15, 5 December 2012 (UTC)

I have set up Eclispe and gone through package explorer to src. There is no arrow next to the folder and there is a "!" on it. I am unable to access it's contents. Ripia300 09:50, 30 January 2013 (UTC)

This needs clarification as to the folder in question in many places. Perhaps specify example names for the folders, used consistently throughout the text? Otherwise it's just confusing. I can't do so myself since I don't actually know which folder is being discussed most of the time. Also, it might be a good idea to split up some of the larger chunks of text for readability. OceanEmbers 22:27, 1 April 2013 (UTC)

How to fix "No Java Virtual Machine Found" error I was struggling for a couple of hours trying to figure out why Eclipse wouldn't run, and here's the solution. If you get the error that Java can't find the virtual machine, the environment variable "PATH" is redirecting to the wrong place. This is copy and pasted from a technical help forum, but the wiki doesn't let me use the link so I can't provide it.

Open up Windows' System Properties (right click "Computer", then go to Advanced system settings) from the control panel and hunt down the environment variables section: (Go to Environment Variables) Add a JAVA_HOME entry (In System Variables) pointing to the directory where the JDK is installed (e.g. C:\Program Files\Java\jre7) Find the Path entry and add the following onto the end ;%JAVA_HOME%\bin OK the changes Restart eclipse so that it is aware of the new environment Most Java tools will now be able to find your Java installation either by using the JAVA_HOME environment variable or by looking for java.exe / javaw.exe in the Path environment variable. 67.1.158.56 04:59, 5 April 2013 (UTC)

decompile failed[edit]

decompile.bat states that: '"C:\Program Files\Java\jdk1.7.0_17" -jar runtime\bin\mcinjector.jar temp\minecraft_rg.jar t...' failed : 1

may i have some assistance, please? XReggie9000 23:02, 5 May 2013 (UTC)

Without the entire error message/log, there's not much anyone can do. -- Orthotope 01:29, 6 May 2013 (UTC)
I had the same problem. The problem was that the client.jar had a different version.

How can i Fix Virtual Machine launcher error[edit]

Hey Guys Could you please tell me How to Fix My minecraft Every time i try to Open My Minecraft a message comes up and Says Error Your Virtual Machine launcher Is not created. Please help I need To Check My Server

MC 1.6.2 Decompile Failure[edit]

I try to decompile, and this is what I get:

         == MCP 8.04 <data: 8.04, client: 1.6.2, server 1.6.2> ==
         "scalac" is not founf on this PATH. Scala files will not be recompiled
         # found ff, ff patches, srgs, name csvs, doc csvs, param csvs, astyle, astyle config, rg, ss
         Looking in C:\Users\|||||||||||\AppData\Roaming\.minecraft\versions for mc installs... OK
         Copying assets... OK
         Looking from minecraft main jar... OK
         > Checking libraries...
               Copying library lwjgl-platform... Error copying library org.lwjgl.lwjgl:lwjgl-platform:2.9.1-nightly-20130708-debug3
         Press any key to continue...

That is everything I get from the cmd from decompile.bat. And that file I get an error on is empty..? Not sure, hoping something can enlighten me! Thanks -- TheNoobieWaffle To contact me:{Skype: TheNoobieWaffle (Best way to contact me!), MinecraftForum: TheNoobieWaffle} –Preceding undated comment was added on 19:50, 10 July 2013. Please sign your posts with ~~~~

Seems like a bug in the MCP configuration; Minecraft isn't using LWJGL 2.9.1 builds yet. You'd be better off contacting the MCP folks directly about this. -- Orthotope talk 20:08, 10 July 2013 (UTC)

Client and Server[edit]

I made sure my workspace is in the folder Eclipse, but there is no Client or Server in my Package Explorer. --46.116.187.204 08:09, 18 August 2013 (UTC)

EDIT: I checked my Eclipse folder and there are Client and Server folders, but they don't appear in my Package Explorer. --93.172.58.111 05:39, 19 August 2013 (UTC)