Talk:Issues/Beta 1.9pre6

From Minecraft Wiki
Jump to: navigation, search

Contents

Enchanting Tables[edit source]

They don't seem to have higher level enchantment even with the maximum amount of bookshelfs around them. Anyone else seen this?68.177.209.95Euclid

Piston Quasiconnectivity Bug[edit source]

A piston can be powered by a block that is not directly adjacent to it, but diagonally above or 2 blocks above. However changes to these blocks will not propagate updates to the piston. However, when the piston is caused to update by other means, it will take into account the state of these nonadjacent blocks. This list seems to have originated from this image: [1]

  • People keep reposting this bug here, unaware that it had been addressed in the 1.9pre5 list. I'm copying it over so that everyone is aware of its status. Please don't remove. —Immute [talk]
  • This is intentional, Jeb even proves it in his "Pistons in progress" video.
  • Can you tell exactly where it is proven to be intentional? it certainly isn't in that video. This bug has plagued everyone who ever tried to make a construction with two layers of pistons above each other, since they cannot be controlled separately and behave really strange. It is also very counter intuitive to new users, and it makes absolutely no sense at all.
  • Tried searching his twitter, could not find such post. What kind of design uses this bug? Also, this bug breaks too many piston-circuits: some hidden solid wall doors and ~all piston-transistors.
  • This bug is used in BUD switches, to detect block changes, and hidden piston doors. Otherwise you would need more complicated wiring to power the 2 bottom pistons. 186.204.105.168 17:12, 12 November 2011 (UTC)
  • I know that pistons being powerable from 2 blocks away is intentional, not a bug to be fixed, but the fact that updates don't propagate from all powering positions might actually still be a bug... 76.105.37.245 18:01, 12 November 2011 (UTC)

blocks dont un-craft[edit source]

While ___ is craftable into ___, ___ is not craftable back into ___. (Add a better title please)

  • Agreed that this is stupid, given how soft clay is in real life and the fact that Steve can chop logs into planks with his bare hands. 75.61.81.249 14:35, 13 November 2011 (UTC)
  • I think this is not actually a bug, because unlike Clay that is useless itself and yields 4 Clay Balls, Wool and Strings are both useful, but Wool is acquired much more easily, in larger numbers with Shears and has a 4:1 value with strings. That would make the Wool OP and render Spider Hunting useless. Seud
  • Wool and Clay blocks are ideal for storage of these items. It's more of a matter of consistency. Spider Hunting is already useless, at least for string (hunting for spider eyes would still be useful), now that abandoned mines are full of cobwebs. You end up with multiple stacks of string that may as well be compressed into Wool. As for if this is in fact a bug or not, that's up to the developers.--Inertia 08:59, 12 November 2011 (UTC)
  • I'll second Inertia's notion. Consistency and interchangeability is the key here. Similar claim about over powerful can also be said about gold ingots going to gold nuggets, eliminating the needs to attack pig zombies all together, and clearly does not work.
  • Maybe 8 strings should compress to something else, like string stack. Then that string stack could be transformed back to 8 strings. --93.106.243.57 16:11, 13 November 2011 (UTC)
  • This would allow the acquisition of string, and therefore bows and fishing rods, without the need to hunt spiders or explore abandoned mineshafts, both risky activities. Not that Minecraft has ever been well-balanced... 75.61.81.249 14:35, 13 November 2011 (UTC)

Chiisana 05:23, 13 November 2011 (UTC)

  • This would allow the conversion of glowstone into dust without the use of a pickaxe, ergo violating the second law of Minecraft Thermodynamics.75.61.81.249 14:35, 13 November 2011 (UTC)
  • If anything, it should be possible to disassemble melons but not reassemble them. 75.61.81.249 14:35, 13 November 2011 (UTC)
  • Agreed that this is stupid, for the same reasons as clay. 75.61.81.249 14:35, 13 November 2011 (UTC)
  • Nobody is complaining about the fact that brick blocks can't be crafted back into bricks, stone bricks can't be crafted back into stone, stairs and slabs can't be converted back to their original materials, fences can't be turned back into sticks, workbenches can't be turned back into planks, etc... I wonder why. In summation, the original rationale for this phenomenon seems to be that the only blocks that can be "converted back" are the storage blocks that have no inherent use by themselves. Of course, this doesn't account for clay or snow (both only useful in ball form)... 75.61.81.249 14:56, 13 November 2011 (UTC)

No Ice with Silk Touch[edit source]

Ice is no longer obtainable with the Silk Touch enhancement; water is produced as usual.

  • Jeb said he "fixed this in an unsatisfactory way" by removing it from silk touch. He might improve on it. I suggest that upon entry to the Nether, water buckets turn to plain buckets, ice and water (8, 9, 79) simply disappears from inventory, and a loud hiss and particle effect similar to lava touching water emanates from the player. This way players are allowed to keep ice in the Overworld and End, and enhances the atmosphere of the Nether.--PlNG 01:45, 12 November 2011 (UTC)
  • Ice no longer being obtainable makes silk touch nearly worthless. When it was introduced, I was so glad that finally there was a legitmate way to get spawners and ice to build cool structures out of them. Especially cool, was that it was quite difficult to get silk touch, so not everyone would have this. And same is with water in the nether. It is really cool if it is not easy. but possible to set water there; some kind of reward for all the effort to get silk touch!
    • Agreed. If anything, perhaps it could be changed so that Ice no longer melts in the Nether? TorchicBlaziken 00:54, 13 November 2011 (UTC)
  • Why can't ice just work the same as water i.e. you can't place it in the Nether? or the ice could melt then the water block vanishes?
  • I don't see what the big deal is with allowing the player to use ice in the Nether or anywhere else for that matter. If the player wants to farm the holy bejesus out of xp to get some rare enchant just to go on a several hour ice farming expedition just to build a grinder in the Nether, what's the harm really? I mean, at that point half a dozen hours have been spent on the task and it really isn't hurting anyone.
    • Agreed, after spending that much effort to get Silk Touch, it might as well be useful. (Same argument applies for monster spawners - the tradeoff with them is you can only spawn pigs). Also, sign your posts with four ~'s. Immibis 09:07, 15 November 2011 (UTC)

cant compress ores[edit source]

Of the ores and minerals: Lapis, Iron, Diamond, and Gold can all be crafted into storage blocks. Redstone and Coal cannot. Iron, Diamond and Gold are all metals and therefore it makes sense for them to be shaped in the way they can be (into a cube). Lapis is a dye so can be made into a cube also. Redstone and Coal however are dust and carbon, not materials that can be made into blocks from smaller pieces in reality. --Corbiere6743 16:25, 12 November 2011 (UTC)

  • One would be hard-pressed (ha) to make a cube out of a bunch of diamonds in real life seeing as how they are crystalline carbon and not metal. Similarly lapis lazuli is a brittle rock, and redstone is not even a real thing. Working properties of these materials in 'reality' have no bearing on this issue; if there is a reason for redstone and coal not being craftable into storage blocks it ought to be design related and I'd love to hear it.
    • Redstone in particular is immensely annoying considering it is very abundant and it often clogs up miners' inventories. Lapis would be about as annoying if the lapis blocks did not exist.
      • The issue has been around for about a year on getsatisfaction. There were even textures proposed. Mr. n 12:45, 13 November 2011 (UTC)
  • This has always really annoyed me. The fact of the matter is that both lapis and diamond can't be compacted into cubes in real life, so this is clearly a case of it works better in game to leave it up to fantasy. Yet why the hell can't we use the same logic for a made up ore and coal? I mean, you could even get creative and give "redstone blocks" new mechanical properties to make creating them worthwhile. I'm thinking something similar to how a repeater works (power goes in and comes back out) without any ticks or tick changes involved. This idea does not remove the necessity for repeaters and allows players to do epic builds a lot easier and with less game lag. Logically speaking, a mass of redstone wire should in theory be able to help improve current in a line. Just my two cents.
  • What about a redstone cube acting as a redstone powered light block, simlar to glowstone, but controllable by redstone signals.

Wooden doors don't open[edit source]

When you try to open a wooden door in singleplayer with either left or right clicking, it does not open.
Trying to close an already opened wooden door (from a a 1.9pre5 world) , does work. But after that it will stay stuck in closed. Unset 16:11, 11 November 2011 (UTC)

See https://twitter.com/#!/jeb_/status/135022340957409280 --Ianweller 16:14, 11 November 2011 (UTC)
I think it was not my hand, that closed the door in my old 1.9pre5, but an Block Update, that detected not any redstone power. Unset 16:22, 11 November 2011 (UTC)

Now Steel Doors wont open and steel doors has the same sound than wooden doors.

Mobs still spawn inside trees and chests spin around it's left-top instead of middle[edit source]

Hey, I noticed that I have a sheep inside a tree's leaves here... ( http://i44.tinypic.com/2qmf85k.png ) and dropped chests spin around it's left top instead of middle like regular drops. --Diamondo25 16:20, 11 November 2011 (UTC)

Wolves are almost black when they are in rain[edit source]

Yea, it's color goes back by 60% or so. --Diamondo25 16:23, 11 November 2011 (UTC)

Torches cannot be placed on half blocks[edit source]

On the 1.9pre5 bug page, it says "[F] Torches cannot be placed on half blocks" but they still cannot be placed on them.

  • What do you want? A flying torch? --Diamondo25 16:50, 11 November 2011 (UTC)
No, but it should not say fixed, should it? --Gitterrost4 16:52, 11 November 2011 (UTC)
Did you form a full block from half-blocks? I believe the fix only applied to full blocks that are formed from half-blocks.--66.133.216.4 17:30, 11 November 2011 (UTC)
Ah this makes sense. Thank you. --Gitterrost4 17:43, 11 November 2011 (UTC)

Detector Rail signal has the same length when 2 minecarts drive over it[edit source]

The signal of the Detector Rail has got the same length when one minecart drives above it and a second comes when the signal of the Detector Rail is still on.

Can't open door by right clicking either in NPC village[edit source]

I'm standing in front of a house in a NPC village, and I can't open the door by either right or left clicking. Double door-open sound is heard by both actions. --Diamondo25 16:30, 11 November 2011 (UTC)

  • Might be the same bug...? --Diamondo25 16:36, 11 November 2011 (UTC)

NPC villages are able to spawn on water...[edit source]

Yea, in the same village as my last report, some part of it is located on a lake lol ( http://i39.tinypic.com/259ibko.png ) --Diamondo25 16:32, 11 November 2011 (UTC)


Tall gras in NPC-house[edit source]

I found dirt-blocks on the ground with tall gras, in a small NPC-House.
(picture: [2] )

  • I already know that bug, it isnt new. That bug could easily be fixed in giving the npc houses a floor instead of dirt. So its confirmed but not new. [2011-11-11]

Linux key sticking bugs[edit source]

Since there's now per-OS icons for the bug list, I'd like to add the following from the common Known bugs page:

Directional keys commonly become stuck, causing a player to continue moving in a certain direction until they bring up a GUI, This also happens with jumping.
What happens if you press the "stuck" button again? User42 17:51, 12 November 2011 (UTC)

I have tested this again on 1.9pre6. Anybody have a problem with adding that? --Ianweller 16:33, 11 November 2011 (UTC)

I had exactly the same problem (also linux) you can fix it by updating the LWJGL library. So the real bug would be: Minecraft does not ship with the latest version of LWJGL. (Tutorials/Update LWJGL) --81.210.192.14 18:13, 11 November 2011 (UTC)

I'm not sure if this is relevant to sticking keyboard keys but I have an issue with right-click sticking (causing two or three items/blocks to be placed) on Linux even with the newest LWJGL. Can someone confirm this? 213.81.127.111 20:12, 13 November 2011 (UTC)

Bounding box of wheat is too low/doesn't increase in height per state[edit source]

Might be intentional? --Diamondo25 16:35, 11 November 2011 (UTC)

May not be intentional but it sounds like something they were limited upon doing as the states are just damage value updates and prior to glass panes and iron bars being released there were absolutely no code (at least that was able to be seen for blocks) that resized bounding boxes due to the state. They were all completely static in shape. I see no reason why this couldn't be fixed now however. And yes, i am confirming this to be a bug. --Kalbintion 18:09, 11 November 2011 (UTC)
There were sloped rails. User42 18:38, 12 November 2011 (UTC)

Nothing can be placed on a Glowstone Block[edit source]

I've noticed a bug where you cannot place anything, like Doors or Torches, on Glowstone. If you had anything on it Pre5 or prior, like a door, then it will pop off when you try to open or close it, and you cannot place it back on. So far, I've tried placing Doors and Torches on it, and both will not work. I also tried Vines, and they would not go on it, but I'm not sure if they could Pre5 or prior (Tested in Single Player Creative Mode). - A-6012 16:44, 11 November 2011 (GMT)

StoneBricks breaks as fast as stone or cobblestone[edit source]

When you try to break stonebricks, its break as fast as stone or cobblestone

I think that is a feature, not a bug. --Unset 17:58, 11 November 2011 (UTC)
I think too... Ffxfan 09:23, 12 November 2011 (UTC)ffxfan

Speed breaking bug with any tools[edit source]

All tools will break blocks as fast as their material (wood, Iron, Diamond) regardless to the tool compatibility (stone blocks for pickaxe etc...) This available for wood blocks, soil blocks (dirt sand...) .

This is available on Obsidian too but only diamond tools can break it.

Can stand on Lily Pads[edit source]

In creativemode I can stand on lily pads in swamps. I havn't tested it in survivalmode or multiplayer. Pcgames3112 17:11, 11 November 2011 (UTC)

  • This is added as a feature, so no bug :) --Diamondo25 17:13, 11 November 2011 (UTC)

Unlight torches from renders may still do no lightning update[edit source]

I've searched for a stronghold, and I found a torch that didn't lit the place. --Diamondo25 17:14, 11 November 2011 (UTC)

Experience resets after killing enderdragon[edit source]

In creative mode I killed the dragon, collected xp and escaped The End. Upon coming back to Overworld my xp was gone.

You are in creative, xp is useless. Switch to survival and try it again. Ffxfan 09:25, 12 November 2011 (UTC)ffxfan
I tested this in Survival, it's true, I got to exactly level 120 from the XP the Enderdragon dropped, skipped the Credits and stuff with Esc, spawned back in my world and my XP level suddenly was 0. Waendchen 14:16, 13 November 2011 (UTC)

Magma Cubes don't have jump animation in multiplayer[edit source]

In multiplayer Magma Cubes don't show their "accordion" jump animation. Just tested and it's still in 1.9pre6. Not sure what to rank it as (minor or annoyance). KoreRekon

Enchantment in Creative[edit source]

Shouldn't you be able to enchant your tools in creative mode, regardless of your xp? I find it rather annoying. FracqGrenade | talk
contribs 17:30, 11 November 2011 (UTC)

Table bug[edit source]

if you touch table (wooden pressure plate on fence) than it activated. (sorry, my english is bad im polish)

This is not a bug. Notch has enabled this in previous version of Minecraft. (1.8 ? I don't remember...) Ffxfan 09:28, 12 November 2011 (UTC)ffxfan
Enabled? I think that was just an unintended side-effect of shrinking the bounding box on fences. Previously, you couldn't get at the pressure plate because the fence was larger than it. The pressure-plate-on-fence might be replaced by craftable tables, but in the meantime, I don't think tables are supposed to make clicking noises when you brush against them. --50.135.57.119 14:08, 13 November 2011 (UTC)

Repeaters cannot power dispensers.[edit source]

Has existed for quite a while now but after checking around the wiki etc, nowhere seems to mention this, so I probably should before release. Repeaters cannot power dispensers directly, or via a block, however if dust is used (with or without a block) the dispenser fires. -TheWyo 17:37, 11 November 2011 (UTC)

Forgot to mention, both Multiplayer and Singleplayer tested. -TheWyo 17:38, 11 November 2011 (UTC)
I have ran into this issue myself in the past, but found out that for some reason the dispenser would fire once the repeater becomes inactive (1 => 0) --Kalbintion 18:03, 11 November 2011 (UTC)

Mob spawners always show pig in multiplayer[edit source]

Any mob spawner will show a rotating pig in multiplayer, even if it is a zombie spawner, etc. Just checked with 1.9p6 and it's still there. KoreRekon

It has to be a bug, because i can remember that they used to be of the correct mob --86.52.2.125 19:52, 11 November 2011 (UTC)
I seem to remember this bug from ... way back. 1.3 perhaps? I also remember that I have never noticed it being fixed in any version. -- Zaz
Really? I remember the bug back then too, but then remember it being fixed all the way up to when Abandoned Mine Shafts and Cave Spiders were added where only the new mobs then had issues with their corresponding mini-mob image. However, it does seem the full-blown bug is back. Maybe a side-effect of them trying to fix it for the new mobs? --Kalbintion 02:42, 12 November 2011 (UTC)

Sun & Moon are Square[edit source]

Not sure if it's a bug, may be intended behaviour. SMP. 86.184.4.40 17:51, 11 November 2011 (UTC)

Not a bug, Notch abandoned the project of making the sun/moon round, due to democracy. FracqGrenade | talk
contribs 18:07, 11 November 2011 (UTC)
You can find more information about the large debate here: http://getsatisfaction.com/mojang/topics/poll_square_or_round_moon --Kalbintion 02:46, 12 November 2011 (UTC)

Bullet points are redundant before issue labels[edit source]

Bullet points are redundant before issue labels, since the issue labels themselves act like bullet points (with added information). I'm trying to remove them, but it's quite hard, as my changes keep on being rolled back. If you don't think that this is a good idea, I'll stop at once so we can discuss it. —Immute [talk] 17:46, 11 November 2011 (UTC)

Villagers have hood in texture file that does not show in game.[edit source]

librarian.png, priest.png and villager.png have hoods, but none show in game. I created a texture pack giving all of the villagers hoods and still no hoods seen in game. RobotHacker 17:52, 11 November 2011 (UTC)

Netherrack Fire Spread Bug[edit source]

I noticed someone posted a comment in regards to the bug with Netherrack with exact quotation as "[!] When burning Netherrack in fireplace, fire is spread to upper floor thru stone floor/roof and burns wooden items and bookselfs on upper floor (at least in SMP)." I can confirm that I had have had this happened to me in SSP as well. Ended up having to replace a good 27 bookshelves due to it and my hallway to my portal being directly underneath with some lit netherrack nearby but a couple blocks under. --Kalbintion 18:03, 11 November 2011 (UTC)

Credits Typo[edit source]

In the ending credits, the coloring for

§7Number crunching and statistics:
§7 Patrick Geuder

is incorrect. Patrick Geuder should be in white. (Sorry, this just bugged me. I like consistency ^^) Havokheli 18:19, 11 November 2011 (UTC)

[Edit] It's not a bug he made it so that wool/wood within 3 blocks of lava or fire will BURN HAHAHAHAHAHAHAHAA!!!! _

                         _ --_- -_--_
                          _     -    -_
                         -_   -_  -    -
                          -    -     --
                          -_     -    _-
                            ----------
Is that really necessary? I think not. It is a visual bug that anyone who's watched at least a youtube video of the end has noticed. I'm sure Jeb is aware of it now as well, and unless someone can point to a legitimate thread in regards of any reasoning behind this I personally would assume bug. --Kalbintion 02:40, 12 November 2011 (UTC)

Harvesting placed Rails with water[edit source]

Under most circumstances water can be used to pick up items that have been placed on the ground, such as torches and rails. When water runs over a rail placed on a slope, though, the rails disappear. (On SSP for sure, have not tested SMP) --JeSuisNerd 18:21, 11 November 2011 (UTC)

Slimes and Magma Cubes postion glitch in multiplayer[edit source]

Often Slimes and Magma Cubes aren't located where they're shown, so you can't hit them. Sometimes this causes a graphical glitch where the "jump" up and down rapidly. Only in multiplayer. Seems to happen when they jump up a block, or attempt to jump up two blocks. KoreRekon

+1, I've seen this problem at least since pre5 if not earlier. Very annoying, especially since slimes are more common now. --174.253.6.217 19:45, 11 November 2011 (UTC)

  • definitely since pre5; got a new world where slimes are everywhere it seems. they can also push you around from 1 or 2 levels below you, and they are stronger than you, so they can manage to trap you (i have no previous exp with slimes so don't know whether that is standard behaviour). you can also not destroy any blocks through which they seem to be popping up (i presume that's because they're occupying that block for very short periods of time). in several instances i went looking for them and found them under stairs, and once in a closed-off space. Piranha
  • This bug has existed since slimes in SMP have existed... Not saying this isn't a valid bug report, but 'since pre5' is a tad redundant when you can see it on current 1.8.1 servers. -175.38.196.137 22:39, 13 November 2011 (UTC)

Critical Bugs[edit source]

I think there should be some rebranding. What is more critical? Setting inventory to the scroll button causing a crash, or the fact that wooden doors CANNOT be opened without redstone. Yes, i know, pressure plates can be used, but thats a faf. You see creeper outside, and go near the door to look, and the door opens, and BOOM! But seriously, who has their inventory as the scroll button anyways? --Joeldamole789 18:41, 11 November 2011 (UTC)

Actually, it's not a bad idea. I certainly don't use the scroll button for its original "pick block" purpose, and upon opening the inventory, you have to use the mouse, so assigning a mouse button to the task sort of makes sense. Euridicus 09:21, 12 November 2011 (UTC)

Ice/snow layers[edit source]

In snowy biomes, instead of a ice layer on top of water ice blocks generate. Also, snow layers still seem to be glitchy. example picture

I can confirm the snow generation bug and had some interesting falls into a ravine, as for the ice thing, no idea what he's talking about, whoever he may be --Kalbintion 02:47, 12 November 2011 (UTC)
Lakes in snow biomes are generated without ice, and then freeze. Oceans generate with a layer of ice, and do not need to freeze until it is broken. User42 18:28, 12 November 2011 (UTC)

Screenshoting bug[edit source]

Try to save screenshot (f2) in windowed mode, then switch to full screen (f11) and save screenshot again. I take this: http://dl.dropbox.com/u/14150510/2011-11-11_22.39.01.png

experience "cloud" after killing the dragon[edit source]

There used to be a bug that when you die, excessive amounts of experience float around. It's like that with the dragon in multiplayer, but afaict it does not stop. I walked around with a screen full of blobs until I jumped in the portal. I know it drops quite a bit experience, but this really looks like a bug. 77.164.81.181 19:31, 11 November 2011 (UTC)

Dragon does not deal damage in multiplayer[edit source]

Sometimes it flies straight at you, and when I don't hit it, it just flies straight through me. 77.164.81.181 19:35, 11 November 2011 (UTC)

Melon are not mined as fast with an axe as pumpkins.[edit source]

Both melons and pumpkins can be mined at the same speed with a pickaxe, but pumpkins are mined faster than melons with an axe.

Cloud setting in Video Settings changes when switching through GUI Scale settings[edit source]

If you switch through the GUI Scale settings : "Small, Normal, Large, Auto" some times the Cloud setting changes from On to Off and so on, quite funny actually. Please try and confirm, thanks. [2011-11-11]

  • Confirmed, but only while game window is maximized KoreRekon

Cocoa beans can no longer be planted on tilled soil.[edit source]

--66.133.216.4

They never were plantable, facedesk. Calinou - talk × contribs » 20:51, 11 November 2011 (UTC)

Rain makes no sound and a problem with bed[edit source]

Silent rain and when I try to sleep, a message appears: "You may not rest now, there are monsters nearby" ChakAttack 21:04, 11 November 2011 (UTC)

  • That's the new bed functionality. Now you can't go to sleep if monsters are nearby, and you will no longer get woken up with a monster near you. KoreRekon

Ok, the rain is silent when Particles is set to Minimal, just found out. ChakAttack 15:28, 12 November 2011 (UTC)

  • thanks for figuring that out; i consider that a feature for now since the rain is a major annoyance for me, being so loud and lasting so long. Piranha 11:13, 13 November 2011 (UTC)

Ocean floor and swamps terrain generation in MP[edit source]

Maps generated in MP have some weird looking underwater terrain pattern... In SP everything is fine (tested on 5 maps), but MP maps have underwater terrain as "stripes", looks like some pattern misalignment... 217.26.18.6 21:29, 11 November 2011 (UTC)

  • I can't add links here, so here it is, just add missing dot: twitpic com/7d6opx and twitpic com/7d6otp
  • Can someone confirm this and add to the Bug list with links?.. I think this is a major issue, because fixing this means altering world generation code and may break map compatibility between versions (again)... 217.26.18.6 12:32, 13 November 2011 (UTC)

Command+Q doesn't quit the game on OS X[edit source]

This problem is probably more to do with the launcher than the actual JAR file, but this bug drives me crazy and it seems like it should be working in a 1.0 game. Thoughts? 69.163.243.45 21:36, 11 November 2011 (UTC)

Can't place torches?[edit source]

I have noticed the in the version history for pre-release 6 that it is stated you can't place torches, levers or glowstone. I have no problem at all placing these items on blocks, walls or ground. --Throex TALK|CONT 22:31, 11 November 2011 (UTC)

It says, that you can't place torches, levers, etc on glowstone anymore. --Gitterrost4 22:34, 11 November 2011 (UTC)


Ahh, selective reading in its prime example. haha --Throex TALK|CONT 22:36, 11 November 2011 (UTC)

Trapdoor & Dispenser bugs[edit source]

pre6 contains at least two trapdoor bugs:

- By placing redstone near (above or below) a trapdoor it opens (and some of the trapdoor arounding it) [3] [The video is from pre5, but it still works in pre6]

- (As already mentioned) two or more redstone together in a row can't be opened. If you open the left one, then click on the right one, the left one closes [4]


Additional the bug I posted from pre5 still persists;

Dispensers fire (when powered) everytime you place a redstone within a 7x7 area with the corners cut out. YouTube Video: [5]


Create Lag using lava/water smoke[edit source]

youtube.com/watch?v=KKeoJkct_EQ

Enough of these can auctally cause lag for the server. I think on a high speed, 5 can lag up a home run server.

Can't hit Bottom Part of a Blaze in SMP (but in SSP) with Swords/Pickaxes/whatever....[edit source]

It seems that you can't hit the Bottom Part of a Blaze in SMP with something like a Sword if you are one Block away but in SSP you can (difficulty doesn't matter)... Is this a Bug or a Feature? Here a Video so you can understand what i mean: http://www.youtube.com/watch?v=PEz1b-Agetc
MfG --Bluemond 02:16, 12 November 2011 (UTC)

Thats not only for blazes, but all mobs. I say to report it on the know bugs page!

Doors and Trapdoors can't keep up with a 1-clock[edit source]

When I attach a piston to a 1-clock, it will extend and retract quickly. When I attach a door or a trapdoor, I can hear the sound of it opening and closing, but visually it doesn't change. Bug?

If the problem is what i think it is, the 1-clock is every single frame. Well, it gets power, the next frame its to show open, but wait it goes back off, and the visual update is rendered useless (whether or not it re-renders as closed as it is already closed is another problem in its own), would be interesting to know if this happens where the door stays open visually if you have it open on default. May not be a bug with this information that i'm thinking of but a side effect of having game frames and not true real-time --Kalbintion 02:38, 12 November 2011 (UTC)
Thus, we can see the piston extending and retracting on a 1-clock cycle, because it has a continuous animation, but we can't see the door or trapdoor open and close because they have no animation, only a state? --Munin295 04:38, 12 November 2011 (UTC)
I would bet my money on that. If you pay attention close enough to the piston animation on a 1-clock it actually doesn't want to do the animation (as on some computer set-ups you will see some clipping and it isn't from lag) but does because it was told to. Minor programming quirk in terms of how the animation was done for the piston in this case compared to say, the door. --Kalbintion 08:50, 12 November 2011 (UTC)

Items Disappearing[edit source]

Whenever I die and close the game, regardless of if I respawned before closing or not, all the items I dropped disappear.

I'm not sure if I described that properly, but it's more than a little bit annoying when I'm carrying around loot after a mining trip and die, just for my inventory's contents to vanish entirely. --50.98.131.131 03:25, 12 November 2011 (UTC)

Someone correct me if im mistaken, but hasn't this been happening since like beta 1.2 if not prior? And was it ever brought up in the past as a bug? Because as far as i know, there is no way for the game, up until recently, that really saved all entities. As for you loosing items due to a world reload for 1.9pre6 I haven't ran into such a problem myself as I have done that a few times due to rage clicking and ending up going to save and quit when i end up dieing, but i do return to see them still there. --Kalbintion 08:45, 12 November 2011 (UTC)

I can't download 1.9pre6.[edit source]

Can someone show me how? --Kwoon1000

Try: http://twitter.com/#!/jeb_/status/135018767620112385
 : :S A R A T J E : :Diamondapple.png  : :T A L K :|: C O N T R I B U T I O N S

Redstone bug[edit source]

If a block is receiving power from a redstone torch below it, it doesn't transfer the power to adjacent pistons. this worked in 1.9 pre 4 and 5 but not in 1.9 pre 6 HelluvaRoman 05:25, 12 November 2011 (UTC)

small graphical Lilly pad bug[edit source]

if you go in third person and hold a lilly pad, its white same thing happends on multiplayer if someone see you hold one.

Kippykip

This doesnt surprise me at all, and i have seen it happen before visually. Lily pads typically get their colour from the code, just as grass changes itself too, and now swamp water. You holding it doesnt know where to get its colour information from, and thus remains what the image looks like in the file: a partly alpha'ed pixel square for the lily pad that is then masked with colour in-game with code. (Just how redstone works for the state colour redness) --Kalbintion 08:48, 12 November 2011 (UTC)

Multiple enderdragons[edit source]

Not sure if this is a bug or not. I remember Notch stating that there would only be one enderdragon per End?

This happened when I fell off the edge of the map in the End the first time, respawned in the Overworld, and went back to the End. I was on creative mode.

See http://imageshack.us/photo/my-images/40/20111111224136.png/ for screenshot Deathgleaner 06:47, 12 November 2011 (UTC)

Ender Crystals + Water = Flickering loop[edit source]

This could probably be under Annoyances, but I'm not sure: "Placing water above one using a Bucket will cause a looping effect, whereas the fire is continuously put out and reinitialized as the water attempts to flow down and is stopped. The water will not spread, as it can flow downward, but is being prevented by the reoccurring fire instantly taking its place." ~What I put on the Ender Crystal page. Might be nice to prevent this somehow, I do notice that annoying earbud static flickers as the fire does, so it's doing something. Anyone want to add this in the appropriate fashion? MegaScience 09:22, 12 November 2011 (UTC)

Skeletons don't make noise shooting arrows in multiplayer[edit source]

This has always been the case, but it should be added to the main bug page to remind Notch or Jeb to fix it for the full release. Euridicus 09:26, 12 November 2011 (UTC)

This bug is my number one gripe with multiplayer. It's technically covered in the multiplayer section, but I added it for emphasis, because it disrupts gameplay much more than the other missing effects. LTK 70 23:29, 12 November 2011 (UTC)

Stronghold Silverfish Blocks Easy To Identify[edit source]

With a normal, not-enchanted diamond pickaxe, it takes just a couple seconds to remove any of the stronghold stone blocks (cracked, mossy, etc). However, the blocks that house a silverfish did not get adjusted. They now take about twice as much time to harvest as the non-silverfish stronghold blocks do. So, you can fairly easily tell that there's going to be a silverfish popping out of the block you were about to cut, and stop chopping in time to not trigger it. Sort of takes the shock value out of silverfish. --R b bergstrom 09:58, 12 November 2011 (UTC)

this is not a bug, this was always like that and is supposed to be like this.

Experience Payout on Blazes May Be Too High[edit source]

I'm not 100% certain this is a bug, they may have just chosen to make Blazes be worth more Experience than they were. It is now super easy to rack up XP by drinking a potion of fire resistance and camping out at a Blaze spawner. The wiki indicates that a blaze is worth double the XP of a creeper, but it seems to be rather more than that. You can go from level 0 to level 15 or so in the duration of a single fire resistance potion without any danger.

Even at a rather high level of XP, it was only taking about 4 blazes to go up a whole level. From level 18 to 19, for example, I'm absolutely certain took me just a tiny fraction more than 4 blazes (killed 5, leveled up and got about a quarter of the way to the next level). According to the math on the Experience page, it should take 133 XP to go from level 18 to 19, which should be over 13 blazes, not a mere 4 or 5. --R b bergstrom 09:58, 12 November 2011 (UTC)

Wooden Door Noise Problem[edit source]

In addition to needing a button, lever, redstone, etc to open a wooden door, the door sound seems to be changed. It's not entirely consistent, but on my mac in survival single player, the wooden door sounds are sometimes odd. Higher pitched, and sounding almost like they're being played backwards. It's a very odd sound. It's not happening consistently on all my doors, and may be different between pressure-plate-activated vs button-activated doors. --R b bergstrom 09:58, 12 November 2011 (UTC)

When you open a door, it will be closed directly afterwards, this will result in 2 door sounds at about the same time. If those sounds are the same, you will get a Flanger[6] effect.
Unset 10:27, 13 November 2011 (UTC)

Nether Flickering[edit source]

The far foggy reaches of the nether sometimes flicker obnoxiously. It was one particular visit to the nether that I made today. For the duration of that one visit, anywhere that was far enough away to have the fog effect would pulse and flicker. Visually, it was a little bit like the bug there used to be when you'd swimming towards the horizon, and the horizon would pulse as you went up and down. The flicker today seemed to be linked to my movement. It flickered less often if I stood and looked around then if I was wandering all over the nether. --R b bergstrom 10:03, 12 November 2011 (UTC)

Minecraft_server.jar resource distribution[edit source]

[A] Minecraft_server.jar needs to be multi-threading to offer better performance for multi-core servers. A server.properties configuration setting the amount of threads to create in a thread pool used by the server would be really nice, too; so minecraft_server doesn't eat up resources on all cores when server admin feels there's need for other things to co-exist. Chiisana

This is a feature request, not a bug --86.52.2.125 19:54, 11 November 2011 (UTC)
Discussion should probably be done on the discussion page or my user talk page instead. Please cut and paste this stream there if you would like to further discuss on this topic :) This is a bug if they want a proper functional SMP server for launch. Chiisana 02:53, 12 November 2011 (UTC)
Yes but with that kind of arguments anything can be a bug. It doesn't mean I wouln't love to see something like that in the future. But I'm pretty sure Jeb is gonna agree with me that this page should only be for "real" bugs. --86.52.2.125 11:54, 12 November 2011 (UTC)
I understand the reasoning behind that "anything can be a bug" from this perspective, but the reason this was regarded as an 'annoyance' on the bug report for me is that optimization is usually done prior to release. And making sure that their server application is capable of handling resource more effectively to scale is a valid claim, IMO, where as "I'm annoyed by the fact that we don't want Enderman on our server and cannot do that" is not. Under that reasoning, I think this is something Jeb_ and Notch would consider as a to-do item. Chiisana 04:05, 13 November 2011 (UTC)
On windows you can set affinity on task manager, if you dont want minecraft server to hog all processing power. "javaw.exe" is process wich contains minecraft server, remember that minecraft client also runs in "javaw.exe" (wich is separate from server in process list, least on my system.). --93.106.77.77 11:04, 12 November 2011 (UTC)
Windows, by default, consumes fair amount of resources, so most people who are anal about performance, such as myself, would not even consider it to run the server. While we are able to leverage things such as schedutils/taskset to set affinity on linux (and maybe GCD will do it automatically on OS X/BSD), it doesn't address the problem that the server application should make use of multi-threading/multi-core better to handle more concurrency. Especially for softwares heading for a 'gold' release. Chiisana 04:05, 13 November 2011 (UTC)
Don't throw the OS card here - if you run your Windows properly, performance is not an issue; I care about my systems' performance, and running an MC server, client, alongside several other servers such as Teamspeak while watching YouTube videos and talking to people on MSN/Skype is not an issue for me (and no, I don't have a supercomputer or a T3 connection, I have an average system that any Windows user would have). Back on the subject, though; multithreading, is almost a requirement, however it's moreso dependent on how Java handles threading in general. If you were really anal about performance, going against running a game that uses the Java Virtual Machine should be your first priority, and trying to get them to port it to a lower level language like C/C++ which would yield exponential improvements in.. well, everything. Paril 17:04, 15 November 2011 (UTC)
It's not really an OS card, but merely fact. Windows Kernel by itself consumes much more resources than a Linux Kernel. Furthermore, the desktop environment most Windows users use to invoke client (most; since there are ways to wrap mcserver into a service and does not require interactive login) occupies more system resources than that of the command line console most non-Windows users use (most; since there are always people using desktop managers over VNC, or otherwise). Take the exact same machine, with exact same configurations, without any applications running, Windows will outright consume more resources. This means at the end of the day, Windows-based system -- because of the resource consumption -- will pretty much by definition not able to host as much concurrent connection as it's counter parts. There is a drastic difference between "can run it" and "can run it at its fullest potentials." Anyways, that is completely off topic and irrelevant. Getting them to re-code the server in a different language days before launch (not to mention compile against different OS's) is not a viable solution. Optimizing their code is, and that is the point of this bug entry.

Fire Aspect working on players on pvp disabled[edit source]

Hello. I've accidentaly found a bug with fire aspect. When you're hit by a different player using a sword with that enchant you'll get on fire. --Erudax.

And how is that a bug? Why shouldn't the enchantment work on other players? --Gitterrost4 12:23, 12 November 2011 (UTC)
Oh, you mean with PvP disabled. Sorry --Gitterrost4 12:24, 12 November 2011 (UTC)

Pie Chart and FPS-Display[edit source]

Someone stated the "bug" on the 1.9pre5 Bug list, that the pie chart takes up too much ressources. This was dismissed by Jeb saying it was a debug screen. But since the chart takes up so much ressources, the FPS-display is useless since you will always have a higher FPS when not displaying the debug screen. I don't know, if it should be a bug or rather a feature request, but a seperate FPS-display would be nice. --Gitterrost4 12:34, 12 November 2011 (UTC)

If the deflection off the true FPS due to the pie chart is the same for everyone, this doesn't really matter, does it? LTK 70 23:23, 12 November 2011 (UTC)
I am going to start by saying I'm on the fence on this one. On one hand, it may be a debug screen and will be disabled unless invoked by some command line argument at launch time, so it doesn't matter, and is irrelevant. On the other hand, it may be some times useful to know the basic information (X,Z) coordinates, for example, is useful for building with precision on large scale buildings, and should not slow down the game because of some fancy pie chart. I think what they should consider is to make the pie chart a separate debug screen, bound with a different invokation key. That way, for creative mode (or other legitimate use) people can still invoke the coordinates and FPS without experiencing drastic lag; and those that are interested to see where the bottlenecks are happening can also check into it in detail. Chiisana 04:10, 13 November 2011 (UTC)

Can we PLEASE, for the love of all that is good and holy, have a way to look at our coordinates without half of the screen being clogged up with graphs and charts that nobody cares about? 75.61.81.249 15:20, 13 November 2011 (UTC)

I have to agree on this whole thing - the pie chart does indeed eat up quite a fair amount of resources for no apparent reason. Benchmarking is supposed to be done while running under the same circumstances as normal - it's tough to benchmark a game when you have factors such as this. There should be multiple levels of the debug screen, not a "shove everything possible on the screen at once" mode.

Boosters are back, baby.[edit source]

As sethbling discovered, minecart boosters work again. Bug or "new" feature? --GALAKTOS 12:58, 12 November 2011 (UTC)

  • "Hilarious and wrong at the same time" (Source) so it is a bug --GALAKTOS 13:00, 12 November 2011 (UTC)

Main Menu Shading / Blurring Glitch[edit source]

Main Menu - Shading Glitch

If you move the Minecraft window below the task bar (tested in XP) the the background image of the main menu gets distorted (well the effect overlay anyway). It seems to be using the "visible height" of the window to perform the effect.


--Eddebaby 13:04, 12 November 2011 (UTC)


  • It also happens if you go off the left-hand side, but not the right-hand side of the screen. Eddebaby 13:22, 12 November 2011 (UTC)
I can not confirm this (tested in XP) but I found an other way to create the same effect. Change the window size and make it only a few pixels high. --Mrheat 21:28, 12 November 2011 (UTC)
Moving below the task bar seems to be no problem on windows 7, but resizing the window to very small height or width does still create the effect. Looks funny :) GALAKTOS 10:01, 13 November 2011 (UTC)
I've added another screenshot showing this glitch occurring at strange resolutions. AGS Phoenix 03:33, 4 January 2012 (UTC)
Menu glitch at unusual resolutions.png

Spiking and short Sound/Graphical Lag at certain boundaries[edit source]

There appear to be certain invisible boundaries that induce between 2 and 10 seconds of extreme stuttering in sound and FPS.

An example can be seen here although I had problems showing this for the Pre 5 bug list.

Can someone else verify if they've experienced this also? --MKUltra 13:05, 12 November 2011 (UTC)

I can confirm this bug, lag spike on leaving an area but not entering it. First happened to me in I think pre2 or 3 although my friend experiences less severe spike of a similar nature in 1.8.1 (may be a different cause). I think it magnifies the lag already in certain chunks as when I killed all entities inside the afflicted chunk the lag spike reduced significantly (it was previously a farm). This bug may originate due to minecraft crashes as the chunks I've noticed this in are the ones I've been in when minecraft has crashed in the past, but not all chunks where I've had crashes are affected, just two or three. I've tried repairing the regions with MCEdit without any improvement. Also cutting and pasting the chunks into a brand new world with a different seed retains the spike behavior.
The border of the affected area seems to align with a chunk boundary but since the lag spike begins before you cross the border and continues for some time after it is difficult to determine the exact position of the lag spike area. Streborsirk 14:25, 12 November 2011 (UTC)
Thanks for confirmation, I'll try and add this to the main list of bugs. --MKUltra 16:25, 12 November 2011 (UTC)

Riding my boat into a pig caused me to die instantly[edit source]

My boat survived

As per title.

This actually happened in pre5 (as I had reverted back today) - but I have subsequently been unable to replicate in either pre5 or pre6. My boat and some of my stuff was still at the scene of the crime, after quitting out and switching to pre6.

--Eddebaby 13:11, 12 November 2011 (UTC)

Happened to me as well, long before 1.8 even. Made boating with a pack of wolves quite perilous. One would teleport in front of my boat and kill me instantly. LTK 70 17:33, 12 November 2011 (UTC)

Look at the bug list for pre5. Maybe related to Jeb fixing a bug where crashing a boat made you take fall damage. Jmaasing 23:58, 12 November 2011 (UTC)

Boats collides with Lily pad[edit source]

Now Lily pads are walkable. And boats collides with them, making swimming in swamp biomes dangerous and sometimes impossible. — MiiNiPaaT|C 13:29, 12 November 2011 (UTC)

Can't interact with minecarts on booster slope in MP[edit source]

If you drive in a minecart at full speed and then stop on a booster rail slope, you can't interact with the minecart - meaning that you can neither leave nor destroy it. This only happens on multiplayer and it is not restricted to any OS (a friend who uses Linux has the same problem).

Look at this image: http://imgur.com/MiHAI <- This is how I build launchers. You sit in the cart, press a button and off you go. I also put this at the end of my tracks to be able to go back on the same track - that's why I discovered this. Of course, this won't happen on normal rails, because you roll back.

I think this is a bug (maybe a major one, but I'm unsure), but it definitely is an annoyance. You can still get out of the minecart by leaving and rejoining the server.

Suchtie 13:31, 12 November 2011 (UTC)

Black and white flickering on mobs, players, chests[edit source]

All mobs including sheep are flickering black during day...
...and white at night

For me this is by far the most annoying bug. All mobs are constantly flickering black during day and white at night. It looks like lightning going crazy, switching between minimum and maximum light level each frame. I don't know why this bug was removed from the bug list. I know it's not easy to reproduce. But it's there. It was confirmed by multiple people.

  • All versions since 1.8 had this bug. There was no problem in 1.7 and earlier. (Confirmed by other people.)
  • The flickering changes when I move the camera. It's bad in the corners of the screen but not so bad in the middle.
  • Sometimes the flickering goes away after some minutes. But it's back every time the game is started.
  • Maybe it's some kind of Z-fighting due to multi-texturing introduced in 1.8?
  • My machine is Windows XP, Java 1.6.0_24-b07 (32 bit), Radeon X1650 Series. (Confirmed by other people.) The ATI graphics drivers are version 8.432.0.0 from 2007. I know this is a bit outdated. But I don't want to change a running system. No other game has a similar problem.
  • 1.9pre5 1.0RC2, creative mode, single player.
  • Advanced OpenGL is on (it helps a lot on this machine, without it's almost not playable).

--Mrheat 21:21, 12 November 2011 (UTC)

New Bug-Can't pick up cow's Meat[edit source]

I can't seem to pick up any meat the cows drop on pre release 6. Never used to be a problem and chickens still work, not sure about pigs. Also not sure if it's also on multiplayer but it is on single player.

  • Are you sure your inventory isn't full? 186.204.105.168 17:28, 12 November 2011 (UTC)
Cannot reproduce, tested in creative as well as survival.LTK 70 17:32, 12 November 2011 (UTC)
Ditto --Kalbintion 09:30, 13 November 2011 (UTC)

Linux texture errors[edit source]

[!] Linux Linux Texture Errors Extremely annoying texture errors under Linux:

The error completely vanishes after taking the screenshot with the ingame feature, but comes back after ~10 seconds. View distance has no influence, updating LWJGL doesn't help as well. The error even occurs on the tool or your hand. The color of the flickering is always the color of the next visible thing behind it that emits light. This means in most cases you can see the skybox in blue or black (depends time of day), but also lava, glowstone and torches can be seen through corrupted textures.

Contact me on twitter (@the0jj) if you want further testing.

System specs:

OS: Linux (amd64) version 3.1.0-4-ARCH
Java: 1.6.0_22, Sun Microsystems Inc.
VM: OpenJDK 64-Bit Server VM (mixed mode), Sun Microsystems Inc.
LWJGL: 2.8.1
OpenGL: Mesa DRI Intel(R) Sandybridge Mobile  version 2.1 Mesa 7.11, Tungsten Graphics, Inc
OpenGL Version: 2.1
Do you have "Advanced OpenGL" on? User42 18:14, 12 November 2011 (UTC)

I'm having the same issue. I thought it was an Intel Graphics problem, but my new laptop with AMD Radeon Mobility shows the same problems. Switching the Advanced OpenGL option has no effect, possibly because I don't have advanced OpenGL libraries installed (yet). My system specs:

OS: Linux version 3.0.0-12-generic (buildd@crested) (gcc version 4.6.1 (Ubuntu/Linaro 4.6.1-9ubuntu3) ) #20-Ubuntu
Java: java version "1.6.0_23"
  OpenJDK Runtime Environment (IcedTea6 1.11pre) (6b23~pre11-0ubuntu1.11.10)
  OpenJDK 64-Bit Server VM (build 20.0-b11, mixed mode)
LWJGL: not installed.
OpenGL: nothing additional installed, default Kubuntu 11.10 graphics.

Screens:

I am currently downloading the latest OpenGL drivers for my video system. I'll post new info as available. Alderin 23:40, 3 January 2012 (UTC)

That was much less than fun. The ATI driver from ATI's website somehow disabled my ability to log into KDE. I was able to log in to the command line where I installed Gnome for a desktop, but now after logging into Minecraft I get a black screen, the error points to the video system, so more work is needed before I get back to normal function before I can see if the driver fixes the texture errors. Alderin 01:27, 8 January 2012 (UTC)

Nether portals warps to the same location[edit source]

When I create a first portal to the nether, and going out from the same I think the game is locking this location for other portals, in the overworld I walk miles away from the first and create another, when entering, I spawn at the same location of the other one, and when going out, spawn in the first in the overworld. It's been a while sine I noticed this. Luschinfloggen 17:13, 12 November 2011 (UTC)

This is intended behavior. When going from the Overworld to the Nether, the game will always look for an existing portal. When going from the Nether to the Overworld, it only looks for an existing portal within a certain range, and if there is no portal, it creates a new one. LTK 70 17:18, 12 November 2011 (UTC)

Completing the game in Creative Mode[edit source]

I've just had a quick look at the game's ending by using Creative Mode, and it struck me that a new player might do the same. Watching the end credits after shooting the enderdragon for a bit, while being invincible, sort of cheapens the sense of achievement, because the game implicitly assumes you've done the cycle overworld-nether-overworld-stronghold-end in order to reach the ending. So I'd like to suggest removing the enderdragon for creative mode, so that you only get the true ending from survival mode or better. This would be filed under The End - Annoyances. Thoughts? LTK 70 17:23, 12 November 2011 (UTC)

Suggestion: Just don't roll the end-game dialogue in creative mode. The credits could still be shown. User42 18:09, 12 November 2011 (UTC)
That's a better idea. I added it to the bugs list. LTK 70 22:38, 12 November 2011 (UTC)
Or if someone really wanted to they could just find the resource in the jar file containing the end-game dialogue and bypass the enderdragon completely, and if they wanted a full sense of what it looked like, they could mod the game to go directly to the end-game credits upon start-up... assuming they knew something about programming anyway... --Kalbintion 09:33, 13 November 2011 (UTC)

Colliding with water (or lava?) doesn't stop you from sprinting.[edit source]

Methods to reproduce:

Sprint into a body of water. No FOV change occurs. Release W or exit water. Notice FOV change when colliding with shore.
Standing on the bottom of a body of water at least one block deep, double tap W. Notice FOV change.
Place water on a flat surface so you can exit without colliding with the side of a block. Sprint into water, turn around, exit water. Notice that you are still sprinting.

User42 18:04, 12 November 2011 (UTC)

Is there a reason this behavior should be changed? LTK 70 22:29, 12 November 2011 (UTC)
I think this makes sense, and is useful to all players which are annoyed by the small moving speed in water GALAKTOS 10:04, 13 November 2011 (UTC)

Spawn in lava.[edit source]

I Spawned in lava when I created normal mode survival single player map. seed 3957282054334031006

Interesting, but I can't reproduce. Are you sure that's the right seed and you were running 1.9-6? User42 18:57, 12 November 2011 (UTC)
It does work, I have done it. Minecraft Beta 1.9 prerelease 6 with the above seed.--Enderdude EndermanFace.png (TC) 19:03, 12 November 2011 (UTC)
Actually it was a bit above some lava, but still.--Enderdude EndermanFace.png (TC) 19:04, 12 November 2011 (UTC)
I was able to reproduce it on another computer. User42 22:11, 12 November 2011 (UTC)
You can spawn at different locations with the same seed. You shouldn't be able to spawn in the air though. -Fexlom
I can confirm this. I tried the seed and spawned in lava. --Mrheat 21:11, 12 November 2011 (UTC)

Go to End on Peaceful, switch, no Enderdragon[edit source]

I wanted to go to The End when I forgot when I was on Peaceful, so then I switched, the Endermen spawned, but not the Enderdragon. The blocks in the boss battle also generated.

Repeaters still get jammed when reloading world/chunk[edit source]

Repeaters still randomly get jammed when the world is reloaded causing repeater clocks to stop working. (Video on youtube)[1] --Jigarbov

For some reason I can't add it to the main bug page... So I am discussing it here so someone can.

Won't generate world.[edit source]

While creating a world I put "Till The End..." (with out the apostropes) in the title. Minecraft froze and crashed after I pressed create. When I tried the same title without the periods at the end, the world loaded just fine.

I can confirm this.

java.io.FileNotFoundException: C:\<...>\.minecraft\saves\Till The End...\session.lock
        at java.io.FileOutputStream.open(Native Method)
        at java.io.FileOutputStream.<init>(Unknown Source)
        at java.io.FileOutputStream.<init>(Unknown Source)
        at du.e(SourceFile:44)
        at du.<init>(SourceFile:38)
        at aak.<init>(SourceFile:18)
        at fa.a(SourceFile:77)
        at net.minecraft.client.Minecraft.a(SourceFile:1632)
        at vb.a(SourceFile:158)
        at tq.a(SourceFile:72)
        at vb.a(SourceFile:216)
        at tq.f(SourceFile:120)
        at tq.i(SourceFile:108)
        at net.minecraft.client.Minecraft.k(SourceFile:1353)
        at net.minecraft.client.Minecraft.x(SourceFile:696)
        at net.minecraft.client.Minecraft.run(SourceFile:649)
        at java.lang.Thread.run(Unknown Source)

On the hard disk a folder named "Till The End" was created, without the periods. That's why "Till The End..." can not be found. --Mrheat 21:16, 12 November 2011 (UTC)

Windows normally does not allow file names to end with a period or space. It can be worked around, it seems, so Mojang needs to implement a fix. --Chungy 22:22, 12 November 2011 (UTC)

Endermen and spiders colored white from a distance[edit source]

When seen from a distance, endermen and spiders are colored white. This doesn't seem to happen with any other mobs. Does this happen to anyone else?

Like my black and white flickering mobs above? Please tell us what Graphics card you are using. --Mrheat 21:18, 12 November 2011 (UTC)
I'm pretty sure this is caused by using a texture pack that uses outdated textures for endermen and spiders. The way the glowing eyes are drawn on both mobs has changed. You need to use a newer version of the texture pack where this is fixed. LTK 70 22:28, 12 November 2011 (UTC)
Here's a screenshot: i.imgur.com/SXLtb.png (this wiki won't let me make an external link for some reason). I'm using the default texture pack.

Multiplayer fence bug[edit source]

It's that when you try to place a fence on the side of fence that did not connect to the block next to it, the fence you just placed will take the place of the block(like stair). p.s.:It only do that in SMP. Leafgreen1 22:34, 12 November 2011 (UTC)

Using pressure plate + fence as an actual table[edit source]

There's an annoyance I'd like to add to the bug list (under blocks, annoyances): When villages were added, you could put pressure plates on fences to make something that looks like a table. But they still work like a pressure plate and a fence; you can neither stand directly on top of it, and the pressure plate still activates when you walk against it. It really needs to be a single block so you can place torches and cakes and the like on top of it. This should be easy with the same method that attaches a single slab to another single slab to make a double slab. Does anyone agree? LTK 70 22:59, 12 November 2011 (UTC)

Chest texturing issue[edit source]

So, this isn't really that critical, but because chests are smaller now, there's a 1 pixel overlap between the texture for the front of the chest, and the texture for the front of the lid. It's completely unnoticeable on the default texture pack, as that row of pixels is identical, but if you use a texture pack where that line doesn't match, you can get this really annoying flickering of the overlapping textures. I think it was called z fighting. I haven't seen the flickering on anything else, just the chests(both big and small), so I don't think it's a graphics card thing. Obviously, you could fix a texture pack to get around this issue, but... --71.139.182.149 23:11, 12 November 2011 (UTC)

Yes, it is indeed z-fighting. I thought this was only an issue with higher resolution texture packs, but if it happens on default resolution as well, it should be listed as a bug. LTK 70 23:17, 12 November 2011 (UTC)

It is visible a bit on default pack, and very visible on some packs (used to be very visible on Misa pack, as an example). It is called z-fighting, yes. Calinou - talk × contribs » 23:31, 12 November 2011 (UTC)

References[edit source]

Muliple records playing.[edit source]

I place two jukeboxes far away from each other. I put a record in one. The I go put a record in the second one and the first one stops. Thats not the main problem. When I broke the first jukebox the second one stopped playing it's music. Same happens when I take the record out of one of the jukeboxes.(The oppisite one stops playing music.)98.239.49.201 01:14, 13 November 2011 (UTC)

Unusually high GPU usage and temps at main menu 1.8-1.9[edit source]

Allowing the game sit at the main menu caused GPU usage to rise from 1-5% to 50-75% usage (Nvidia GTS 250 1GB) and temps to rise from 55*C to 68*C. (By contrast, 1.7 at the main menu only 1% usage, and while playing the game on any versions on Single or Multiplayer show 15-25% usage.)

  • Main menu does not limit the framerate... FPS goes above 300... Just because Main Menu does not use much CPU, GPU has to process as much FPS as CPU can send to it, and it can send a lot...

boat is broken more easily[edit source]

I was making eats road in 1.9pre5 and when I changed to 1.9pre6 boat was broken on both right and left turns. I think boat became even more fragile. boat should be stronger.


Pumpkin appears to never grow[edit source]

been several (Minecraft) days now and I've wasted hundreds of bone meal on the vines, trying to grow them (They're stuck last vine before pumpkin). Please confirm. Note: Unsure about melons.


  • Pumpkins grow just fine for me. Using bone meal on the vine has never produced pumpkins, it only grows the vine to the final stage. Not a bug. Jmaasing 23:36, 12 November 2011 (UTC)
  • Yes, one of vines suddenly became a pumpkin. Took about 15-16 Minecraft days. I just though that very long.
  • Takes a while, bone meal wont produce a pumpkin, i suggest reading a bit more about pumpkin's on their own wiki page, as it clearly states bonemeal wont make a pumpkin grow and that it may take some time for one to grow. --Kalbintion 09:38, 13 November 2011 (UTC)

Circles in Minecraft[edit source]

Dropped items and mobs shadows are circles. WHY???

By tha way, achievements and stats are still removed when minecraft crashes.

Remaining block picking bugs[edit source]

After testing, I saw that the problem with differing damage values was fixed... mostly. It looks like it trips up on a couple of things due to extra bits used for growth and flags. The other two bugs remain as-is (are?).

  1. It chokes up on correctly identifying these blocks by damage value
    • Leaves
    • Saplings
  2. It does not select items that are placed as blocks
    • Sugar Canes
    • Redstone Repeaters
    • Cake
    • Signs (from both wall signs and signposts)
    • Brewing Stands
    • Iron Doors
    • Wooden Doors
    • Beds
    • Cauldrons
    • Redstone Dust (Would be understandable if it didn't)
    • Nether Wart
    • Seeds (Would be understandable if it didn't)
    • Melon Seeds (Would be understandable if it didn't)
    • Pumpkin Seeds (Would be understandable if it didn't)
  3. It does not select blocks which are technically the same block (or are part of it) yet have different IDs
    • Burning Furnaces (Furnace)
    • Deactivated Redstone Torches (Redstone Torch)
    • Piston Arm (Piston)
    • Sticky Piston Arm (Sticky Piston)

As for the leaves and saplings, you could probably apply a bitmask or something. --50.135.57.119 14:55, 13 November 2011 (UTC)

Doors in strongholds stay open instead of closed.[edit source]

I found a stronghold and many (but not all) of the iron doors in it are stuck open. Operating the button next to the switch causes the door to close momentarily, then reopen. Removing and replacing the door causes it to behave as expected (closed unless the button is pressed). seed: -8828007030566871345

Boats fall through rock[edit source]

A boat placed on a 3x3 grid of cobblestone, with walls around, and wooden pressure plates like so:

 x x x
 x   x
 x   x

x being a pressure plate, with water occasionally coming into the gap, will eventually (within a few days) drop through the cobblestone into the gap below. This makes float switches unreliable.

Bows on SMP[edit source]

Crafting a bow in SMP gives this error message: "Connection Lost Internal exception: java.io.IOException: Received string length is less than 0! Weird String". The bow doesn't even have to be used, just crafted.

Double Doors Not Working Properly[edit source]

So let's say I have double doors in my house. If I open the right door, it opens the left door instead. If I click again, it opens the right door, even though I attempted to open the right door before the left door. However, if I right click the left door and then the right door, it opens up properly.