Talk:Issues/Beta 1.9pre3

From Minecraft Wiki
Jump to: navigation, search

After writing a report please sign your name by typing four tildes "~~~~" at the end or by clicking Button sig.png in the editor page.

This page is for reporting bugs in the Beta 1.9pre3 version, if you think you have found a bug, put it under the appropriate topic under 'In discussion'. Please use the search function of your browser to avoid duplicate topics. Do not use external image sites to host your picture files. Upload them to this wiki if you have an account.

Since this version is an outdated prerelease, there's no need to search for bugs in this version. Instead, search for bugs in the fourth prerelease, here. However, it may be worth your while to take the time to test the bugs on this page in the new prerelease.

In discussion[edit]

Installation Issues[edit]

Crashing[edit]

  • Still here from previous 1.9 pre-releases: some clients crash when attempting to generate a world or switch to that world, leaving only an empty folder with the world name in .minecraft/worlds. Delphinus 22:43, 8 October 2011 (UTC)
Tested with a 64-bit JVM: cannot create any world; the attempt results in an access violation error in the dump file, while compiling ahc.a(II[B)V (659 bytes).--Asterix99 05:55, 9 October 2011 (UTC)
Is this a 64-bit JVM problem? I'm also using a 64-bit JVM. Can anyone else test this? Delphinus 12:25, 9 October 2011 (UTC)
I've done the 64-bit Java hack on my Mac, and I have not had this problem. And yes, I'm sure it's running in 64-bit mode. — minrice2099 (talkcontribs) 16:13, 9 October 2011 (UTC)
I'm running Windows 7, so perhaps it's a combination of operating system and Minecraft? 1.8.1's generation algorithm runs perfectly, it's only the 1.9 pre-releases that cause me to crash. Delphinus 22:48, 9 October 2011 (UTC)
I'm running FreeBSD 8.2 on AMD64 using OpenJDK7 (diablo-1.6.0) -- always crashes at "Preparing start region for level 0" (at loading bp). Doesn't matter which FreeBSD jdk I use. Also, 1.8.1 runs perfectly and 1.9p3 runs fine on the 32bit jvm (on a Celeron machine). Sunwukong 23:31, 9 October 2011 (UTC)
Is this serious/widespread enough for someone to get in touch with the Mojang staff and ensure they know? Delphinus 20:10, 11 October 2011 (UTC)
There's a not-too-well documented report in the bug forums that hints at the issues -- since 1.9p4 is almost out I'll wait until that gets released before I post far more detail there. Sunwukong 20:25, 12 October 2011 (UTC)
  • Mincraft closes imediatly when i start to move in creative.
  • When minecraft is runnign with render distance set as FAR: minecraft start crat crashing after a few minutes.Bug started since 1.8 Rbag 13:55, 12 October 2011 (UTC)

Creative Mode General[edit]

  • Using a water bucket on a cauldron fills the cauldron as expected, but it also empties the bucket. This runs counter to the standard behavior of being able to use one bucket to place infinite water springs. — minrice2099 (talkcontribs) 19:34, 6 October 2011 (UTC)
  • Ender Pearl not throwable --96.49.116.92 17:43, 6 October 2011 (UTC)
Just like 1.9pre2. Confirmed, but I can't see this as a big problem. Why would you want to teleport when you can fly? — minrice2099 (talkcontribs) 19:54, 6 October 2011 (UTC)

I think this is intentional.

  • Wheat removed from hotbar when mob is fed. --96.49.116.92 17:38, 6 October 2011 (UTC)
  • You can't right click a water source with a full bucket to remove it. And cliking it with an empty bucket removes the water, but also fills the bucket. caramba2654 20:18, 6 October 2011 (UTC)
  • When in Creative Mode you can fly that high that you see the moon and the sun at the same time even if the moon is in mid air. (at night)178.112.243.175 12:10, 8 October 2011 (UTC) (TheWickedAUT)
  • Blocking with a sword then left clicking toward any mob then releasing the right mouse will cause damage the the mob no matter the distance?
There's no need to hold the block button: in creative, you can damage mobs up to around 30 meters away with any melee weapon (this includes tools). However, this might be intentional. This doesn't work in survival. --Mokunen 22:17, 10 October 2011 (UTC)
  • It is possible to access minecarts with chests through other solid blocks.

Gameplay[edit]

  • Filling a single glass bottle with a water source block replaces the item in your hand properly with a water bottle. Filling a single bottle from a cauldron empties your hand and puts the new water bottle in the first free inventory slot that is not your hand (preference to hotbar, but it will jump to your inventory if the bar is full). If your inventory is full, the glass bottle is removed from your hand and a water bottle is thrown out by the cauldron, usually resulting in you picking up the bottle immediately (if you're close enough to the cauldron). Only tested on CSP; didn't have time to try anywhere else yet. — minrice2099 (talkcontribs) 20:08, 6 October 2011 (UTC)
  • Critical hits are not dealing extra damage, despite the "stars" special effect still being present: when dealing critical hits with stone or iron swords, it still takes two hits to kill friendly mobs; zombies take four critical hits from a stone sword. --Mokunen 00:04, 7 October 2011 (UTC)
EDIT: Further testing reveals that zombies take five hits from a stone sword to die, and spiders take four normal hits or three critical hits; the difference in the amount of strikes necessary seems to indicate that this is not a bug in the combat mechanics, but that the sword damage and/or mob health have been modified. If anyone confirms this, then it's not a bug and should be removed. --Mokunen 05:08, 7 October 2011 (UTC)
This is just weird. I tried this out with a bunch of sheep (which have 5 hp according to our very own wiki). A diamond sword (supposed to do 5 damage) killed in two hits. Diamond sword critical killed in one. Bare-hands took 8 hits regular, 6 critical. Something is either seriously wrong or seriously changed. — minrice2099 (talkcontribs) 05:18, 7 October 2011 (UTC)
Tested with punching Chickens now. Regular punch yields dead in 4 (as expected), critical punch kills in 3 (expected 2). — minrice2099 (talkcontribs) 06:05, 7 October 2011 (UTC)
From your information, it seems that punches deal a full heart of damage and critical punches a heart and a half again. Chickens would seem to have 4 hearts, and from my previous testing zombies and spiders also received bonuses to their health, the zombies having between 15-21 hearts and spiders 12-15.5. This could be considered a major upgrade to the combat system, and as such it would be a feature, not a bug. It's weird that they made such a huge change between pre-releases, but let's see what we make out of it. I'll be punching things to death later to get some more accurate values. --Mokunen 12:44, 7 October 2011 (UTC)
It doesn't explain everything here, but I just remembered something I saw a few days ago. Mobs could have some sort of armor now. — minrice2099 (talkcontribs) 17:30, 7 October 2011 (UTC)
I'll have to say this is not a bug then. I'm curious as to what Jens meant with "armor", I'm guessing it was a brain fart for "health" since it's kinda silly for chickens and sheep to have armor. I'll leave this convo here and update the mob pages with their new health points after some testing. --Mokunen 21:00, 7 October 2011 (UTC)
EDIT: No, forget it. Further testing with all kinds of swords and mobs is giving me completely incoherent results. I can't figure out what the changes were, so I'll just leave things as they were until the devs decide to shed some light on this issue. --Mokunen 22:19, 7 October 2011 (UTC)
  • Game occasionally has problems with block targeting. Most notably when holding down the left mouse button.70.45.5.146 02:38, 7 October 2011 (UTC)
The only time I've had problems with targeting is when in creative mode when there's an entity behind the block you want to target. Could this be what's happening? — minrice2099 (talkcontribs) 04:19, 7 October 2011 (UTC)
In my case it happens when I break several consecutive blocks without letting go of the button.70.45.5.146 04:33, 7 October 2011 (UTC)
  • The water in a cauldron doesn't put out a player on fire. Caramba2654 18:17, 6 October 2011 (UTC)
I doubt this can be considered a bug, since the water in the cauldron is not actual fluid but a graphic simulation of water. I would consider this a feature request. --Mokunen 02:03, 7 October 2011 (UTC)
And I tried placing fire underneath it. The water didn't boil. So that means we're supposed to do potions with cold water? caramba2654 02:40, 7 October 2011 (UTC)
I would agree that this should be considered a new feature request, but it is counter-intuitive. As for the boiling water thing, you're not expected to brew anything in the cauldron; I doubt it'll even be in the full release. Just use the Brewing Stand. — minrice2099 (talkcontribs) 02:57, 7 October 2011 (UTC)
Or that or its use is going to be added in 1.10. Mojang wouldn't add a useless block. It'll have a use in the future. Maybe boiled food? caramba2654 03:21, 7 October 2011 (UTC)
No, Jeb was working on it as a possible platform for brewing potions, but later dropped it in favor of the brewing stand. If you look, you should find corroboration all over the place (such as all over the Cauldron page). — minrice2099 (talkcontribs) 04:17, 7 October 2011 (UTC)
  • In some cases, when played in any mode except hardcore, the player will not take damage. PawnStar 12:28, 7 October 2011 (UTC)
  • When you go out from lava with the fire resistance potion, you die.
This might be related to the phenomenon of zombie pigmen dying when getting out of lava, see info on zombie pigmen, particularly the "theoretical vertical momentum" part. --Mokunen 14:18, 7 October 2011 (UTC)

Floating beds. I noticed this first in pre 2. I removed the blocks from under a bed and surrounded it with wooden slabs blocks (imagine a loft with the bed at floor level.) I can't get into bed from above or to the side but I can get into it from below it from below. Weird. I didn't test to see if it had to do with standing at a half block level or above the bed or something...--Barkerman 22:06, 7 October 2011 (UTC)

  • Enchanting just works for just one hit, after this the weapon will turn normal again and you will get your experience points back.--Grandremone 23:32, 7 October 2011 (UTC)
  • Full dimond armor set is far too powerful. On normal difficulty close explosion of a creeper deals half heart of damage. In addition something is wrong with armor bar. earlier when items i was wearing were damaged the armor bar was decreased. Now it's full until item dissapear. --Neonidas1 14:34, 8 October 2011 (UTC)
This isn't a bug. It's diamond armor. For a full set, that's 24 diamonds, so it's a big investment for a big return. As far as the armor bar decreasing, that is also not a bug. Jeb recently reworked the mechanics of armor.[1][2]minrice2099 (talkcontribs) 16:52, 8 October 2011 (UTC)

Biomes / Map Generator[edit]

  • Glass pillers show where strongholds are. Chaosmonkey45 21:55, 6 October 2011 (UTC)

http://i53.tinypic.com/2db84ly.png

This is fairly widely presumed to be leftover from debug code. — minrice2099 (talkcontribs) 11:01, 7 October 2011 (UTC)
this IS a leftover from debug code --Rbag 14:00, 12 October 2011 (UTC)
  • If an underground casm/revine intersects with a dungeon, certain aspects of the dungeons construction will stay floating in mid-air across the casm, such as door ways and bars.
  • Sometimes world is created with very big holes, even thorugh bedrock. World is working fine but...

If u fell ito it, you get 2-3 hearths damage and get kicked from the server for flying. when yuo relog, you are still falling and again get damage and get kicked. it repeats until death. Screens were made on multiplayer on survival mode. --Neonidas1 09:44, 7 October 2011 (UTC) http://i54.tinypic.com/2vl1g08.png http://i55.tinypic.com/358c5fc.png

Well, it's obvious from the screens that you weren't on survival, but anyway. I was really confused by the first one, but the second made it more clear. It looks as though the sections on either side of the hole were generated in previous builds. The part with the hole was generated in 1.9pre3, and is part of a Sky Dimension "biome" which has been largely presumed to be testing code. Expect more answers as Air Portals are explained and finished. — minrice2099 (talkcontribs) 11:01, 7 October 2011 (UTC)
I'm also getting the same in SMP, on two different seeds... the server is set to gamemode 0, difficulty 3, but I was flying around in gamemode 1. The seed and location in screenshot: http://i.imgur.com/jl2D9.jpg (View the other direction: http://i.imgur.com/XzUqW.jpg ... looks like the server is generating floating islands in the normal world.) Nschubach 20:46, 7 October 2011 (UTC)
Happened on 3 different servers, on three different computers for me.My world was almost unplayable.Kin0025
Confirming this as well. Use seed -301047969778251240 and navigate around x=-23 and z=-57. To make sure my host wasn't causing any issues I regenerated it locally using the same key. Shinji257 20:39, 9 October 2011 (UTC)
Screenshots: http://www.robertpendell.com/mcimages/2011-10-09_15.35.57.png http://www.robertpendell.com/mcimages/2011-10-09_15.36.03.png http://www.robertpendell.com/mcimages/2011-10-09_15.36.15.png http://www.robertpendell.com/mcimages/2011-10-09_15.36.30.png http://www.robertpendell.com/mcimages/2011-10-09_15.36.38.png
Confirming this. I've run over 10 worlds on the 1.9 Pre3 server build. All of them are generating massive open areas (in excess of 10 chunks square). In addition, they seem to overwriting the locations of the Strongholds, at least for me. The server will give the following message: Generated Stronghold at (X, Y) in biome INVALID. Glek 16:14, 12 October 2011 (UTC)
edit well i used seed which i knew it was cool on previous versions of 1,9 pre, but i've deleted old world and generated it again with 1,9 pre 3. Server was in survival mode. i turned my gamemode to 1 (in server console) to make the screenshots. --Neonidas1 06:24, 8 October 2011 (UTC)
  • Don't know if it's bug: there are no spawning monsters inside mushroom biome. I've spent 2 nights on mushroom island and didn't see even a littlest spider. --Neonidas1 12:22, 8 October 2011 (UTC)
  • Underwater air "bubble" in ocean biome.
    Strange underwater air zones are being created in ocean biomes, see screenshot. There is nothing but air inside these bubbles, they were created automatically by the map generator (this is a map created in 1.9 pre3, not an old map). Even when there's water on top of these static "bubbles", it won't fall on its own and fill the hole it as it should. The water around the topmost layer of air has no current, while the water surrounding the underlaying layers has an inward current that pushes the player into the air "bubble". Placing a block over the topmost layer causes the water to fall as it should, but only in the block immediately surrounding the added block. Placing a block in any other place, under or inside the bubble, doesn't cause it to collapse. --Mokunen 23:59, 8 October 2011 (UTC)
  • It seems that no mobs spawn, at least in snowy biomes. While playing the Skyblock challenge, after several days of leaving a well-lit patch of 8x8 grass 24 blocks away, not as much as a single chicken had spawned. Tested both with an open environment and a closed 8x8x2 room.--Asterix99 06:03, 9 October 2011 (UTC)
I'm seeing much the same thing, plenty of aggressive mobs, but no passive mobs. Except, oddly enough, squid. Lots and lots of squid spawning. Very weird.-- jimnutt
So you mean passive mobs, then? Well, I can't tell you exactly why it's not working for you, but I did the same challenge, and got two cows and a sheep to spawn in about seven in-game days. Are you sure the blocks you were trying to get them to spawn on were grass blocks? The details of post-world-generation spawning can be found here. — minrice2099 (talkcontribs) 06:11, 9 October 2011 (UTC)
  • I am not sure if this is a bug or not, but the swamp and snow biomes do not blend with other biomes. They do, however, blend with each other. 70.53.3.241 07:30, 12 October 2011 (UTC)Kirsten
  • I'm almost sure this is a bug. The snow biome (Ice and Snow) mixes with the desert biome. I don't think it's supposed to do that. Note this happened while I was elsewhere. i.e. I didn't SEE it happen in front of me.
    Snow and Ice mixing with Sand
    --ReelTin 17:11, 12 October 2011 (UTC)
When did you first generate the world/those chunks? If it was before any of the 1.9 pre-releases, the snow biome wasn't coded in. This means that, when it generated, it could have met the criteria for a snow biome but defaulted to the next closest thing (in this case desert), and now that the biome code is included, it has the weather for a snow biome, but the blocks have already been generated. If you take a picture with the F3 screen enabled so I can get the seed and coordinates, we can test this. — minrice2099 (talkcontribs) 19:03, 12 October 2011 (UTC)
  • The "Generate Structures" option only half-works; dungeons and Nether Fortresses are still generated if it's off. The fortresses do seem to be more rare than with Generate Structures on, but they're definitely there. --84.186.251.145 10:18, 13 October 2011 (UTC)

Hardcore Mode[edit]

Difficulty is fixed, but not set to hard. To reproduce, open a survival world, set to peaceful, open hardcore world, roam around at night. --77.164.81.181 11:08, 10 October 2011 (UTC)

Graphical (GUI)[edit]

  • Enchanting table has no tooltip in inventory (CSP) --96.49.116.92 17:40, 6 October 2011 (UTC)
  • Lily pads still have an empty tooltip in inventory. Dhalek 21:38, 6 October 2011 (UTC)
Confirmed, they are also colorless when dropped or in the inventory, while other biome-affected blocks such as leaves and vines are green. --Mokunen 01:54, 7 October 2011 (UTC)
  • When carrying an item with the purple wave effect, (such as potions), and moving it over the book while it's closed in the enchantment interface, you are able to see the entire wave effect around the object in front of the book.
  • When holding a potion, the Hotbar outline will become Clear. This only happens when holding a potion.

This also happens with swords on my computer. And any glowing object for that matter.

Lighting[edit]

The same lighting bug that effects chests and signs seems to effect the books on enchantment tables.

The extending segment of pistons are darker than would be expected at times other than day. Redstone repeaters are also still not lighting properly when not activated. GhengopelALPHA 03:46, 10 October 2011 (UTC)

Any animal that goes in the water 'flashes' between a normal and shaded texture. It's nothing major, but kind of a pain to look at Uberorb 22:12, 12 October 2011 (UTC)

Memory/CPU[edit]

  • Still getting very high CPU usage on Server/Client ( 100 % ) since 1.9pre1. Tested on different Computers: Dedicated Linux Server ( Lenny 64-bit, Core2Duo @ 2.2GHz ),Laptop ( Win 7 64-bit, Core2Duo @ 2.2GHz ), Mac ( Snow Leopard, CoreDuo ). CPU usage was fine with 1.8pre versions and 1.8.1 ( approx. 25% ) with 2 players on the Server ( now 1.9pre 1,2,3 = 100% both Cores.92.231.109.254 12:32, 8 October 2011 (UTC)
I can confirm this. 1.9pre3 seems to use 10x or more cpu than 1.8.1 on the same system. Have them running side by side for comparison and testing purposes. I just checked and 1.8.1 shows < 5% cpu usage and 1.9 shows > 95% cpu usage. Both are running using Sun Java 7 (1.7.0) and are empty at the moment. Shinji257 20:40, 9 October 2011 (UTC)
Also confirming very high CPU use for server on 1.9pre3 in windows 7 x64, using server java 64bit. 2 concurrent servers with McMyAdmin the one running 1.7.3 using 0% and the 1.9pre3 using 100% of one cpu with no players logged in. --75.129.58.160 05:02, 10 October 2011 (UTC)

Also confirming very high CPU use for servers on 1.9 pre3 Using Windows 7 64 bit. running vanilla server CPU use went up 30% when switching from 1.8.1 to 1.9 pre3

Yet another confirmation. Running 1.9 pre3 on Xen VPS, Debian 6 w/4 CPUs and the one CPU is maxed at 95-100%
  • What about the FDIV bug report ? This bug only exists on '94 pentiums (66-150MHz) and Minecraft would certainly not run on those... I'm reverting.

Mobs[edit]

Endermen[edit]

  • In SMP Endermen warp far away from a player who is hurting them in quick succesion with a sword making the damage taken in a battle one sided and cowardly.--ChopStickSoSushi 22:15, 7 October 2011 (UTC)
Probably not a bug: Notch said he would make endermen more difficult to kill, the quick teleporting is likely intended. Personally, I like them being hard to kill, it's more rewarding when you actually do. --Mokunen 03:35, 9 October 2011 (UTC)
weird my endermen are perfectly easy to kill (ignoring boosted hp/armor) if i'm on a higher location than it... killed 3 which stood around staring at me barely charging (but agro'ed) and not teleporting till it was jealous that i hit a zombie on a different corner of my 3x3x3 house... 98.134.54.163 17:15, 9 October 2011 (UTC)
  • In SMP Endermen will warp away from the player if it is daylight and a player trys to slash the Endermen with a sword making battles in the daylight near impossible.--ChopStickSoSushi 22:15, 7 October 2011 (UTC)
  • In SMP Endermen warp away from being hurt by water they also act quite crazed in there warping patterns if caught in the rain.--ChopStickSoSushi 22:15, 7 October 2011 (UTC)

Breeding[edit]

  • Mobs cannot re-enter love mode after breeding once. (CSP) --96.49.116.92 17:38, 6 October 2011 (UTC)
This is probably intentional to prevent too much breeding. TiriPon 18:25, 6 October 2011 (UTC)
This is also not true, although it is a big buggy. Wait for the adult's baby to grow up and try again. You may need to quit and restart the map to get it to work, but I did eventually get an animal that had previously bred to breed again. — minrice2099 (talkcontribs) 03:02, 7 October 2011 (UTC)
In SMP I Visitor observed the following:
  • Child animals look like grown up animals
  • Child and parents stay together and can't get influenced for real by wheat (hearts are only visual; you can't lure them)
  • After some time they can be influenced by wheat again
  • The times between that was different for me between child and parents but that could be because of chunk unloading or because the child wasn't fully grown up.
Thus in my opinion the only bug is that the server does not tell the client properly that some animals are child or parents.--Visitor 08:36, 7 October 2011 (UTC)
  • After breeding, parent mobs will path toward their child; this takes them through the most direct route, which can cause them to fall to their death, and sometimes instead of moving in circles around the baby mob they'll just keep walking into it and pushing it around. --Mokunen 03:33, 7 October 2011 (UTC). Other parent mobs might think that that the baby of other mobs of the same type are theirs causing a baby mob to have three parent mobs following it.
i can confirm parents pushing their babies, maybe this should be reported bug of its own. also i noticed parents keep pushing even after baby grows up.
  • Wolves enter love mode, but won't breed. Tamed wolves do not enter love mode on account that right click is co-opted by the sit command.--PlNG 22:49, 7 October 2011 (UTC)
  • Squid do not enter love mode. Also recommend fish for this.--PlNG 22:49, 7 October 2011 (UTC)

Baby animals[edit]

  • Loading 1.9pre2 world, some existing adult animals in farm become babies (2 of 2 pigs, 2 of 2 sheep, 1 of 2 chickens)

Snow Golems[edit]

  • Snow golems are invisible. Even newly created golems in pre 3. --anonymous - 11:43pm, 6 October 2011 (UTC)
My snow golems are perfectly visible. FatherToast 01:02, 9 October 2011 (UTC)
Snow Golems invisible (in SMP only) for me aswell, old and newly created. (on XP x64, 64bit JVM) --BoneCrusherXes 11:52, 10 October 2011 (UTC)
Wow, that's a weird one, but confirmed (smp only). — minrice2099 (talkcontribs) 17:19, 10 October 2011 (UTC)

Squid[edit]

  • Squid not spawning. Started a few new worlds and have yet to see any squid. Did they change the spawn rate?
They're still spawning for me in newly generated worlds. Still, they seem to be far less common, they probably changed their spawn rate. --Mokunen 03:47, 9 October 2011 (UTC)

Chickens[edit]

  • Chickens are able to walk through doors in-between fences (possibly due to the changes in the fence's collision).
i tested this and could easily push chickens through, tho i dont know if they do it by themself. confirm?

Mob Spawning[edit]

  • Mobs can spawn in glass panes. [3] Umpa2 12 Oct 2011

Nether portals[edit]

Server[edit]

  • When placing the cauldron on a server you get 'end of stream'
  • 100% cpu usage on Win XP Prof SP2, pic: http://i1118.photobucket.com/albums/k620/Meerlin/193-100.png --Merlinn
    • Confirmed on Debian Squeeze with 64-bit OpenJDK-7 packages from testing. The 1.9pre3 package pegs one core on a dual core machine.
      • Confirmed it here on Ubuntu 11.04 64-bit using Sun Java 7. Pegged 1 core on a 8 core Xen VPS. Reads anywhere from 95% to 115% cpu usage. (garbage collection is spread over other cores)
        • Yep, my server almost always has one core pegged at 100% since 1.9pre1. Mac OS X 10.7.1.
  • Stopping server on Linux gives java exception:
Second confirmation on this, the last line (java.lang.Thread.run) has a different number for me (636) --Daraeman 05:14, 13 October 2011 (UTC)
java.io.IOException: Bad file descriptor
at java.io.RandomAccessFile.seek(Native Method)
at oj.a(SourceFile:342)
at oj.a(SourceFile:279)
at ho.close(SourceFile:259)
at java.util.zip.DeflaterOutputStream.close(DeflaterOutputStream.java:149)
at java.io.FilterOutputStream.close(FilterOutputStream.java:143)
at nk.a(SourceFile:119)
at nk.c(SourceFile:107)
at cl.a(SourceFile:29)
at cl.run(SourceFile:22)
at java.lang.Thread.run(Thread.java:662)

Don't know if that leads to file corruption. Dhalek 19:10, 9 October 2011 (UTC)

A similar error occurs with my server on my Windows 7:
java.io.IOException: Stream Closed
at java.io.RandomAccessFile.seek(Native Method)
at oj.a(SourceFile:342)
at oj.a(SourceFile:279)
at ho.close(SourceFile:259)
at java.util.zip.DeflaterOutputStream.close(Unknown Source)
at java.io.FilterOutputStream.close(Unknown Source)
at nk.a(SourceFile:119)
at nk.c(SourceFile:107)
at cl.a(SourceFile:29)
at cl.run(SourceFile:22)
at java.lang.Thread.run(Unknown Source)
This set of lines gets repeated 3 times for me. It also says "Saving chunks" after some of them. --Allenmelon 21:24, 9 October 2011 (UTC)allenmelon
And I have this when I stop the server on my Mac:
java.io.IOException: Bad file descriptor
at java.io.RandomAccessFile.seek(Native Method)
at oj.a(SourceFile:342)
at oj.a(SourceFile:279)
at ho.close(SourceFile:259)
at java.util.zip.DeflaterOutputStream.close(DeflaterOutputStream.java:149)
at java.io.FilterOutputStream.close(FilterOutputStream.java:143)
at nk.a(SourceFile:119)
at nk.c(SourceFile:107)
at cl.a(SourceFile:29)
at cl.run(SourceFile:22)
at java.lang.Thread.run(Thread.java:680)
It doesn't always happen, but it happens most of the time. — minrice2099 (talkcontribs) 21:34, 9 October 2011 (UTC)


EDIT: It seems to only occur in a certain area. Probably a corrupt chunk. --Allenmelon 21:09, 9 October 2011 (UTC)allenmelon

Sound[edit]

  • Chests still don't have an opening sound. Dhalek 21:39, 6 October 2011 (UTC)
Not a bug, just part of the pre-release. When the official updates are downloaded, they download other new files as well (such as sounds). Pre-releases are game and texture changes only. — minrice2099 (talkcontribs) 21:52, 6 October 2011 (UTC)
  • Lost all game sounds (including music I think) after a thunder storm Sparkalyn 02:23, 7 October 2011 (UTC)
  • When on creative at least, the sound from a record in a juke box is only heard loud enough to hear when turned away from it –The preceding unsigned comment was added by 156.34.154.151 (Talk) 19:03, 7 October 2011. Please sign your posts with ~~~~
Moved this over from the main page. I cannot confirm this issue. Make sure your client's "Sound" setting (not "Music") is turned up). Was this on a server? — minrice2099 (talkcontribs) 01:46, 8 October 2011 (UTC)

Spawning[edit]

  • In SMP, I'm not seeing any passive mobs spawning except for squid. The rate seems to have declined as the world has aged. It could be that squid aren't actually spawning any longer either, I've just not been harvesting them. Aggressive mobs seem to be spawning, however, their spawn rates seemed to have dropped as well. Especially for creepers, when I first created the world, creepers were spawning in packs of 4 or 5, now I'll only see one or two. --jimnutt

Weather[edit]

  • I'm occuring the same bug since 1.8, on multiplayer. Sometimes reloging helps:

Occasionally when i'm logging in while it's raining or snowing it rains though solid blocks (some of them, not every1), in houses or even deepest caves. Later i'll post screenshots.--Neonidas1 12:04, 8 October 2011 (UTC) - and here it is http://i56.tinypic.com/voyckx.png

Same here, seems to happen when entering world either by connecting or entering via nether while its raining, rain then passes through solid blocks seemingly through the world. --75.129.58.160 05:04, 10 October 2011 (UTC)
I have video evidence too just in case it is needed: Video LB 22:33, 10 October 2011 (UTC)
I ran into this when placing a portal inside the entrance to my base in a snow biome. While the entrance is open, it isn't exposed directly to the sky, but ever since placing the portal, it snows in the entryway. Yes, the snow is white, along with the usual purple sparkles near the gate, but no snow builds up inside. --71.193.49.206 07:40, 12 October 2011 (UTC)

Confirmed[edit]

Biomes[edit]

Creative Mode[edit]

Gameplay[edit]

Charcoal is no longer available in 1.9 Pre-Release.--LethalComboFilms 02:18, 11 October 2011 (UTC) If you click on the bed to sleep, and then break it before falling asleep (to get out) any wall (Side of a block) you touch will hurt you with 1/2 damage heart until you click on the bed and go back to sleep... when you wake up the walls will no longer hurt you

Graphical (GUI)[edit]

Files[edit]

Memory/CPU[edit]

Mobs[edit]

Sound[edit]

Weather[edit]

  • Snowfall still creates snow caps on top of uncovered water blocks, chests, doors, half blocks, fences, and deletes torches. Ice and snow ignore torch lighting that should prevent them from forming. --Mokunen 23:50, 6 October 2011 (UTC)
If someone can figure out if it still deletes minecart tracks and crops, we should move this to confirmed. — minrice2099 (talkcontribs) 01:35, 7 October 2011 (UTC)
Just tested with regular minecart tracks, full-grown wheat, and redstone: snow keeps deleting every one of them. Also, the game seems to recognize when a snow cap is placed on open water and removes it after a while, only for it to form again afterwards. --Mokunen 02:14, 7 October 2011 (UTC)
I agree the behavior is exactly as if the snow is ignoring lighting. I wonder if this is related to the change to updating tile lighting values in a new way not being propaged to snow, or if there are further changes planned and this simply has not yet been updated for them. Either way this makes surface living very difficult due to the inability to secure areas AND the destruction of crops. Mjevans1983 06:55, 9 October 2011 (UTC)

SMP[edit]

  • Yep, the data loss on shutdown bug is still there in pre3, I think Mojang must not be aware of it. Kilorat 18:45, 6 October 2011 (UTC)
Can you describe it more in detail(steps to reproduce; what kind of data is lost)? I had no data loss on my server so far. --Visitor 12:59, 7 October 2011 (UTC)
Maybe you have save-off, or something like that? xPaw 13:03, 7 October 2011 (UTC)
I also expierenced data loss a couple of times, even after save-all and stop. The inventory stays the same but some chunks are just not saved, I also lost a lot of chest content inside an affected chunk. My world has a size of 50MB (quite big?), please post your size to compare whether this occurs when exceeding a certain size. --80.138.2.71 15:51, 7 October 2011 (UTC)
Confirmed data loss here. I did a save-all and stop shortly after generating the worlds and they all had to regenerate the next time I started the server. Then I went in and dug up/built a small tower of dirt blocks, and quickly stopped the server again. Restarted, logged back in, and the tower was gone. — minrice2099 (talkcontribs) 17:59, 7 October 2011 (UTC)
The world folder is 150 MB huge for me and I had no data loss so far. I just stop my server by pressing on the [x] button of the server window --Visitor 18:01, 7 October 2011 (UTC).
I'm not saying that the files disappear; I'm saying that changes are not saved. The easies way to test this should be building something and quickly stopping the server. — minrice2099 (talkcontribs) 18:05, 7 October 2011 (UTC)
I tried to stop the server very fast: First everything was fine. Then I tried to stop the server right after placing a block without disconnecting with the client first. Now the client gets an exception when logging in. So I guess the servers data is now corrupted. Edit: No it's just minecraft.net ... No data loss so far. --Visitor 18:13, 7 October 2011 (UTC)
Are you sure that you use the 1.9pre3 minecraft_server.jar? --80.138.16.190 20:36, 7 October 2011 (UTC)
Yes. I am using a 64 bit linux system with java 7 (64 bit). Maybe it only happens at certain systems? --Visitor 08:38, 9 October 2011 (UTC)
Well, I am using 64bit Windows 7, with Java 6 32bit and I'm getting these save bugs. --W1th0utnam3 09:46, 9 October 2011 (UTC)
I am using 64bit Windows 7, with Java 7 64bit and I'm getting these save bugs. Just using the server .jar, not a batch file. Do you think using a batch file to allocate more memory might help?--Cdewitt87 07:44, 10 October 2011 (UTC)
This happens to me on Linux 64bit with Java 6 and 7. It coincides with the Java-Problem mentioned above, It coincides with the
"java.io.IOException: Bad file descriptor" mentioned in another thread. I've two affected chunks in my test world which are not saved even by save-all... the :::::::::::java exception does not oocur when doing save-all, only when I stop the server though.
happening to me im useing a .bat file to start up my server , any know solutions yet? when i stop server and start up again a large amount of chunks reset back to before i edit them (UTC)
Happening to me as well. 84.106.66.96 12:35, 13 October 2011 (UTC)
Just tested 1.9 pre4 and it seems to be fixed. I just went around blowing up chunks with TNT and stopping the server. Did it three times, seemed to be saving fine.--Cdewitt87 05:37, 13 October 2011 (UTC)


  • A glowing enchanted weapon cannot be seen by other players, only yourself. --Grandremone 23:34, 7 October 2011 (UTC)
  • Might be an old bug, but I just noticed; Server instance constantly consuming 50-100% of one core (even when no one connected). Is this a bug or is it actually doing work? (it also doesn't explain why the rate isn't more normalized and lower) Mjevans1983 08:43, 8 October 2011 (UTC)

Old Bugs/Not Bugs[edit]

Cake on pressure plate[edit]

  • This doesn't seem like a bug to me, cake is a block, if you place a block on top of another block it fills the block slot above. This is like complaining you put a pressure plate in a corner and now can't stack a ladder block in the same corner. Mjevans1983 08:39, 8 October 2011 (UTC)
This is a bug, it simply isn't new to 1.9pre3. I've had it occur in 1.8.1; either way, I've removed it from the page 152.157.78.145 19:17, 10 October 2011 (UTC)

Biomes[edit]

Achievements[edit]

References[edit]


Pistons[edit]

If a block is moved so as to connect a redstone circuit by a piston and that circuit with no delay moves that block so that the circuit is broken the game will crash. Here are two arrangements http://i.imgur.com/wes0U.jpg that will cause this. If the glass is replaced by a solid block or the lever is switched it will cause the crash. This does not occur in 1.8.1 or any previous release with pistons. TinBryn 12:20, 11 October 2011 (UTC)

image is 403 forbiden, try direct or not direct linking? 96.13.79.32 17:04, 11 October 2011 (UTC)
When you delete the i. you can see the picture. (Well, I can see the picture this way) --☺ Sven Kein Schwein ruft mich an! 16:05, 12 October 2011 (UTC)
i tried one on right and confirmed crashing (on ssp). i noticed after restarting world, there will be two ghost blocks. on where piston extension should have been and where block would been pushed to. you can walk through the blocks but croshair targets these invisible blocks. when i used pistons on these invisible blocks they disappeared completely.

Glass[edit]

I don't know if it's a bug, but I generated a world and two columns of Glass were close to me, starting from a dirt block and going to the clouds. Really didn't looked natural. Pasemo--174.95.239.7 19:14, 12 October 2011 (UTC)

OMG, I cant believe that there is people that doesn't know yet that jeb accidently left debugging code on the prerelease 3 that creates glass towers on top of strongholds! --201.68.100.21 19:44, 12 October 2011 (UTC)

Shorn[edit]

I was just browsing through the wiki, fixing past participles of "shear". I often see "sheared", which is a decent guess if you don't speak English fluently, but the actual participle is "shorn". I just wanted to change it to that, but the page is protected from editing. - Dermot Mac Flannchaidh 06:55, 20 November 2011 (UTC)