Talk:Java Edition version history/Archive 5

From Minecraft Wiki
Jump to: navigation, search
This is an archive of past discussions.
Do not edit the contents of this page. If you wish to start a new discussion or revive an old one, please do so on the current talk page.

Contents


Administrative Stuff[edit]

Link to Complete Bug List [1] is missing. User:Incelebrity 18:46, 2 August 2012 (UTC)

1.1 IS OUT![edit]

Quick update it.


Yeah, they seem to have added eggs that spawn a certain mob. Each egg has its unique mob, and you right click to spawn that mob on the face you clicked of that block facing North (face 0), even if there's not enough space there to normally spawn the mob. So far I can only find it in Creative mode.


Pumpkin and melon can spawn without farmland now. They can spawn on dirt.

1.1 Bug[edit]

I found a bug where natural lava isn't lighting. Don't have an account, so i can't upload a picture. It was with a single lava block flowing out of a wall, not a pool. Edit: Block updates fix this bug.

That's probably a lighting bug like the "generated torch doesn't give off light" bug. metarmask 09:00, 4 November 2012 (UTC)

1.1 Undocumented Changes[edit]

Feel free to add additional undocumented changes here. If these should go straight to the Page instead of Discussion, feel free to move this and delete.

  • Baby sheep can no longer be sheared for wool
  • It is now possible to obtain the newer music disks without creative from creepers. (except disk 11)


  • Fixed bug where you could open a big chest with a block over one of the two block of the chest

1.1 Nether Bug[edit]

  • I made several trips to the nether in my 1.1 hardcore and on the last trip i returned to find a completely broken world where chunks will never load visually, even restarting minecraft does nothing to fix the problem. chunks of the nether have returned through the portal with me, i can see them breaking the water in the seas and even deep underground through the gaping abhorrent voids of nothing that once were. another minecraft version that i will not be touching ever again, just like 1.0! how upsetting

Cobblestone generators (water/lava flow)[edit]

An update was pushed out today that seems to have made the way water and lava flow interact follow drastically different rules that break all forms of cobblestone generators that I've tried. This needs to be noted. This did not happen until a minor update on the 27th, and not exclusively with the 1.1 update.

This was probably an attempt to fix what can be considered a duplication bug. 85.81.40.95 16:28, 13 February 2012 (UTC)(comment edited to avoid facetious nature. 63.145.183.198 08:01, 27 February 2012 (UTC))


I am not seeing the problem here, and it certainly doesn't break "all forms of cobblestone generators", even if it might be something you may have seen. I'm trying the pre-relese version 1.2 with Anvil on a fresh world made just for this purpose, and I'm successful in generating Cobblestone just fine with a purpose-built generator. --Robert Horning 21:18, 29 February 2012 (UTC)

In 1.2.1 snow is not showed in maps,can someone write it?I'm not good to do articles --95.237.19.164 14:21, 1 March 2012 (UTC)

Snow in maps[edit]

I dunno in 1.2,but in 1.2.1 snow is not showed in maps --95.237.19.164 14:40, 1 March 2012 (UTC) Sorry for double And the same map wont correct itself in 1.2.2

1.2.2 Undead not Burning in the morning.[edit]

Just want to see if anyone else is having this issue other than me. I was in the desert and the undead would not burn in the morning. I changed my difficulty to easy to see if that was the issue, but they still remained unphased. Also the endermen seemed to have no trouble with the sunlight either. Levy 21:03, 1 March 2012 (UTC)

I just figured it out! The clouds cast shadows on the ground and they don't burn in those shadows! :O Levy 21:06, 1 March 2012 (UTC)

its been fixed in 1.2.3 Stepanma01 10:18, 2 March 2012 (UTC)

Shovels vs. Spades[edit]

I know that the name of shovels turned to spades, but the resulting pages (tools, shovles, items etc.) also need to be changed

You must not be using American English. This site uses American English naming so the pages do not need to be changed. --Moxxy 00:21, 2 March 2012 (UTC)

Rain Bug[edit]

In 1.2.2, whenever it rains (and probably same goes for snow) no noise is made. Rain appears to pass through blocks, but, standing under an overhang or anything obstructing the sky still makes it rainless in that area. Rain also does not splash. Water (and probably Lava, too) acts like a block (it obstructs rain, but it still liquidy)

Rain worked fine for me in single player 1.2.2, sound was present, rain didn't pass through my roofs or overhangs, and entering a roofed area didn't stop the rain in the area. Seems it was either a rare bug or your system in general. —Neithan Diniem 22:43, 2 March 2012 (UTC)
Do you have particles turned on to "All"? I've encountered the same problem with particles off. Once I turned on the particles, though, it worked.

70.58.59.190 22:48, 4 April 2012 (UTC)

wheat is attracting all animals[edit]

When did wheat start attracting animals that have already been put in love mode? This is making it harder to breed animals, though it is making it easier to herd them. 68.142.35.128 19:34, 2 March 2012 (UTC)

Save Area Bug[edit]

Multiple times when I've saved since upgrading to 1.2.3, it's teleported me. If I save in my underground base, it teleports me to the top of the mountain. And one time I saved while I was mining, and when I logged back in, it had teleported me directly where lava was, resulting in me dying and losing everything I had mined.

I have the same problem in SMP. I have to disconnect in a safe, above-ground location, otherwise when I come back I could end up anywhere above ground. --70.77.72.34 05:35, 16 March 2012 (UTC)

Villagers bug[edit]

In 1.2.2, the Villagers created in previous versions disappears and don't respawn.--MisterSanderson 23:44, 2 March 2012 (UTC)

Constantly Running Out of Memory on New Singleplayer Worlds[edit]

I've made two new worlds where I can play for a minute or two before it crashed due to lack of memory. It saves the world like its supposed to, but I have done nothing special on both worlds except get basic resources. Nothing specifically seems to start them; sometimes when destroying blocks, sometimes attacking mobs, sometimes just walking. Didn't happen before the update(I've only played v1.2.3 with this computer and 1.1).

There are only two notable things. In both worlds I spawned in a jungle, and blocks destroyed just before the crash don't go away (but still drop resources that can be collected). I'll see if I can find the source. This computer hasn't had this issue before either.JerreyRough 02:57, 3 March 2012 (UTC)

Mob Spawn Deaths[edit]

now this has been a glitch for some time, but it's VERY apparent with the new jungle biomes. far too often peaceful mobs will spawn INSIDE a damn low hanging tree or now especially jungle bushes and die. this wouldn't have been a big deal before the new spawning rules, but now it certainly is. care needs to be taken with world/mob generation timing so that the trees ALWAYS generate first, and then mobs spawn around them, or we'll always be assed out of having nicely dispersed wildlife.

1.2.3 bugs[edit]

Sometimes torches doesn't melt ice into water.

Holding right-click while crafting doesn't increase amount of what you are trying to craft anymore.

Is it just my testing of Forge on top of vanilla, or when you log back in while y >= 128 do you 'bounce' in place, unable to move while a mortal? Mjevans1983 05:15, 6 March 2012 (UTC)

Forming a nether portal y >= 128, going in to the nether and then returning to the overworld creates a second over-world portal y <128 in the same area (as if the first portal hadn't existed) Mjevans1983 05:15, 6 March 2012 (UTC)

I experienced this bug too, from a y=210 overworld portal. It connects well to the nether-side expected portal (already placed at the right coordinates), but back from Nether, another overworld portal was created at y=119 in mid-air, ignoring the first one.LordKalt 18:59, 6 March 2012 (UTC)

Someone misspelled the word "block". Lol. My OCD is kicking in, can we get that fixed?

villager babys[edit]

--108.9.55.243 01:47, 4 March 2012 (UTC) How do you breed villagers?I do not know but you can in version 1.2.3

tell me how!!!!
You can't actively breed them, they will automatically breed to repopulate the villages homes

Cultist O 04:36, 4 March 2012 (UTC)

Furthering this, I think villager breeding is broken, on my SMP server my current village has died down to 2 villagers, they have plenty of complete and undamaged houses (and a few I repaired) but they just will not repopulate. Perhaps its just unimplemented for SMP so far and jeb forgot to mention. 87.194.26.132 23:14, 7 March 2012 (UTC)

Villager breeding is not 'Broken', but I believe it has been decreased greatly. They will only breed when 2x the amount of WOODEN DOORS are within 16 blocks in ratio to the number of other villagers around.
since 12w18a, villager spawn eggs spawn random professions. Why cant they spawn villager children, change the topic mame from villager babys to villager children

Dlpham 18:20, 10 July 2012 (UTC)

Fire Glitch?[edit]

Burning netherrack will set fire to wood planks through 2 layers of horizontal piston bases.

Render Distance in the Nether has changed?[edit]

Since the 1.2.x update, my render distance has changed, but it seems only in the Nether. Setting it to Far looks like it did when set to Normal, Normal looks like Short, etc., and continuing down to Tiny actually adds what appears to be the maximum amount of Void Fog everywhere. Is this happening to anyone else?

Also, completely random, but Villagers do not detect fence gates as doors, and thus, will never use them.

Ok, something doesn't make sense in the 1.2.3 Bugs section.[edit]

The article says "Mobs (Praticularly Skeletons and creepers) can teleport through glass panes when trying to escape sunlight." Creepers don't try to escape sunlight. 75.118.73.118 00:54, 9 March 2012 (UTC)

I just noticed the same thing. GenericCola 16:41, 9 March 2012 (UTC)

Um A DER.of course they don't avoid it, i mean they are sun prove if you haven't noticed.People you need to think.

CREEPERS EAT PEOPLE BOOM :) --42.241.211.193 05:43, 16 June 2012 (UTC)

"Minceraft" - was earlier[edit]

It was added in 1.9, said by notch in one of the interviews.

77.252.190.239 13:31, 12 March 2012 (UTC) Polish ver. only, cuz i cloudnt find the interview in the net: [2]

1.2.3 Bug with specific seed/spawn biome?[edit]

Wasn't really sure where to put this, but using the seed "Brux" (without quotes), a few anomalies can be noted that may be bugs:

1.) The seed takes an abnormally long amount of time to process (the game may even freeze).

2.) Once you're in, a large amount of render lag is produced until chunks have loaded.

3.) You are dumped in the ocean (leave Jump pressed to swim up, or you may drown while lagging, or use Creative Mode).

That's all the data I have so far. Has anyone else experienced similar issues with other ocean biome spawn seeds? With this seed in particular?

References?[edit]

I don't get it where you get all the info. On mojang.com there's not that much. From twitter? Anywhere else? Could you please provide more references.

And by the way, were there any updates since 2012-03-02? They are supposed to be weekly, aren't they? --212.92.188.168 16:21, 16 March 2012 (UTC)

Why don't we add download links into this article...[edit]

... to the different versions like in Version history/Development versions? Is there a reason? --88.74.28.103 00:08, 17 March 2012 (UTC)

There is no download link for an official version of Minecraft. You cannot legally download an official version of Minecraft (with the exception of downloading it through the launcher, of course). ISQ Talk 02:11, 21 March 2012 (UTC)
Really, I did not know that. So when I downloaded version 1.0.0 somewhere so that I could use Aether mod, I did something illegal? Even though I have a regular minecraft account?! --88.74.11.118 17:14, 21 March 2012 (UTC)
You didnt do the illegal thing as you have a paid account but the person who uploaded it did as it put it up everyone. If you didnt have a minecfat account thats paid for then that would be 15years in prison! im joking but it would be illegal

Idea about bugs in 1.2.4[edit]

Hi, I noticied when I read the bugs about 1.2.4 that the text "Limit framerate on menu screens, no longer uses 100% cpu and make my computer melt" I think "and my computer melt" is pointing just at the persion who wrote it, it should be: "and computers isn't running as hot as before". Just one idea, you can also say what you think about this.

/oggehej

That's actually taken from the official changelog, as was the commentary on cat behavior. It could still be changed to read better. -- Orthotope 20:20, 22 March 2012 (UTC)
i would be happy if minecraft could use more cpu-power (on different cores/threads) --MG127 22:14, 22 March 2012 (UTC)

Silk Touch and 1.2.4[edit]

Silk touch is marked as being able to be used on glass again in 1.2.4. I just tested and it appears to still not work. Confirm please?

80.254.74.5

They seem to have fixed it in 1.2.5, at least, I tried it in 1.2.5 and it worked. --RedMser 20:34, 7 April 2012 (UTC)

Colored Text[edit]

It says you can't type § with vanilla clients. I, however, have been able to before by pressing alt+6 on the Mac. Did they make it so you can't do that?

you're kicked off the server if you try to type it in the chat.
So, what's the point of this update, then? 83.165.25.218 15:21, 26 March 2012 (UTC)
it's probably just a bug. they made it possible to type/paste it into the chat, but didn't remove the protection from using it. minecraft devs not testing their updates, especially multiplayer ones is nothing new. Yarrmateys 17:36, 26 March 2012 (UTC)

control key is used in place of command key on macs[edit]

tested this with a vanilla minecraft, the Ctrl key works in place of the normal ⌘ Command key [at least for pasting, haven't tried cut/copy yet]

Can't escape the chat on Ubuntu[edit]

Well, this doesn't seem to be a bug of Ubuntu. It seems to be a problem when using OpenJDK. The solution is to install oracle's java by hand, because debian and ubuntu throwed out sun aka oracle java because of security issues and because of no longer being allowed to distribute java by packaging it. How to install java by hand is described in german language here but I think it is also useable for non-german people. On every fresh ubuntu install you'll not find any sun or oracle java and will run into the problem that you can't escape the chat. I tested it with ubuntu from 10.04 to 11.10 and got it fixed by installing oracle's java every time.

Dogs don't sit on exit[edit]

It is my experience that in 1.2.4, dogs no longer go from standing to sitting when the game is saved and re-loaded. PhilHibbs 18:31, 24 March 2012 (UTC)

Also, dogs stop attacking monsters if that monster is not attacking the player. PhilHibbs 23:26, 28 March 2012 (UTC)

Minecraft 1.2.4 Creeper Glitch[edit]

I was playing in Creative mode, then I spawned Creeper on the stone. Creeper exploded and destroyed only 2 stone blocks! At the other blocks like dirt, ice, cobblestone etc. explosion is bigger. Do you have the same? 213.195.145.245 21:35, 24 March 2012 (UTC)

It's called blast resistance, It's been like that for a very long time, certain blocks are harder to explode. Cultist O 06:36, 25 March 2012 (UTC)

New hidden feature?[edit]

After updating to 1.24, I've noticed that stairs can now be placed upside down on the bottom face of a block. I don't believe this was possible before. I only had a chance to test with wooden stairs (on a stone block ceiling) so far - can someone confirm? Is this a new feature that was added but not mentioned in the release notes? Thanks for any info. - VendettaGreen

It was added in 1.2.1, and applies to all stairs and all slabs. It is in the notes for that update. Cultist O 13:48, 27 March 2012 (UTC)

Trouble updating![edit]

I've been trying to update to 1.2.5 lately, but once I get on and click "Yes" to update, it gives me this message (this goes for force updating too):

FAILED TO LAUNCH

Fatal error occurred (4): Address family not supported by protocol family: connect

Could anybody help me with this?!

thingyguy 03:34, 5 April 2012 (UTC)

1.2.5 Bugs[edit]

  • On linux, we can't leave the chat when we use the "/" in message. Random chance of leave with "/exit".

hactarus 13:29, 5 April 2012 (UTC)

  • When you shift-click an object into a furnace with objects inside it, the game crashes.

Please report the bug here ->[[Known bugs/Version 1.2.5]] TTiscoming 14:21, 6 April 2012 (UTC)

Fence Gate issues 1.2.5[edit]

Fence Gate seem to close if open when a block moves next to them (I'm trying to make a fence gate elevator.)

This bug is older and not from 1.2.5. --RedMser 20:31, 7 April 2012 (UTC)

I do hear rain[edit]

"*Rain not producing any sounds" I don't see a problem with my game. I use 1.2.5 and for me rain DOES make sound. There is a bug where sometimes it won't spawn particles in some chunks, but that isn't this. This needs more testing - discussion! --RedMser 20:30, 7 April 2012 (UTC)

Old feature[edit]

it says for the new features in 1.2.5, that torches can be placed on top of glass. But I'm in 1.2.4, and i can place it on glass. so this needs to be moved.

ZeCraftyMiner 00:26, 12 April 2012 (UTC)

Wrong information[edit]

>> These can not be typed using vanilla clients. << For the special codes involving §. This is false because they can be typed using vanilla clients if you use a keyboard layout that has the character. For example, the US-International keyboard layout has it at Shift+Alt Gr+s while the Slovenian one has it at Alt Gr+m . I just tested it in Minecraft 1.1 for §k (random characters) and §0-§f (for colors) and I was able to type them fine and they worked. The §l-§o (also typed them fine obviously) don't work because they only exist in Minecraft 1.2.5. - 94.140.73.150 10:57, 21 April 2012 (UTC)

Edit: Seems you can type § fine in Minecraft 1.1 but not in 1.2.5 so this article is right. - 94.140.73.150 13:14, 21 April 2012 (UTC)

v1.2.5 Select Block Error[edit]

I was jacking around in the creative mode, and I noticed that when I clicked the "pick Block" button (default: Middle Click) on a sheep, it gives you a bedrock block. Can anyone confirm this bug? I would have thought they just made sheep/other entities unclickable with that key. SonOfBDEC 15:18, 29 April 2012 (UTC)

Ghost Blocks[edit]

ever since the dawn of this game there have been random moments where certain areas don't graphically represent what the player does to them, for example broken grass will still be visible or a planted sapling will be there but invisible. this combined with the lighting glitches that still exist make minecraft an often very ugly game. considering you can still come across problems like this where if you enter the wrong space the whole world around you randomly becomes invisible and you see only random mobs and underground lava... i'm finished with this game until it's fixed. it really is unplayable.

recently i also discovered a jungle tree leaf block that was visible that i could walk through, but i was also able to break it. i just don't understand anymore.

Restore link to upcoming versions.[edit]

Someone deleted it & replaced it with the Xbox version history link.

Keeping files when upgrading[edit]

Hello. Out of interest when you get an updated version of Minecraft, do you keep your worlds you already have or do you have them removed?

80.229.230.86 18:24, 26 May 2012 (UTC)

- be mindful not to double post. oddly only admins can delete the second post so it will be an eyesore for a while. i typically delete the world and start fresh because i play hardcore mode and before it existed i would delete a world when i died anyway. it's unnecessary most of the time because maps aren't really version specific for the most part, the majority of changes will take place in ungenerated chunks when you do enter them in an older world.

Sorry, the second pose was my fault with the server and submitting. Is what you mean that your created worlds will appear the same but new worlds will be different. 80.229.230.86 05:12, 29 May 2012 (UTC)

I do keep my worlds. BTW, Please sign your posts. Creepergoboom64 11:22, 15 August 2012 (UTC)Creepergoboom64

Next version?[edit]

I'm exited for it. Anyone else? Does anyone know when it's coming out? Sillyskittys 13:23, 10 June 2012 (UTC)

  • No release date yet: [3] "We'll release 1.3 when it's ready, but it can take 2, 3 or any number of weeks" [4]. To shorten the waiting time for V1.3, try the latest snapshot... --Kumasasa 13:35, 10 June 2012 (UTC)

Oh cool thanks. :3 Sillyskittys 13:36, 10 June 2012 (UTC)

Xbox Version updates[edit]

Will the Xbox version receive the same, if not similar updates to make it like the PC version? For example the adventure update? 67.242.132.185 19:49, 19 June 2012 (UTC)

Yes it will, but the 360 version is no where near the current PC Minecraft version is. Twixthehero 20:06, 20 September 2012 (UTC)

Beta 1.3 boat bug[edit]

boats will break lillypads but when a boat goes through more than 1 lilly pad it breaks and drops 2 sticks and 3 logs it does not drop a boat like the update says it is supposed. but it still breaks lilly pads but it is only good for 1 lillypad/use


                                 signed
                                      bmangt

1.3 Wolves despawn in SMP[edit]

The tamed wolves in SMP sometimes despawn. I don't know why this was removed, because it's been a common problem among people.

1.3 Bugs[edit]

I've noticed two bugs since the update. One being that when items are dropped (such as while using a melon harvesting system that uses sticky pistons) ghost items are dropped. They look just like regular items but I can't pick them up. Also, I've noticed that I eat food a lot faster, about twice the speed in the previous version. Anyone else notice these problems? 75.185.172.255 03:43, 2 August 2012 (UTC)

-When a player is pushed by water to a 2 high corner, the player will suffocate Danny~

I've had a bug similar to Danny's when walking between a zombie pigman and a wall when the zombie pigman is partially on the block next to the base of the wall. Pognet 14:27, 2 August 2012 (UTC)

I've experienced a bug during all singleplayer Creative Modes. I can access my inventory, but as soon as I click out, the game crashes. Never experienced it up until the latest update. Any advice?

1.3.1 Multiplayer-Like Lag in SSP.[edit]

Is there a way around this? I'm sick of punching animals and having them lag in midair like I'm playing on a 56k server. XZippy 21:42, 2 August 2012 (UTC)

1.3.1 BUG[edit]

Every time I am trying to fight a mob, they seem to be half way in the blocks, some mobs I cannot attack because of that, for example, a spider almost all the way disappears.

Also, I am getting hungry super fast now.

98.230.6.63 03:42, 3 August 2012 (UTC)

Um, What were you fighting, and what did you hit it with? I'd like to know so i can help. Creepergoboom64 11:20, 15 August 2012 (UTC)Creepergoboom64

1.3[edit]

I just started a new world yesterday and now when playing today and when i spawned in i felll through the world didnt die so i was stuck in the black nothingness

1.3.1 Chunk not loading after respawn[edit]

Chunks around respawn point will load but the one I am on when I respawn does not load until I reload the map.

1.3.2 bugs[edit]

1. Some of the blocks I have destroyed doesn't get picked up. Same thing with some apples.
2. When you have eaten and still have hunger left, the character eats one more "food thing" after you stopped pressing the right mouse key. (sometimes)
3. Sprinting through vines (in the swamp area) no longer slows you down (in the patch before you would run slower / stop sprinting when in collision with vines) please confirm.

4. When a LAN world is open, the Edit button is not locked and pressing it will cause the game to crash.

1.3.2 Fall Damage Bug[edit]

Fall damage seems to have gotten messed up, jumping from a platform 2 blocks high (a fall of 3 blocks) causes the character to take a half heart of fall damage. However falling 3 blocks with jumping causes no fall damage. I don't believe this is intentional, but I could be mistaken.

-First, please sign your posts. Second, it does seem that fall damage has been messed up, although your example makes no sense. I tested yours and you take damage in both cases. I noted: If you walk off a two block high platform, you take no damage, yet walking off a three high platform, you take damage and you're not supposed to. Twixthehero 20:05, 20 September 2012 (UTC)

bug[edit]

bug: iron golems spawners spawn golems on air (block 0)

Uh, Number one, you should put this on the bug page, number two, sign your post, please. Creepergoboom64 01:00, 16 September 2012 (UTC)Creepergoboom64

Customizable World Generation[edit]

It is said to be a feature in 1.4 but it is not (or at least not in the way mentioned in the citation). Only flatworlds are customizable, so:

Either remove the line or move the flatworlds description as the subpoint.

What happened to 1.4 and 1.4.1?[edit]

Is the update really from 1.3.2 to 1.4.2 without a few steps in between?
Oh, never mind, I just checked the main screen of Minecraft itself and it really is 1.4.2. I know it's their decision, but it should be noted somewhere the update has taken the pre release versions into account...
Leaving this here for not having other people repeat the same answer.
- TheOtherRetard 14:52, 27 October 2012 (UTC)

It's because they found too many bugs in 1.4 and 1.4.1 pre-release versions. It was actually the same in previous versions: they skipped 1.3 and released 1.3.1, they skipped 1.2 and released 1.2.1. Any intermediate version can be found in the Development versions subpage.
-- Fomtg 19:01, 31 October 2012 (UTC)
They didn't skip version or take the pre-releases into account. If everything went smoothly, 1.4 pre-release would've turned into just 1.4. If 1.4.1 pre-release was fine, it would've been just 1.4.1. They figured they had a final product, so skipped the pre for 1.4.2 and just released it. --Kanegasi C 20:49, 31 October 2012 (UTC)

Wasted Space[edit]

Why is the contents box pushed out by the box on the right on this page when it isn't on other pages? I'd go look in the wiki page src but it's protected... --GufNZ (c: 03:14, 1 November 2012 (UTC)

The "- Removed Herobrine" joke?[edit]

Should we include the "- Removed Herobrine" joke? metarmask 08:57, 4 November 2012 (UTC)

Newly compatible with computers that have Intel Core i3 previous generation whose running Windows 8[edit]

All is in the title : Minecraft is now compatible with computers that have Intel Core i3 previous generation (1st) whose are running Windows 8 24.203.182.185 01:57, 9 November 2012 (UTC)

Switching tools while mining[edit]

While playing in 1.4.5, on a 1.4.4 server, I noticed that I could no longer mine with my sword, and then quickly switch to torches to preserve my swords durability. I don't know if this was recent, but perhaps add it as a bug fix to be made?

Minecraft: Pi Edition[edit]

Should Minecraft: Pi Edition be added to the Version history nav? -- MinecraftMuffin 18:55, 24 November 2012 (UTC)

Once it's released and has a version number, yes. -- Orthotope 11:08, 25 November 2012 (UTC)

1.4.5 Leaves Stacking Bug[edit]

Haven't done much with leaves before now but I'm playing on a 1.4.5 server and I seem to have 6 different kinds of leaves from my tree farm after using a Silk Touch Shovel to harvest Birch, Spruce, and Oak trees (haven't messed with jungle trees at all). All 6 types stack separately:

1) "Spruce Leaves" that look like spruce leaves,

2) "Oak Leaves" that look like spruce leaves,

3) "Birch Leaves" that look like birch leaves,

4) "Oak Leaves that look like birch leaves,

and most confusingly,

5) "Oak Leaves" that look like oak leaves,

6) "Oak Leaves" that look like oak leaves but don't stack with the other "Oak Leaves".

Can anyone confirm? --Roachy 04:36, 9 December 2012 (UTC)

According to 1.4.6 release notes they fixed a leaves tooltip bug. My oddly unstacking leaves however were not affected. I'm guessing those individual leaves items will always be messed up. Haha! Now I have limited edition leaves! Roachy 12:25, 20 December 2012 (UTC)

Older version text there in edit but not visible on page.[edit]

Someone messed up when editing the Version history page. There's probably a tag in the wrong place or something as all the previous data is there but only the info for 1.4.5 and the references is actually visible.

Could a more experienced editor fix this please? I don't want to mess with such an important page

Lucifer_LLS 19:43, 9 December 2012 (UTC)

Sharpness to axes[edit]

You are also able to enchant sharpness on an axe using these books, not sure about picks or shovels. Although I would definitely take a sharpened shovel renamed "Shaolin spade" 71.178.36.123 21:44, 20 December 2012 (UTC)

Double Post of Bug in 1.4.5 notable bugs[edit]

The following bug was listed twice in the 1.4.5 notable bugs section:

The /enchant command not enchanting with ID 0 (Protection)99.43.132.231 12:46, 21 December 2012 (UTC)

1.4.6 Bugs[edit]

Hi guys, i found some bugs and can you please tell these to designers:

  • Red Mushrooms, Sugar Canes and spawners are not counting in block statics.
  • If i try to open my singleplayer map to lan, minecraft is hosting it on "0.0.0.0" ip adress.
  • Minecart has sound problems.--78.160.33.245 00:29, 28 December 2012 (UTC)
You can report them here--Moddie1000 ? 00:32, 28 December 2012 (UTC)

1.4.6.5?[edit]

I think there was a minor update after 1.4.6 that wasn't official or something. Up until a week ago, wall signs didn't reach the edges of the blocks they were attached to, but now they do... 63.152.64.237 15:33, 1 January 2013 (UTC)

1.4.7 is out...[edit]

I just got auto-updated. --Mental Mouse 14:30, 9 January 2013 (UTC)

v 1.5 bug - Baby mobs can't swim.[edit]

Baby mobs cannot swim (i.e. babies drown in 1x1 block of water) Go ti Mojang's bug page, and if you have an account, please vote for this bug so it will get fixed https://bugs.mojang.com/browse/MC-9388. Buzzaro 23:25, 25 March 2013 (UTC)

Minecraft Wiki isn't for advertising bugs. -- (T) Numbermaniac (C) 04:55, 26 March 2013 (UTC)

2.0 = April Fool's Joke?[edit]

Yeah, Minecraft 2.0 looks very believable, but it's April Fools Day, so it's likely it's a joke. Coal.png CS Sponge Revision 3.png 01:26, 2 April 2013 (UTC)

Summary readability[edit]

Currently we have something like 1.2 1.5 where 1.2->wiki division, 1.5 minecraft version
->could it be possible that the summary add the word Version between the wiki division and minecraft version numbers (1.2 Version 1.5) ?
--82.150.248.29 08:05, 10 April 2013 (UTC)

I thought the same. I don't know what to do about it though. -- Numbermaniac - T - C 08:56, 10 April 2013 (UTC)

1.5.1 Bug : Doors are invisible (half)[edit]

/give [Player] 64 OR /give [Player] 71

But it is invisible check MC-13422

--Minecraftaddict154 09:37, 11 April 2013 (UTC)