Minecraft: Story Mode has now been discontinued. If you already own a copy, make sure you download it before June 25 before the servers go offline, or else you may not be able to in the future. See here for more details.

Talk:Controls

From Minecraft Wiki
Jump to: navigation, search

F3 Toggle?[edit]

Since Beta 1.3, I have noticed on Ubuntu that F3 now toggles the information, whereas before it showed it while held in.

Also, using F3 (also on Ubuntu) shows a number above all mobs, like player names in SMP. This occurs in both Single and Multiplayer.

Olligobber 20:55, 26 February 2011 (UTC)

Did you not even read the page? "Pressing this key will toggle the showing of extra debug information on the top of the screen along side the Minecraft version, such as FPS (frames per second), chunk updates, available memory, and a performance graph. Before version 1.3 F3 had to be held down to show this info." –ultradude25 (T|C) at 23:53, 26 February 2011 (UTC)

F11 Fullscreen w/ multiple monitors[edit]

I've tried fullscreen and have two monitors. It always occupies my main monitor when fullscreened, no matter which screen the window is on. This may be an act of DisplayFision or UltraMon though, so someone else without these will have to give it a test. In addition, my monitors are offset from eachother (screen2 is on top of and about 70% to the left of screen1). --Sennyotai 00:48, 11 September 2011 (UTC)

Time Controls[edit]

They aren't working in 1.8.1 (or 1.8, for that matter) If no one responds or edits this (or even finds a new controller of time!) I will edit the page and move them to the removed conrtols section

-cake –Preceding unsigned comment was added by Cake (Talk|Contribs) 09:18, 15 September 2011. Please sign your posts with ~~~~

They were accidentally left in for the 1.8 pre-releases, and were removed for the full release. Also note that they do not actually affect the passage of time in Minecraft, but only the day/night cycle. ディノ千?!? · ☎ Dinoguy1000 04:45, 25 September 2011 (UTC)

Pick Block[edit]

Hello there. Pick block. What does it do? I can't find any documentation for it here in the wiki. Thanks! 200.51.92.142 14:35, 29 September 2011 (UTC)

If You have a Wood and a Dirt Block in your Inventory Bar, for example, you can select Wood/Dirt by look on a Wood/Dirt-Block in the World and then press the Pick-Button. 77.176.86.193 04:40, 1 October 2011 (UTC)
Except nothing here explains what key "pick block" is, or what it does. If the wiki redirects here it should mention it at least once. Frozenne 05:44, 21 October 2011 (UTC)
Not any more, I gave the page a much needed overhaul and fixed the redirect to anchor to the pick block key. –ultradude25 (T|C) at 06:24, 21 October 2011 (UTC)

Alt+GR[edit]

Anyone tried this? its like the old F8 function, but with zoom

--Drizak 21:29, 3 October 2011 (UTC)

F9 camera lock?[edit]

Hi in 1.9 Pre-Release 5 when ever i press F9 the camera locks facing straight ahead and usually turned, in the 3rd person your characters head is looking straight down and the controls seemed turned any explination? –Preceding unsigned comment was added by 68.99.140.209 (Talk) 07:32, 28 October 2011. Please sign your posts with ~~~~

Jeb unintentionally left those camera controls in the prerelease. [1]Toshu (talk) 07:35, 28 October 2011 (UTC)

'Computer'?[edit]

Um... For the time being, wouldn't 'PC' be fine? I mean, eventually add 'MAC', for sure. COME PYU TER is just so 'abacus' (that is:from Heb. abaq "dust," from root a-b-q "to fly off.")

& then, to be quite honest, the term 'computer' is kind of invalid. Is more 'terminal', that is, based on terms. Compute is more... well from etymonline (1630s, from Fr. computer, from L. computare "to count, sum up, reckon together," from com- "with" (see com-) + putare "to reckon," originally "to prune" (see pave).)

If anything, that would be the user, I think. Not that it is anyway topical....

The machine is a sort of causal nexus, it relegates the input/output. Not so much a 'computer'. Just a thought to think about...

'compute' is "with reckoning"

it is not computer –Preceding unsigned comment was added by 173.218.85.222 (Talk) 01:58, 9 November 2011. Please sign your posts with ~~~~

L-Shift + Left mouse click[edit]

Why is there no mentioning of the L-Shift button? Its way faster to tranfer and craft things that way. –Preceding unsigned comment was added by 82.215.56.151 (Talk) 13:47, 15 February 2012. Please sign your posts with ~~~~

Button 1,2, and 3?[edit]

When I was in my controls, I thought you CAN change the forward buttons,but unluckily, It turned out to be Button 2 in red letters. I was clicking some other controls and they came up to be button 1, or button 3. Can you tell me how to change it back to the NORMAL controls? 98.242.204.73 21:53, 13 March 2012 (UTC)MagesticMelody

When you click any of the controls, it's assigned the next key or mouse button pressed. It sounds like you're accidentally hitting other mouse buttons. Just click on it again and type 'w' (or whichever key you want to use). You could delete options.txt in your .minecraft folder, but that will reset all your settings. -- Orthotope 00:50, 14 March 2012 (UTC)
If you accidentally hit one of your mouse buttons after selecting a control, you can do 2 things:
1. reset all controls to deaufalt with the Deaufalt button
2. try again selecting a control

Found a way for the man to show up[edit]

Just press F5 to reveal him. –Preceding unsigned comment was added by 1.124.255.239 (Talk) 07:35, 26 June 2012. Please sign your posts with ~~~~

Found ? How in the world did you manage that ? Without reading the article Controls ? Wow ! --80.134.12.209 07:39, 26 June 2012 (UTC)
Yes, I was just playing around with the F-buttons. Dandelion2 –Preceding unsigned comment was added by 1.124.255.239 (Talk) 07:52, 26 June 2012. Please sign your posts with ~~~~

Are you trolling? This has been known since ALPHA! if it's not on the wiki I will fix Russell4 02:38, 29 July 2012 (UTC)

EDIT: ok it IS on the wiki,did you not read the page? everyone knows this... Russell4 02:39, 29 July 2012 (UTC)

For your information, I know nothing about trolling or alpha. I just posted this in case my friend [He doesnt know how to get the man to show up] would see it. I know this is face-palm info, but I never realized that it would be on the wiki. So yeah, sorry to waste your time.

how to trade?[edit]

i know this is probably a face-palm question, but for some reason i can't interact with traders. everything on the internet says to right-click, but nothing happens. please help? –Preceding unsigned comment was added by 86.134.8.9 (Talk) 22:48, 23 July 2012. Please sign your posts with ~~~~

You need to be using snapshot 12w21a or later; it won't be in the release version until 1.3 comes out. -- Orthotope 00:54, 24 July 2012 (UTC)

1.3 version has come out, and I tried trading on Survival and Creative, nothing happened. And if I'm supposed to download the new update then what do I do?

Well, you could have changed Use Button to something else. Press esc - Options... - Controls... If Use Item is set to Button 2, then well. Oh, and on some computers (mine for example) you have to press with two fingers to right click.

Another possibility is that you don't have the version needed.--62.242.64.212 13:32, 4 January 2013 (UTC)

How to return the controls to default[edit]

I am a video game noob and my trusting boyfriend left minecraft downloaded on my computer. I am allowed to play offline on his account whenever I like. However, when I was trying to view the controls I foolishly switched half of my controls to "button 1." I have no clue what that is but now I can't move in the game. Will these changes affect my boyfriend's overall game on his computer? And how in gods name can you switch back the controls? Please help me ._. –Preceding unsigned comment was added by 69.41.10.10 (Talk) 16:28, 9 August 2012 (UTC). Please sign your posts with ~~~~

To change a control, click once on the button showing the current key for that control. The next key or button you press will be assigned to it. Alternatively, you can delete the 'options.txt' file in the .minecraft folder, which will reset all the preferences. This won't affect the savegames, but he might have to re-configure the preferences if they weren't left at default settings. -- Orthotope 19:21, 9 August 2012 (UTC)

^^^All this is true, but first, you need to press Esc (usually at the top left of the computer), then press Options..., and then Controls..., and then you do what Orthotope said.--62.242.64.212 13:36, 4 January 2013 (UTC)

Pick block key[edit]

Pick block key explanation is out-of-date. It still argues about picking entity gives bedrock! Someone should fix it. I tried to fix it myself, but when I used preview fuction, well, it gave me corrupted result. Kevin J Rattman 18:18, 19 August 2012 (UTC)

Problem With Tab/Playerlist Key?[edit]

I've discovered that holding TAB or the Player List key will block up-right movement (default W and A) but will not impede any other diagonal movement. Is this worth mentioning in the article? I think it's been happening since 1.1 or 1.2 but I can't honestly remember; I know it has been happening since at least 1.2.5 or 1.3.1 (I honestly can't remember). If anyone knows any more about this, I'd like to know.

Mac controls[edit]

There is a lack of it. There is no F2 button on macs, what's the button for that them? --Gil2455526 21:55, 4 November 2012 (UTC)

Alt-shift[edit]

This does not work for me. I suspect it may be an OS 'sticky key' feature, and not actually related to Minecraft. -- Orthotope 13:13, 8 December 2012 (UTC)

XBox 360 Controller with PC[edit]

I've been told you can play it on PC with a 360 controller, and wonder if and how much the controls differ from the 360 Edition. Could somebody who knows please add a section or page for it (I also have no idea how to get the 360 controller properly hooked up to a PC in the first place, so info on that would help as well)? 208.93.223.162 03:04, 24 February 2013 (UTC)

Configurable controls issues[edit]

The left and right button section has issues. I don't know exactly what, but I do know that the descriptions given don't match reality.

I have all of pick block, attack, and use block rebound to keys. There are still cases where I need to use the mouse.

In other words, some of the actions listed under the left and right button as configurable are NOT configurable; other actions are configurable.

Specifics:

1. Wiki: Attack/dig/Button 1: Attack entity or block -- configurable. "Split stack evenly" -- I can only make that happen with psycial right mouse button. Sort loose items into one stack -- I cannot get that from either double physical click, nor double press of the bound key. Method of testing: 5 loose items in my inventory, expected to see them combine into one stack in inventory.

2. Game play: Physical left button is used to move objects in/between inventories. Physical shift (either; both shift keys are mapped to different commands)-physical left click is used to move a stack between different inventory zones (i.e.: into a furnace or chest).

3. Wiki: Use/Button 2: Place blocks; toggle switches/doors (click once), fire with a bow; block using a sword; use special blocks like chests, doors, and switches; enter vehicles.

Also: Eat food, hoe farmland, shear sheep.

All of those actions are associated with the rebindable/configurable key.

Place one item from a stack in each inventory slot (hold and drag) -- This I cannot get to work no matter what I try.

4. Gameplay: Physical right-click on an inventory stack while empty: Pick up half of the stack. Physical right click on an inventory slot while carrying something: Drop one item in that slot if it can go (either empty destination or stackable item)

5. Button 3/middle/pick block: Wiki: Seems to document the older 1.2/1.3 behavior: replace the active block even if there is an empty space (1.4's behavior, for me at least, is to use an empty spot if possible). Equally, in creative, I no longer match the resource of the block; I match the block itself (so grass does not match dirt, and stone does not match cobble).

Definately re-mappable (no physical middle click on this laptop.)

6. "Hovering over an item in an inventory and clicking with the mouse wheel when in creative gives the maximum stack of that item." -- WOW, that does work, with the rebound key. (silly me, first test was not in creative :-).

Keybounce 01:49, 5 March 2013 (UTC)

How Do You Fly?[edit]

In my case, As a Beginner, I didnt know how to fly and it didnt tell you soooo, I did all this research and I figured out that you have to double tap the Space bar to fly. Then to go up it's Space and to go down it's Shift. --68.60.32.24 02:48, 9 May 2013 (UTC)

Creative#Gameplay Kanegasi C 04:23, 9 May 2013 (UTC)
Additionally, the page which you posted on tells you exactly this... ultradude25Talk
Contribs
05:09, 9 May 2013 (UTC)

CTRL and Q[edit]

CTRL and Q will drop all items in hand, like a stack of dirt in hand, CTRL and Q will drop all 64 of them at once. --94.209.244.74 17:13, 5 July 2013 (UTC)

F10 - Left Alt[edit]

Can the entry for f10 be moved to 'Old Keys' as it was a bug that has since been fixed See here

Webchimp 11:47, 3 September 2013 (UTC)

Controls customization in 13w37a+[edit]

As of snapshot 13w37a most of the "Uncustomizable Controls" are now customizable. A note could be added about that. --88.115.80.47 13:27, 21 September 2013 (UTC)

PlayStation Edition[edit]

Are the Controls for the PlayStation Edition the same as these for the Xbox 360 Edition? I actually don't think so, but why aren't they in the article? | violine1101(Talk) 21:32, 3 November 2014 (UTC)

Configurable shift+key Options[edit]

Is there a way to edit the controls so instead of only one key being pressed, two keys are required? Such as instead of "t" for chat, having "shift+t". This would be incredibly helpful for non vanilla Minecraft. Th3l0stSpart4n (talk) 22:36, 21 November 2014 (UTC)

It is not possible, although if you are using mods one may add or you could get a mod that adds that feature. KnightMiner (t·c) 03:51, 22 November 2014 (UTC)

Anyone got a good idea how to add this?[edit]

This is what it says for taking a screenshot on MCPE:
Hold the Home button and Lock at the same time (iOS) or hold Volume Down and Power at the same time (Android). Android devices will save the screenshot to your Gallery and iOS devices will save the screenshot to your Camera Roll. Only works on iOS 4.0+ and Android 4.0+

Someone should add that taking a screenshot on Android isn't allways the same, on some devices its not "Vol Down + Power" so it should say to google your device: "device name take a screenshot"
I have no idea how to add this! –Susko3 (talk) 21:33, 11 June 2015 (UTC)

 Denied The control you are thinking of is not specific to Minecraft. 71.212.10.80 23:01, 11 June 2015 (UTC)
Since this is a feature of the iOS or Android operating system, not part of Minecraft, I don’t think we need to mention it at all. — Orthotopetalk 23:30, 11 June 2015 (UTC)

Lack of clarity[edit]

This article is good but at some points there is a lack of clarity Clarity is a important thing guys, maybe many readers are super-gamers but there are even some people that don't know this topic(keyboard controls), so please EXPLAIN what you say in a wiki. Keep it simple yes, but not even too much.

Just look here:

On 1.1(computer=> non-configurable controls), at Shift controls, when the article talks about using shift with a container scenario there is written:

"If you Shift + double click you can move all = items." So, what I've got the first time I've read it is that using shift + double click all items would be moved to chest(yeah, considering "=" as a typing mistake, that's what you understand). It's not implied that "=" stands for equal. But the real point is why use "=" instead of say equal or even say "items of the same kind", that would be even better This instead is clear => "To move all items of one kind into a chest from your inventory (and vice versa), pick up any item, hold ⇧ Shift, and double click one of the items (or a stack) of the items you want to move." , and even this "By holding ⇧ Shift and double-clicking while holding an item, all items of a type clicked on will be moved into or out of the chest." (both are taken from minecraft.gamepedia.com) And actually, now I notice even the term "container" isn't so clear, and clicking on the link it opens just the "Inventory" page.........

Just do a google search to find very long topic about these issues, and these issues are caused by lack of clearness on pages like this. Remember that not many people will look the entire "gamepedia" to find an answer.


PS for who hasn't got the minecraft gamepedia article about minecraft game controls: For what I got, the sentence that lack of clearness stands for "If you press Shift and Double Click you can move all equal items". To better-explain I wants to quote "David Toh" from stackexchange: "To put this into a scenario, if you have a chest entirely filled with ONLY iron ingots, ALL the iron ingots will be transferred to your inventory is you were to ⇧ Shift and double-click one of the IRON INGOT STACKS.

However, if there were blocks of sand mixed up with the ingots, and you were to ⇧ Shift and double-click a stack of IRON INGOTS, all the iron ingots and ONLY the iron ingots will move into your inventory, leaving the sand behind."

I won't reply, nor I will se if something will change, this is just an invite to the writers of this wiki. Finally, I want to say that minecraft is a videogame, not a subject of studying. The articles here should be simple. Simple doesn't mean short, mean just simple.

--151.40.172.6 23:21, 16 February 2016 (UTC)

 Done. —Fenhl 00:39, 17 February 2016 (UTC)
Rather than writing this lengthy diatribe, it would have been more productive to simply make the improvements you want to see yourself. -- Orthotopetalk 05:41, 17 February 2016 (UTC)

Wii U Edition[edit]

I felt that this article is outdated. Can someone please add the Wii U Edition controls to the article? Probably need to upload Wii U button assets as well. --172.68.2.172 12:19, 28 June 2016 (UTC)

 In progress: added a {{wiibutton}} (aka {{wbtn}}) template complete with graphical assets.
Todo: Does anybody know what the controls even are? – Sealbudsman talk/contr 02:29, 1 July 2016 (UTC)

Fixing incorrect links[edit]

 In progress: Found 2 incorrect links. (Progress: my User page)
Todo: If anyone wants to help me, please check if links from What Links Here -mainly Edition ones- are directing to the correct subsection on this article. Feel free to fix them! TheLOLxd2 (talk) 12:31, 31 December 2018 (UTC)

Nintendo Switch + (Plus button) does not pause the game[edit]

Per MCPE-28037 this Works As Intended but differs from the usual expectation for the console owners. When “paused” using the + button the game continues, time passes and the player is subject to being killed by mobs. Using the Switch “Home” button has the same non-effect, the game continues in the background.

The wording on this page should be changed for both the Plus and Home buttons. Ctgreybeard7684 (talk) 13:53, 13 January 2019 (UTC)

[Switch] X button drops a stack when holding it in Inventory[edit]

I'm not sure where to add this but I discovered that when the Inventory is open and you are holding a stack the X button will cause the entire stack to be dropped. This is a great shortcut to using the Down button to drop single items.