Minecraft Wiki talk:Issues/1.3.2

From Minecraft Wiki
Jump to: navigation, search
Notice
The Issues page for the full version is located at Issues/1.3.2

Page Redirect[edit]

Why is "Known Bugs/Version 1.3.2" being redirected to "Issues"? Also, the page formatting since the redirect is wonky and the links to in-line images are broken. --KADC - "Be unreasonable." 10:07, 31 August 2012 (UTC)

What the #$%& is wonky? -oplopy1234

1.3.2 / 1.3.2 pre?[edit]

There's a 1.3.2 out? Yoshidude56 22:24, 14 August 2012 (UTC)

There's 1.3.2 pre, which presumably will be byte-for-byte identical to 1.3.2, (as happened for 1.3.1 and 1.3.1pre). Assuming that's true, perhaps 1.3.2pre ought to redirect to this page. That would save having to migrate the bugs across in a few days. --82.69.54.207 13:16, 15 August 2012 (UTC)

They are one and the same. In fact, I have no idea why anybody is waiting to update mods (Risugami in particular) thinking that somehow something is going to change between the pre-release and the full update when Mojang already made their intentions very clear. For the purpose of this page, the bug reports should definitely be merged. --Robert Horning 21:00, 16 August 2012 (UTC)
  • Oh, good. Nothing to merge then; 1.3.2 and 1.3.2pre both point to the same place already. --82.69.54.207 21:03, 16 August 2012 (UTC)

Old bugs[edit]

If there are bugs from previous versions of the game that aren't apparently fixed, should those bugs (after verification in the current version of course) be reported for the current version of the game? Should outstanding bugs that haven't been fixed over several versions be marked up in some way to note that they are perennial bugs that aren't getting fixed? --Robert Horning 21:06, 16 August 2012 (UTC)

  • I've just started reporting bugs and am wondering this as well. Should I go back through each version to try and find the bug I'm reporting or just report it against the current version (if the bug still exists of course)? --Denney 13:55, 17 August 2012 (UTC)
  • I tend to take an ad-hoc approach, re-reporting old bugs whenever they inconvenience me again sufficiently, but not every time I see them for every last weekly release. Too much hassle.
  • We pretty much have to take it on trust that the world's Jebs and Dinnerbones are familiar with all the bugs reported. Still, if a bug keeps getting reported, then clearly it's regularly affecting a lot of people and annoying them enough to take action. So the system is a bit of a mess, but it sort of self-regulates; recurrent, intrusive bugs regularly get re-reported, but rarer bugs are re-reported less often. Using a wiki as a bug tracker is a bad idea in the first place, and we've complained about that before too. I don't have the citations handy, but Mojang do know that using a wiki as a bug tracker is... let's just say sub-optimal, and there are supposed to be plans afoot to adopt a proper bug tracker at some point. Complaining on the relevant Mojang Twitter feeds might help prod them into action. It's some time past due IMV. --82.69.54.207 18:56, 17 August 2012 (UTC)
  • I only report bugs for full releases and not snapshots because I don't really play snapshots so I guess reporting the bugs for each version is probably best for me. --Denney 05:43, 19 August 2012 (UTC)

Resolved issue[edit]

So I play on a Mac, when I got 1.3 I went into creative mode in a new world to check out the new stuff, The Emerald Ore block was pink, the Emerald block was a wooden block basically, Emeralds were invisible, Tripwire hooks are a pink screen, and the new books you can write in are invisible too. Please fix this!!

  • Your texture pack is out of date. Update it to one that matches the current game version and you will be fine. DarkWolff 14:03, 17 August 2012 (UTC)
  • Moved from bug page because it's unnecessary, was in the wrong section, tagged incorrectly, and already solved. --Keithicus420 16:27, 17 August 2012 (UTC)

[X] - World MpServer Chunk Stats: MultiplayerChunkCache: 35 - Forced Entities: 16 total; [jz['Painting'/162, l='MpServer', x=17.50, y=39.50, z=-484.06], jz['Painting'/160, l='MpServer', x=21.50, y=39.50, z=-484.06], jz['Painting'/161, l='MpServer', x=19.50, y=39.50, z=-484.06], jz['Painting'/159, l='MpServer', x=21.50, y=39.50, z=-488.94], mr['Mooshroom'/163, l='MpServer', x=20.53, y=64.00, z=-479.63], jz['Painting'/162, l='MpServer', x=17.50, y=39.50, z=-484.06], jz['Painting'/161, l='MpServer', x=19.50, y=39.50, z=-484.06], jz['Painting'/158, l='MpServer', x=19.50, y=39.50, z=-488.94], jz['Painting'/160, l='MpServer', x=21.50, y=39.50, z=-484.06], jz['Painting'/157, l='MpServer', x=17.50, y=39.50, z=-488.94], atg['oplopy1234'/174, l='MpServer', x=13.49, y=39.62, z=-487.32], ju['Experience Orb'/152, l='MpServer', x=439.00, y=1285.00, z=-15622.00], mr['Mooshroom'/153, l='MpServer', x=14.38, y=64.00, z=-473.34], jz['Painting'/157, l='MpServer', x=17.50, y=39.50, z=-488.94], jz['Painting'/158, l='MpServer', x=19.50, y=39.50, z=-488.94], jz['Painting'/159, l='MpServer', x=21.50, y=39.50, z=-488.94}} - Retry Entities: 0 total; []

java.lang.NullPointerException at avz.a(SourceFile:29) at awa.a(SourceFile:29) at awa.a(SourceFile:14) at avy.a(SourceFile:168) at aul.a(SourceFile:64) at aub.b(SourceFile:115) at auw.a(SourceFile:801) at auw.b(SourceFile:685) at net.minecraft.client.Minecraft.J(SourceFile:607) at net.minecraft.client.Minecraft.run(SourceFile:535) at java.lang.Thread.run(Unknown Source) --- END ERROR REPORT a34f58a8 ----------}}

Pleez help!!! –Preceding unsigned comment was added by 69.211.136.75 (Talk) 22:17, September 5, 2012 (UTC). Please sign your posts with ~~~~

Ender Dragon is now a ghost?[edit]

I made it to the end today for the current world I am playing, 1.3.2 vanilla, seed: Mojang, only to discover that I may not ever be able to defeat the Ender Dragon.

I dug down a few blocks and started on a tunnel. I went to the nearest tall tower and climbed it from the inside. I destroyed the crystal and then used a bow and arrows to destroy the crystals of near by towers. Then I descended the tower. I started to extend my tunnel in the direction of the next tall tower and died almost immediately. I was even wearing full iron armor.

Slightly confused I ported back to the end and went to pick up my dropped items. Then I went to put them in my chests; however, part way through the process the Ender Dragon attacked me as though the ground above me wasn't even there. It destroyed my chests and as a result I lost several items, including some diamond armor, a diamond sword, and several healing 2 potions.

At this point I was very upset, as I'm sure you can imagine, but I wasn't about to let that be the end of the fight. So, I dug down another 25 blocks and started to stash my stuff there. Once again, the Ender Dragon swept down and killed me, destroying my chests as well. That was 27 blocks down and the dragon was still able to attack me.

I logged out shut down the computer and then restarted and logged back in only to be killed by the Ender Dragon once more. Seems to me like this would be a bug. Am I wrong?


-131.191.13.85 09:16, 8 September 2012 (UTC)

I do believe it was intended that the Ender Dragon can phase through blocks to get you. Don't try to stash anything or even build in The End until it is defeated. --User:Kanegasi User_talk:KanegasiSpecial:Contributions/Kanegasi 09:06, 11 September 2012 (UTC)

Minecraft bug, found in it's source code[edit]

I'm not quite sure, where should I post some info on the bug I found recently in Minecraft's source code. So, I'm asking for your advice, what should I do with that issue?
About the problem itself: recently my friend had a great bug in minecraft server while he and another 2 players where online. After reloading server there were lots of graphical and server glitches, and some chunks in the world were missing (not on the client side, but also for every connected player, so it was the problem with the server). I was examining the code and found out, that there is small but stupid bug in chunk relocation code in case of errors. That's what minecraft says when that happens:
Chunk file at -42, -42 is in the wrong location; relocating. (Expected -42, -42, got -10, -10)
And the relocation simple doesn't happen. As it's forbidden to post mojang code on the Internet, I could say that there is a wrong tag used to store new chunk position, file Minecraft/common/net/src/AnvilChunkLoader.java, line 95. It could be really easily fixed. So, what should I do with that?
--Kabbi 14:00, 12 September 2012 (UTC)

Post it as Major Bug, and say "that there is a wrong tag used to store new chunk position, file Minecraft/common/net/src/AnvilChunkLoader.java, line 95." --Spy227X 13:19, 6 October 2012 (UTC)

1.3.2 Chunks still not loading[edit]

I have updated my Minecraft game to patch 1.3.2 and I am still having a chunk loading issue. Every time I start a game, be it an old saved game or new game on any type of map, the chunks in front of me do not spawn correctly. I am able to see the tunnels and lava flows beneath the ground in front. As I walk, the top part of the chunk beings to spawn, but then I am able to see the under-earth of the chunks ahead of me.

Items also keep randomly spawning on the newly spawned terrain, including apples, saplings, seeds and flowers.

What do I have to do to correct this issue? I want to play Minecraft, but ever since 1.3.1 I haven't been able to play due to the loading issue.


Alorxico, Mage and Mischief Maker 05:09, 19 September 2012 (UTC)

Half Blocks and Pickaxes[edit]

Since the page is corrupt I am putting this here.

I am well aware of a bug involving wooden half blocks requiring a pickaxe to be broken. However, I thought this was fixed when colored wood half blocks were added. Today, I tried to break a wooden half block with an axe, and had to use a pickaxe. It makes me question whether this was ever fixed, or if it has returned for some reason.

--Olligobber 08:21, 20 September 2012 (UTC)

Wood slabs created prior to 1.3 remain the old 'stone' type; only ones made after that update can be harvested with an axe. Some map editors may be able to convert all the old ones automatically. -- Orthotope 17:40, 20 September 2012 (UTC)

EDIT

I derped, this is not an issue, it just seemed to take a while with the axe.

--Olligobber 09:11, 21 September 2012 (UTC)

  • There is single player commands, one certain command allows you to replace a certain kind of block with a certain kind of block withing a certain distance form the block the player is standing on. Trigger hurt 15:31, 6 October 2012 (UTC)

Missing ".minecraft" folder[edit]

Hello My name is hiddenblade38. I accidentally deleted my .minecraft folder. And i re downloaded minecraft to see if would come back. It did not. If you know how to fix this please contact me at hiddenblade38@gmail.com. Thank you.

minecraft crashes even after deleting and reinstalling minecraft and forcing update.[edit]

i recently tried downloading a mod but it didnt work, so when i tried to play again without a mod it didnt work. I can create new worlds but not play on saved ones. my saved worlds have been copied and pasted a lot (i dont know if this has anything to do with it). Here is my error report:

--- BEGIN ERROR REPORT aee264d2 -------- Generated 9/25/12 10:46 PM

- Minecraft Version: 1.3.2 - Operating System: Windows 7 (amd64) version 6.1 - Java Version: 1.7.0_07, Oracle Corporation - Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation - Memory: 469943296 bytes (448 MB) / 514523136 bytes (490 MB) up to 954466304 bytes (910 MB) - JVM Flags: 2 total; -Xms512m -Xmx1024m - LWJGL: 2.4.2 - OpenGL: AMD Radeon HD 7560D GL version 4.2.11472 Compatibility Profile Context, ATI Technologies Inc. - Is Modded: Probably not - Type: Client - Texture Pack: Default - Profiler Position: N/A (disabled)

java.lang.RuntimeException: Failed to check session lock, aborting at aeb.h(SourceFile:49) at aeb.<init>(SourceFile:35) at adx.<init>(SourceFile:16) at ady.a(SourceFile:78) at net.minecraft.client.Minecraft.a(SourceF… at apq.e(SourceFile:142) at apr.a(SourceFile:189) at app.a(SourceFile:176) at apq.a(SourceFile:162) at auw.b(SourceFile:706) at net.minecraft.client.Minecraft.J(SourceF… at net.minecraft.client.Minecraft.run(Sourc… at java.lang.Thread.run(Unknown Source) --- END ERROR REPORT 4a8c5a0e ----------

[Edit]- Hey, its me again. i made an account. it seems to me that it is a problem with the saves. I created a new world and it worked. i exited minecraft and tried going on the new world again and it worked. is something wrong with my saves? --Blockmaster18 04:40, 26 September 2012 (UTC)blockmaster18

[Edit 2]- Hey, once again, its me. I replaced all of the dat and lock files (with working files from a new world) on one of my saves and it spawned me in one of my saved worlds in a really glitchy way. I backed up the old dat and lock files, but i seem to have randomly spawned without any of my items. I think i will try placing on the session lock file now, since that seems to be the problem.

[Edit 3]-It is very challanging to uncorrupt. I tried replacing all files, and then i tried replacing just the session lock. It both doesnt work. It takes a while to load, and then it seems as if though i drop from a huge distance, only to find myself in a random location with no items.

[Edit 4]-I tried replacing everything except the data itself. It seemed to put me in the same location as when i first tried replacing just the dat and lock ones, with the same glitchy nature. I'm going to bed now. if anybody can help that would be great since this is really bothering me. I really dont want to lose these worlds that i have worked so hard making.

[Edit 5]-I deleted session lock and played a game without it. it seemed to work in one of my worlds, although i was in a place i have never seen before. I tried it again on another world, and i was in the SAME EXACT PLACE. It was really weird. I dont know what to do at this point.

[Edit 6]-I deleted session lock on a copy of an unaltered save. It worked and i could play on my SSP as normal. But when i exited and came back, it didnt save what i did.

1.3.2 Minecart Bug[edit]

If you are sitting in a minecart in nether and your computer is a little laggy (Multiplayer)your minecraft can freeze and after about 3 seconds you will start get hitted, and it will not stop before you jump of the minecart and if jump of it then you get hurted you will see fire around you. I dont know how this work but it is like it come lava on you even if you cant see any lava. After a wile you will die i dont know what this is but it is really anoying for me then i die every time i am in the nether and driving on a minecart. I dont know if it is a hafl slab bug becuse i use half slabs then i made it so i didnt need to use so much stone bricks.

Sorry the bad English!

  • Just to clarify for other people what he is saying:

If you are sitting in a minecart in nether and your computer is a little laggy (such as multiplayer) your minecraft can freeze and after about 3 seconds you will start to get hurt, and it will not stop until you jump off of the minecart and if you jump off of it then you get hurt and you will see fire around you. I dont know how this works but it's like lava is pouring on you even though you can't see any lava. After a while you will die. I don't know what this is but it is really anoying for me because I die every time I am in the nether and riding a minecart. I don't know if it is the half-slab bug because I use half-slabs so I waste less stone bricks.

Sorry i'm a bit of a grammar Nazi! And I do believe that this may have something to do with the slabs. Try mining the slabs around the point you start dying. if there is netherrack below it all, mine the netherrack a few blocks down, but not straight down. This is to see if there is any lava underneath all that netherrack. if there is: We've found your problem! Also please sign your posts with four tildes. Trigger hurt 13:02, 28 September 2012 (UTC)

  • If lava is underneath there, try covering the lava up. This will stop the burning because client side you are not sinking but the server is forcing you to. Technically singleplayer is multiplayer so this applies to both. Basically, you are sinking into the below ground, because of the slabs. Try to use dirt, since it is common in the overworld, instead of slabs if it is impossible to cover the lava below, if it exists.
  • If no lava exists underneath, try mining the ceiling if it directly above you in some way. If lava pours down, immediately cover it, and mine the entire track and set it about 2 block into the ground.
  • If lava exists in both spots above and below you, try just simply moving the track if it is impossible to cover the lava. Trigger hurt 13:12, 28 September 2012 (UTC)

Bug.[edit]

This bug was deleted by accident:
"[X] A bug that used to be only in multiplayer but is now in singleplayer due to the 1.3 client-server architecture change: The spherical area that the player has to be in for monster spawners to become active is shifted skywards by a distance of two blocks. The monster spawner's glowing particle effects are tied to the correct sphere, so from certain positions it can be confusing to see the spawner apparently active but never spawning any mobs."
It was under Gameplay (Bugs part to be precise). Can't re-add it because browser fails to submit it. Polaris 15:41, 28 September 2012 (UTC)

Changes do not save after logging out[edit]

The game is working good, no issues or bugs that stop the game from being played. Untill I 'save and quit the game'. Whenever I log back on, some changes I've made are gone. I'm not using mods or

a few examples: Making a farm, logging off an back online, the farm is gone. putting stuff in chests, logging off an on, stuff in chest is gone. putting torches in the caves, destroying spawners, building stuff, etc. the same thing.

91.182.134.77 08:10, 29 September 2012 (UTC)

  • Well, i can suggest something: Whenever you hit escape, it autosaves after a couple of seconds, it says in the bottom left corner. Wait for that to go away, then try save and quit. Trigger hurt 16:58, 29 September 2012 (UTC)

crafting table bug??? wtf[edit]

crafting table wont craft ladders, piks, and other objects. ? how do i fix? 24.231.30.81 18:50, 13 October 2012 (UTC)

Is this lag related? Does it crash your game? Trigger hurt 15:33, 15 October 2012 (UTC)


No crashing is not a problem. Every time this happens I have to delete and install all over again 24.231.30.81 01:57, 18 October 2012 (UTC)

What OS do you run it on? Mac? Linux? PC? Trigger hurt 10:21, 18 October 2012 (UTC)

Uhm...[edit]

Okay, so about an hour ago i was playing in my single player hardoe world, i entered the nether, but when i returned every block was invisible. Entities were not invisible, if it happens again i will grab a screenshot. I had a small fort with an enchantment table in it, when going inside it and moving to a certain position, part of my fort was visible, the enchantment table was, my bed was, and about 3/4 of the entire thing was. I was using a school computer, so this may be lag related. I tried exiting the world and rejoining, same issue. Tried a full restart of minecraft, still present. Render distance was irrelevant, i tried it on all renders. Right before this happened, blocks' textures were not updating, like how sometimes you open a door but it still appears to be closed. It would not update. This is the kind of reason i think technology hates me, but i love technology. Trigger hurt 14:12, 16 October 2012 (UTC)

minor bug[edit]

I found a bug. I made a long telegraph wire with red stone and red stone repeaters. When I flip the switch to turn it on, it works for a certain length, but after that the current stops at one of the red stone repeaters. When I destroy the repeater and replace it, it works. Then, when I turn off the switch, the red stone turns off to a certain length, but after that the rest of the red stone repeaters stay on, unless you destroy and replace the repeaters. My long telegraph does not work, even though I did it all right. (my computer is MacBook Pro, bug on single player world, not on browser)

Somewhat weird[edit]

I have a glitch when skeletons start shooting arrows somewhere even there is nothing there. creepy... somewhat... I think in creative mode:that dying in the void is a big glitch everyone has.

--192.168.98.65 08:17, 19 May 2013 (UTC) I might have more to share... This can get annoying.