Czech, Thai, and Turkish language wikis are now available. Please help with translating!

Issues/Weekly 12w41a

From Minecraft Wiki
Jump to: navigation, search
Read this
Mojang has an official bug tracker and does not track bugs for any editions of Minecraft on this wiki. Please use the appropriate bug tracker to report and view current bug reports.

PC: bugs.mojang.com/browse/MC.
Pocket Edition: bugs.mojang.com/browse/MCPE.
Console Edition: bugs.mojang.com/browse/MCCE.


For further info, see the issues notice page.
Do not delete this page, any issues currently being recorded are purely for archiving purposes.
Issues
Full releases
Pre-releases
Weekly releases

Crashing/system[edit | edit source]

Bugs

[!!] [SMP] Windows Possible memory leak while playing multiplayer resulting in server crash. Both players were just walking to other areas of the map when it happened and it doesn't happen when no one is on the server. This also happened with the previous snapshot. DarkWolff 01:51, 12 October 2012 (UTC)

  • I saw this happen in the previous snapshot. Using the Java 7 G1GC garbage collector (Windows environment variable: JAVA_OPTS=-XX:+UseG1GC) helped keep the CPU from high utilization. In the current snapshot with G1GC enabled, I have not observed an OutOfMemory situation.--Inertia 05:35, 12 October 2012 (UTC)


[!!] [SMP] Windows Running a server with new anvil. Anyone that tries to rename or use the anvil crashes the server. Tested several times it seems that the crashing actually happens after deleting the last character on an item to rename it plus some other uses of the anvil. Further tests are needed. The crash report from server log reads as so --Gazeofdisaster 15:34, 11 October 2012 (UTC):

  • [!] [SMP] Linux Getting same problem, but server does not crash. Just kicks out that one player that tried to rename an item.

--MuttJunior 15:52, 11 October 2012 (UTC)

  • (Merged duplicate --Kumasasa 19:39, 11 October 2012 (UTC) ) Removing all characters in Repair & Name will disconnect and throw an exception. – xPaw at 14:47, 11 October 2012 (UTC)
  • A temporary workaround was found for renaming items. Go to the beginning of the word type in a place setter (first letter of what you want to rename it) then press the delete key to delete all characters in front. This crash only results from someone deleting all the characters in the rename path. --Gazeofdisaster 16:17, 11 October 2012 (UTC)

[!!] [SSP] Windows Attempted to dispense a lava bucket into an upside down stone brick stair block, got thrown a server tick exception.

[!] After staying in a world for a long time idle, (e.g. 4 hours), all mobs will not despawn but remain in the world as ghost, non-interactable entities that lag the game to the point of being unplayable. It's actually very creepy, walking around during the day passing by creepers that don't move or blow up. It's like time was frozen....

  • I observed a zombie that would not move and could not be killed by my player. But a iron golem had no trouble killing it. --Inertia 05:30, 12 October 2012 (UTC)


Annoyances

[A!] Despite running a server with 3G of memory allocated (with only 1 person connected) the host will disconnect several times with connection lost errors for random reasons - especially in the nether/hell. Reasons are unknown except maybe a client memory issue. Server keeps running, client crashes. --Gazeofdisaster 15:35, 11 October 2012 (UTC)

  • Can you post the messages received? Do these disconnects occur even on small or tiny render distance? This may be related to a clientside performance issue I am currently researching. --Martok 21:37, 11 October 2012 (UTC)
* I fixed the problem because minecraft itself was not using the java command -Xmx4096M or -Xmx4G. I ended up having to create a .BAT file to failsafe launch the game with more memory. This seems to have fixed the problem. The render distance did have an impact in performance before I did this, though it still crashed. My system is an i7 overclocked multithread and I have noticed that minecraft will run majorly 100% on CPU1, and other cores will be idle at 0% and jump everynow and then to 50%. This itself is curious. --Gazeofdisaster 23:04, 11 October 2012 (UTC)
  • Minecraft mainly runs in one thread (which works on one core). AFAIR only thing, which is threaded, is IO operations and terain generation. — MiiNiPaaT|C 09:18, 12 October 2012 (UTC)

Fixed/skipped

Gameplay[edit | edit source]

Bugs

[X] Nether portals fail to transport certain entities which work fine through End portals. Minecarts, Storage Minecarts, and Lit TNT(pushed into the portal via piston) all tested and failed to go through. Arrows were iffy as well. Malsententia 14:53, 11 October 2012 (UTC)

  • isn't it intended? I think it can't save movement, or the TNT fuse time.
  • As I said, it works fine with end portals. TNT fuse time is preserved and everything.Malsententia 00:02, 12
October 2012 (UTC)

[X] mobs will randomly fall through blocks, then pop back up. Mostly villagers, but I saw slimes do it to. ~Anonymous

[X] Linux Boats float in midair above the water and/or sink below the water after placing a boat in the water, saving the map, opening the map, and then touching the boat.

A boat floating in midair above the water in an enclosed dock.

To reproduce: 1) Place boat in water; 2) Save the map; 3) Open up the same map; 4) You will see the boat floating in midair just above the water; 5) Nudge the boat slightly by going adjacent to it and it will drop into the water; 6) After dropping into the water, it will actually start to fill with water and sink slowly; 7) Go next to it and the boat will float to the top once again; 8) After that, it may start to sink again; 9) This occurs when placed in water in an enclosed dock, and sometimes in open water. --Eugeniusz 20:42, 11 October 2012 (CEST)

[X] Drinking a Invisibility potion, then going into Third-Person mode makes the held item not swing at properly.

[!] The /kill command doesn't actually kill you, it only gives the 'ouch' text. Tested both SSP/SMP, in both survival and creative.

  • Also of note is that when holding an item with a damage value atributed to it (tree blocks, wool, potions) and using the /kill command, the damage value seems to change to a different, random one, changing the item held. You still are not killed. 69.113.144.41 03:42, 12 October 2012 (UTC)

[X] The ghost item bug has been around for a while, and it's like one of the most annoying and recurring bugs in all of Minecraft. When you take something(s) out of a chest (and only with chests and enderchests), it might pop back in after a few seconds and vice versa. Imagine you put valuables in a chest after mining, go back to the mine, fall into lava and still had the chested items are still in your inventory. Imagine the rage if this caused you to lose diamonds. Only encountered in SMP. --Mario-Fan 13:46, 17 October 2012 (UTC)

  • That sounds like simple client-server lag, especially if you're only seeing it in SMP. --timrem 14:44, 17 October 2012 (UTC)

Annoyances

[A!] Just to rename a sword, it costs a whole 15 levels. What is the point of charging the player so much for a simple action? Also, the anvil crafting recipe is ridiculously expensive for the level costs after you make it. yoshidude56 17:38, 11 October 2012 (UTC)

  • It could be considered overpowered if it wasn't expensive. 121.214.111.164 22:44, 11 October 2012 (UTC)
  • If you create a super-weapon as a special enchantment, you can't rename it at all if the level cost is too high. As a super-weapon is surely the case when you're most likely to want to rename the darn thing, what's the point of specifically coding things so that that particular case is prohibitively costly or impossible?--82.69.54.207 23:20, 11 October 2012 (UTC)
  • Naming an item doesn't make it overpowered - all the other prices are fine (I actually went through the code; I find the algorithms rather admirable for the goal of making things expensive :p). But it's silly that naming an item costs significantly more than most generic repairs and enchantment-enhancements. I can produce an excellent digging pick, Unbreaking III Efficiency V, from UbIII EIV + EIV, at the cost of 15 levels. Even more strangely, renaming gets a 50% surcharge if you want to change the name of an already named item. While the restrictions on enchantments seem well balanced (although, it seems you still get charged for wiping away conflicting enchantments), it's silly that renaming an item is considered equivalent to giving it a powerful enchantment. --WolfieMario 00:08, 12 October 2012 (UTC)

Fixed/skipped

Blocks[edit | edit source]

Bugs

[X] When dropping a damaged anvil, it get's fixed again. To recreate: Create dirt tower, put anvil on top, break top dirt and it's repaired. -- Mustek 14:28, 11 October 2012 (UTC)

[X] When an anvil falls and lands again it points to north/south even if you placed it east/west. --☺ Sven ? ! 14:41, 11 October 2012 (UTC)

[X] Digging straight down makes the player glitch into blocks. Digging down a dirt pillar with a "slow" tool causes momentary block glitches every now and then. Digging with Efficiency IV diamond shovel (single blocks at a time == short clicks) makes the player glitch into a block and keep spazzing until you relog. If you dig down while you are glitched, and then relog, you are (sometimes) standing on a floating dirt block after re-joining. So the block does not brake server-side, but it does brake client-side. Are these some kind of timing issues between the server and the client? --Masa 15:02, 11 October 2012 (UTC)

[X] Placing dirt or a block next to a cactus will destroy it. However, you can place a block on top of a cactus no problem. --Gazeofdisaster 19:08, 11 October 2012 (UTC)

  • intended since when cactus was implemented.

[X] Repairing/merging of items in an anvil is not consistent based upon repair 'direction'. No renaming was performed, but a test revealed the following: An Eff IV For III diamond pickaxe with a damage of 1000 (on the left), added to an Unbr III diamond pickaxe with a damage of 1000 (on the right) costs 41 levels. Swapping their positions around makes the cost rise to 51 levels. Damage values on the pickaxes was specified via /give before enchanting them at level 30. -TheWyo 16:40, 11 October 2012 (UTC)

[X] When merging items in an anvil, the merged item does not appear at all if the level cost is 45 or higher. --174.84.234.195 20:44, 11 October 2012 (UTC)

[!] [Ad] You can place blocks, but not destroy them in Adventure mode. Not entirely sure which versions this bug is in. whizzer0 13:49, 13 October 2012 (UTC)

Annoyances

Fixed/skipped

Items[edit | edit source]

Bugs

[SMP] [X] When renaming an item like a torch to anything, and placing it... the name does not stick once picked up. If the item is destroyed and picked up it returns to its original name. --Gazeofdisaster 16:21, 11 October 2012 (UTC)

  • This is followed by bricks, and anything that can be destroyed. Dropped items however are working correctly and retain their second name.
  • Renaming a bucket that contains a liquid, then emptying the liquid, causes the bucket to lose its name. --Inertia 06:35, 12 October 2012 (UTC)
  • I can tell you all exactly why this happens if you did not know already. They would need to store tile data in each individual block, otherwise if something placeable is placed and collected, it will default to it's original name, since it does not store tile data. Trigger hurt 14:44, 17 October 2012 (UTC)

Annoyances

[SMP] [A] It seems you can not rename enchanted items with more than 1 enchantment. It is extremely hard to get to rename an item with 1 enchantment, it takes a lot of playing around. For example put in a diamond helmet enchanted into 1 slot (not other slots filled) and rename it. It will list how many levels it will take but the item won't appear. Take the item out, put in a regular item like a block, it will be available to be renamed - then replace the item with the original item. You can now rename the item you wanted. --Gazeofdisaster 16:36, 11 October 2012 (UTC)

[SMP] [A] Leaving an item in the anvil and then exiting it will cause the item to drop and the item will bounce around, sometimes it will bounce and appear on top of the anvil, sometimes it will move around it. --Gazeofdisaster 16:38, 11 October 2012 (UTC)

[SMP] [A] Placing an anvil underwater will cause an air-bubble to form around it. --Gazeofdisaster 16:46, 11 October 2012 (UTC)

  • Not a bug. This is normal for all transparent blocks like doors, ladders, vines etc.--Kumasasa 19:36, 11 October 2012 (UTC)

[A] Renaming a map will work, but it will retain it's number. For example, renaming Map #0 into Cookie will result as Cookie #0. This behavior did not appear in 12w40b. --GrygrFlzr 09:30, 12 October 2012 (UTC)

  • Has been reverted as of 12w41b --GrygrFlzr 09:47, 12 October 2012 (UTC)

Fixed/skipped

World generator[edit | edit source]

Bugs

Annoyances

Fixed/skipped

Mobs/NPCs/animals[edit | edit source]

Bugs

[X] Zombie Pigmen spawned by portals in the overworld are immediately transported through the portal that spawned them. As a dramatic example, idling near this for an hour or two, will result in something like this when you go into the nether. Malsententia 14:55, 11 October 2012 (UTC)

I had a similar problem where large amounts of mobs that spawned in my underground base (where the portal was) ended up wandering into the portal, and the next time I went to the nether there were maybe 40 normal mobs. yoshidude56 17:54, 11 October 2012 (UTC)
The issue here is that they no longer have to wander in. They spawn in them, and are instantly transported to the nether. Malsententia 19:11, 11 October 2012 (UTC)

[X] The villagers become invisible when they leave the village boundary (or change village?), while transporting them in minecarts. Relogging fixes it, or they may become visible on their own after some time. Also, transporting the invisible villager right back to his village made him reappear around the village boundary. --Masa 15:03, 11 October 2012 (UTC)

  • After some more screwing around, it actually happens with other mobs as well (tested zombies and creepers). They become invisible after riding in a minecart some 30-60 blocks or so. When transporting them back, they become visible again. --Masa 00:07, 12 October 2012 (UTC)

[X] A mob that has picked up items from the ground can still despawn like normal mobs, without even dropping the gear. Is this intended? It means that if you die and a mob picks up your armor and sword, you are most likely to lose it unless another player is within 32 blocks of that mob until you get back. This seems quite harsh as it can practically mean instant gear despawn instead of the 5 minutes it normally has left. --Masa 15:07, 11 October 2012 (UTC)

[X] Slimes sometimes have the wrong size hitboxes. It makes it sometimes very hard to melee a large slime. --Masa 15:22, 11 October 2012 (UTC)

[X] The side of a pigs face loses its texture when they take damage

  • I have noticed this as well since 12w40a. However, Since I run a HD resolution pack I figured that there were just new textures that the pack does not support. Are you running a resolution pack? I haven't tested if it happens without a res pack. --Gazeofdisaster 15:50, 11 October 2012 (UTC)

[X] Mobs still sink through the ground, causing damage to them, then killing them.

Annoyances

[X] Wild cats if they are on one block will spin around in circles nonstop when approached and wont jump down or etc


Fixed/skipped

Graphical/lighting[edit | edit source]

Bugs

[X] The player's legs do not line up properly with the torso. It seems that each leg is set back a few pixels, and each leg is set inward a few pixels (legs overlap one another on their inner face). --Gilmoreja 17:21, 11 October 2012 (UTC)

[X] The player's head orientation (or wearable item orientation) seems to get stuck to the one it was at when drinking a potion of invisibility. It resets when the potion effect runs out. This can be seen by wearing a pumpkin when invisible. The helmets do update their orientation correctly while invisible though. --Masa 23:58, 11 October 2012 (UTC)

[X] Any block placed above cloud level will disappear when a cloud passes below and/or through it but the sun, moon, and stars can be seen through the clouds even when blocks are present behind the clouds.--Sickma 04:17, 12 October 2012 (UTC)

[X] Clouds act like one way mirrors, blocks above the clouds can't be seen through the clouds from below but when above, all blocks below are visible through the clouds.--Sickma 04:17, 12 October 2012 (UTC)

Annoyances

[A] The debug menu key combination has been swapped. Pressing F3 will NOT show the graphs and Shift+F3 will.

Not a major bug at all, and I'd even think this was intended. -- Mustek 15:24, 11 October 2012 (UTC)
  • It's in the damn chanegelog. Did you read it? — MiiNiPaaT|C 09:26, 12 October 2012 (UTC)

Fixed/skipped

Sounds[edit | edit source]

Bugs

[X] [Su] The fire extinguish sound does not play in survival, it only works in creative. In survival you get the hitting a block sound for the block behind the fire. (bug present since 1.3 snapshots) --Masa 15:11, 11 October 2012 (UTC)

Annoyances

[A] Reducing the frequency of the level-up sound doesn't make it any less annoying when it does play. It just reduces the number of occasions on which it annoys you by a factor of five. It also introduces another problem - you only get a level-up sound every five levels. I want to know every time I go up a level, but without being irritated. The best way to do this is have a non-irritating level-up noise that plays once a level, OK? How about repurposing the level-up jingle so that it plays once whenever you pick up a mega-XP orb you get when you kill a boss? That would be a far more fitting use for it. --Simons Mith[82.69.54.207] 15:02, 11 October 2012 (UTC)

  • All we need is a simple *ding* one sound syllable - not a song. --Gazeofdisaster 15:54, 11 October 2012 (UTC)


When you open a chest the sound is normal, but at the end of it it sounds like an arrow hitting something.

Fixed/skipped

Menus[edit | edit source]

Bugs

Annoyances

Fixed/skipped

In-game interfaces/HUD[edit | edit source]

Bugs

Annoyances

[N] Pressing shift+f3 doesn't remove the chart yoshidude56 17:56, 11 October 2012 (UTC)

Just press F3xPaw at 19:25, 11 October 2012 (UTC)
Works fine for me, not a problem with shift-f3. Trigger hurt 14:57, 17 October 2012 (UTC)

[A] [Cr] Building blocks and brewing items are a bit unorganized, example: ore blocks are not together, slab and stair blocks are scattered, and potions can be tricky to find.-- Sickma 04:59, 12 October 2012 (UTC)

Good point, they should be organized like the old creative menu. It seems that the new wooden stairs are a good distance away from the old one. Trigger hurt 14:57, 17 October 2012 (UTC)

[A] The "shadow" effect while using unicode font is misaligned and detached from the colored part of the letters (evident in the anvil interface and the level counter at the bottom). --Svajoklis 14:51, 17 October 2012 (UTC)

Fixed/skipped

Chat/commands[edit | edit source]

Bugs

Annoyances

Fixed/skipped

Language/text files[edit | edit source]

Bugs

[X] In Spanish (Mexico), the name for the item frame is not properly capitalized. --76.168.136.118 03:41, 12 October 2012 (UTC)

[X] In Spanish (Mexico), the GUI title for the anvil was not translated from English. --76.168.136.118 03:41, 12 October 2012 (UTC)

Annoyances

Fixed/skipped

References[edit | edit source]