Issues/Weekly 12w32a

From Minecraft Wiki
Jump to: navigation, search
Read this
Mojang has an official bug tracker and does not track bugs for any editions of Minecraft on this wiki. Please use the appropriate bug tracker to report and view current bug reports.

PC: bugs.mojang.com/browse/MC.
Pocket Edition: bugs.mojang.com/browse/MCPE.
Console Edition: bugs.mojang.com/browse/MCCE.


For further info, see the issues notice page.
Do not delete this page, any issues currently being recorded are purely for archiving purposes.
Issues
Full releases
Pre-releases
Weekly releases

Crashing/System

Bugs

Red Mushroom + Brown Mushroom cant be farmed anymore before you could farm those in a dark pleas (like a building without light)

[!!] Using the beacon block (Work in Progress block), I made a pyramid of emerald blocks about 4 high, then the beacon block on top. Using it, Minecraft crashed, and I was unable to get the crash report. I re-entered the world, but before I could, it gave me an internal server error (this was on single player). Alexkill51 19:12, 9 August 2012 (UTC)alexkill51

  • Same here, got a bit of a crash report --Kumasasa 21:07, 9 August 2012 (UTC)
I guess i got the same error when i build a diamond pyramid with this "Work in Progress"-Block on it... here are logs:
http://pastebin.com/QbThQak7 Server.log
http://pastebin.com/hs7f92Jc Client --M1n3r2011 16:06, 15 August 2012 (UTC)
  • While my game hasn't outright crashed from using Beacon/Work in Progress blocks, they have caused the "Internal Server Error" problem which made the world inoperable. I was able to use MCEdit to delete the Beacon from the world, but I still can't access the world without the error. Luckily it was a test world I made, but the fact remains it breaks the world somehow. 12w32b might be required to prevent this from spreading. On a side note, I watched CaptainSparklez' video on the snapshot, and at the end he experienced the problem the exact same way I did: [1] --MegaScience 02:24, 10 August 2012 (UTC)
This can be reproduced, maybe not when you place it. but try changing the effects multiple times. 213.46.192.198 14:31, 10 August 2012 (UTC)
Remember to select your secondary power guys, forgetting to do so causes the crash above. (Secondary powers are selected in the same manner as primary powers) Plet53 23:31, 11 August 2012 (UTC)
This can *probably* be fixed by navigating to the world folder and then deleting your player file. --91.157.201.175 05:32, 12 August 2012 (UTC)
No, doesn't work. Still "Internal Server error". --Kumasasa 08:15, 12 August 2012 (UTC)
If you delete the beacon block with MCEdit you also have to delete the associated tile entity. You might have to use NBTExplorer for that... LB(T|C) 22:54, 12 August 2012 (UTC)
If you create a new world, and copy over your regions, you can retrieve your terrain data. --Wormy14 20:12, 19 August 2012 (UTC)

[!!] Crash when extending an existing, active beacon pyramid (placing layers below), maybe the same issue as above --Kumasasa 10:47, 11 August 2012 (UTC)

[!!] While experimenting with the new villager trading mechanic (trades=better trades, smacks=worse trades) my game crashed after punching a villager about 7 times and attempting to trade. Yoshidude56 18:36, 10 August 2012 (UTC)

  • This is the same issue I reported below, for I recognize the error message and it is exactly the same (except for the index values, depending on the exact circumstances). What you did is that you clicked the right arrow too many times and because of a brief period of lag, it tried to go on a page that doesn't exist. This is impossible, for it doesn't know how to handle the situation, and so it crashes and shuts down. --Wormy14 20:12, 19 August 2012 (UTC)

[!!] MAJOR crash bug, where the game freezes up the ENTIRE system. the only fix is to shut down via the button. It freezes all keyboard and mouse input. I have had this error MULTIPLE times. It was present in every snapshot released, and in this snapshot as well. it only ever happens on Minecraft. it can happen at any time, but generally needs the launcher to have been open for a fair while.
Game continues as normal, so no crash report is ever created. ctrl-alt-del, windows button etc. are all unworkable due to the aforementioned disabling.
I have a very high-end computer, and everything is up to date. it only ever happens with Minecraft. I am unsure if this is also a mac issue. --Kizzycocoa 21:59, 10 August 2012 (UTC)

[!!] [CMP] macOS Seeing a Client-Side Segmentation Fault when player goes to 0.3898271732032299, 100.0, -117.99870360837357 on seed 147. --Inertia 03:27, 14 August 2012 (UTC)

  • Can you replicate this crash repeatedly? --Wormy14 20:12, 19 August 2012 (UTC)

[!!] Usually in somewhat laggy conditions, when trading with villagers, you can crash the game by trying to browse the villager's selections. If you click the right arrow key too many times, you can click past all the selections which crashed the game because you can't have anything beyond what you have, and it overflows the count. Occurring since trades were introduced. --Wormy14 19:58, 19 August 2012 (UTC)

Annoyances

Fixed/Skipped

Gameplay

Bugs

[!] Enchantment system does not work. Fire Aspect on swords work atm. ~Archus

  • I was unable to reproduce this, as I got a knockback 2 sword and a flame 1 bow, both of which worked just fine. --107.2.255.13 04:28, 10 August 2012 (UTC)
  • At least enchanted pickaxes, shovels and axes do work like unenchanted tools. The tools are enchantable. If bows and swords work as expected, I cannot say. --Kumasasa 06:20, 10 August 2012 (UTC)
(Merged duplicate)Silk Touch doesn't work at all. --Kumasasa 06:09, 10 August 2012 (UTC)
  • Just found this out while mining, Fortune II Efficiency IV diamond pickaxe mining at normal diamond pick speed, but Fortune was working fine.
  • Efficiency doesnt work on Picks, regular axes, and shovels. Needs to be fixed..

[!] Using a nether portal around X=0, Z=0 back and forth will leave the player in an unloaded world, either stuck in place (lucky) or fall in void (unlucky), tested CSP, have same issue in 1.3.1 SMP. ­Raplemie 01:56, 11 August 2012 (UTC)

  • To recreate, create a new world, superflat (for y coord, normal have same behavior) tp to 0 5 0, create a portal, enter portal (nether render), re-enter portal (overworld render), re-enter portal (only entities render). ­­­­Raplemie 03:14, 11 August 2012 (UTC)

[!] When teleporting a long distance (roughly 200 blocks away) using a command block, the new area I teleported into won't load new chunks. Flying back to where I teleported from, and then flying back to where I was trying to teleport to, chunks still would not load. If I teleport far enough away, the chunks I was just in will unload and so I'm stuck flying around in a world with no loaded chunks. The only solution seems to be the /kill command, which causes chunks to load when I respawn. Does not happen when using the /tp command normally (ie: without a command block). EDIT: 10 seconds after posting this, I tried it again and the teleport worked, but when I tried it a second time, the same thing happened. I wonder if it has something to do with the destination chunk still being loaded somehow the one time it worked.68.147.135.46 19:09, 12 August 2012 (UTC)

[X] The /kill @p command doesn't work on the new Command Blocks. Virisenox 18:49, 10 August 2012 (UTC)

  • The kill command has never accepted parameters. For now it's working as intended. Suggesting move to annoyances. --10.244.112.237 06:11, 12 August 2012 (UTC)

[X] In Adventure mode you can place blocks.

[X] [SMP] When PVP is disabled you can still harm co-player with fire aspect enchanted sword.

[!] Ocelot can't be tamed --Raffox97 19:45, 11 August 2012 (UTC)

  • Unable to reproduce. Partonetrain

[X] If you get out of a minecart on a track next to a wall of iron bars or glass panes, you can end up on the other side of the wall depending on which side of the track the wall is. --Thorny 22:11, 14 August 2012 (UTC)

[X] During daytime while it is raining/snowing, villagers frequently walk in and out of their houses in a confused manor. They want to go outside cause it's daytime, but want to go inside because of the weather. Water99 13:16, 16 August 2012 (UTC)

[X] [SP] [LMP] /msg gives "You do not have permission to use this command." even though I'm an "op" (I created the world, I host the LAN game). –nyuszika7h (talk)

  • When you hosted the map, you failed to enable cheats. I had this happen before, and enabling cheats on publishing allowed it. --Wormy14 19:08, 19 August 2012 (UTC)

[X] [LMP] Op can't ban players. --90.178.255.155 15:47, 20 August 2012 (UTC)

Annoyances

[A] In Creative,the survival inventory crafting interface does not work.

  • It does not even exist for me, what do you mean 'does not work'? LB(T|C) 23:00, 12 August 2012 (UTC)

[A!] Villager trading is made cumbersome due to the nature of the offer renewal feature. On average, an offer can be used 7 times before a player must trade with the final offer slot to renew disabled offers. Because rarer offers are weighted to be more likely when a villager has many offers, and rarer offers tend to be more expensive or provide items which aren't as useful in large quantities, a villager which has been traded many times tends to be less useful than a villager traded only a few times. This is because, in order to renew desired offers, often an expensive or limited-use offer such as 11 emeralds for a watch must be traded. Once a villager has all its offer slots, further trading with this villager will require trading always with the last slot, putting a player at an excess of an item they may not have a use for. There is no particularly logical reason a villager can't renew their offers after making any other trade: in fact, if we assume villagers have actual jobs aside from trading, offers should be capable of renewal over time. It would be much less cumbersome to trade with villagers if *any* trade had a random chance of renewing a disabled slot. Also, it is not logical that only disabled slots can be renewed - why is there a limit to how many uses any offer can gain? Surely, if a villager amasses larger amounts of wealth, they would have more to trade and therefore be willing to trade more. Jeb has stated he intends for villagers to have more long-term benefits, but currently you are still better off building villager breeders than spending your time caring for any one particular villager. --WolfieMario 01:25, 15 August 2012 (UTC)

  • Very nice analysis. They keep saying they're trying to dissuade us from killing villagers, but the problem isn't that we kill them, it's that we MUST kill them in order to have anything even resembling a useful trading system. --5thHorseman 22:22, 16 August 2012 (UTC)

[A] Multiple enchantments have been made dramatically less common in practice as a result of the reworking of the enchantment system. You can enchant several items at level 30 without earning more than one enchantment per item. This may or may not be caused by a bug - there is a curious line of code in the enchantment creation method: when checking whether or not to add another enchantment, a random number between 0 and 50 (inclusive) is selected. Further enchantments are only applied if this number is less than or equal to the modified enchantment level. However, prior to the rework, the modified level was halved once before enchanting, so leaving the random number 0-50 is likely intentional. --WolfieMario 20:27, 20 August 2012 (UTC)

  • Now that enchanting is capped to level 30, enchantments like Efficiency V are impossible or highly unlikely on tools, Sharpness V is impossible or highly unlikely on tools, and Power V has been reduced to Power IV on the bow. I rather have a cap of 50, unless all enchantments previously obtainable can be "squeezed" or "fitted" in the 0-30 levels and not "cut off." Androo123 04:30, 22 August 2012 (UTC)

[A] /weather does not do anything if you put in a time parameter of 1 in both Singleplayer and Multiplayer. Caleb Sander 16:32, 12 August 2012 (EST)

  • Are you sure? Perhaps because weather changes are gradual, and because you give it 1 second to switch to that weather before it has to change again, you are not seeing the 1 second change? After one second the game will change the weather again and chances are it is the weather you were just in. LB(T|C) 23:00, 12 August 2012 (UTC)

[A] If you build an Iron Golem near a Village, exit Minecraft, reload the world, then attack it (or a nearby Villager while on Survival/Hardcore), the Iron Golem will attack you. [This bug has been present since 1.2.5] --Anonymous

Fixed/Skipped

Blocks

Bugs

[X] Beacon block works as intended and gives off the lightlevel as it is supposed to, but the lightning effect does not show. problem on win 7 home ed 64bit, vanilla (no mods/no texture). changing all settings do not affect this problem. reinstalling minecraft does not either. anyone else having the same bug? --Wally

  • Me, too. --☺ Sven ? ! 12:04, 15 August 2012 (UTC)
  • 3 things could cause this. 1. The beacon block cannot "see" the sky. 2. you have not built any form of pyramid below it. 3. you have found a bug. --Queegey 21:51, 15 August 2012 (UTC)
  • before i report a bug i like to recheck everything, i build pyramids in all different materials and sizes, used youtube videos as reference and build it both in a flatworld as well as in a real world on a tree. and like i said the buffs all work, the problem is the light just does not activate. i am just happy i do not seem to be the only one having this bug. --Wally
I have tested this in multiple worlds, out in the open, latest snapshot, and I can't get the effect either. WinXP 32 bit vanilla. --Nathan2055 15:38, 20 August 2012 (UTC)
  • The beacon block flickers occasionally, and seems to always turn off when you crouch. Androo123 04:32, 22 August 2012 (UTC)

[X] When priming TNT from far away (with Redstone), when the TNT explodes you cannot view the blocks that the TNT had blown up. A video can be found here: http://www.youtube.com/watch?v=iZWi1x2aSFk. --CallumTennant

[X] Normal-sized mushrooms can't be planted outside at night. This is because the skylight level is always 15, even at night, and the reason for this is so crops and flowers don't uproot themselves every night. Perhaps there could be a workaround for this. It is intentional that they're not supposed to be planted outside in the daytime, but they don't even work at night. TorchicBlaziken 20:39, 5 July 2012 (UTC)

[X] Vines' hit-boxes are the size of a solid block.

  • All the time? Or just when the vine is two vines in one block? LB(T|C) 23:02, 12 August 2012 (UTC)

[X] Some blocks can be seen through the "light ray" block when you place a lot of Beacon Block close together. Not sure if this should be in the "graphical bugs" section or here... List of the blocks visible : Water, Ice, Chest (and double Chest), Ender Chest, Nether Portal, End Portal, Enchantment Table (book only), Sign. Screenshot ~~Geneosis 11:51, 10 August 2012 (UTC)

  • Clouds can also be seen through the "light ray". ~~Geneosis 12:43, 11 August 2012 (UTC)
  • it is probably because they have 3d textures (not just a 6 sided block) or transparency. same happens when you look through a water stream, except opposite. you cant see water or ice or nether portals.

[X] After using command blocks to teleport between a desert and an ocean rapidly several times the block in the desert I teleported to turned into an ocean biome. I noticed it because it was raining at this time and rain was falling onto one single block in the desert. After teleporting once again everything was normal again. I couldn't reproduce it a second time. --☺ Sven ? ! 14:54, 10 August 2012 (UTC)

[X] Mob Spawners look like Pig Spawners again. Screenshot Pteprocks 19:00, 10 August 2012 (UTC)

[!] Timing on NOT gates (redstone torches) seems to be broken. I would expect them to act as a one tick inverting repeater but they seem to require a three tick pulse to activate and then only emit a two tick pulse. This effects any circuit that depends on timing, pulse length, or short pulses. A full explanation of the problem can be found here: Video The video was recorded in V1.3 but the bug is the same in 12w32a --Innovate.Invent 07:44, 12 August 2012 (UTC)

[X] A command block positioned at x0, y:62, z:16, programmed with the command /give @p 346 1 (fishing rod), when activated by a player nearby, will give the item to a player at x:-1000000, y:80, z:1000000 instead of the player nearby. --Inertia 07:52, 12 August 2012 (UTC)

[X] Cakes pushed (and destroyed) by pistons make the piston get a buggy texture --IMeta95 15:35, 12 August 2012 (UTC)

[X] Destroying the arm of an activated piston in creative will drop a piston entity --IMeta95 15:37, 12 August 2012 (UTC)

[X] Still seeing the behavior of upper pistons of piston pairs not retracting. Breaking the upper pistons and placing them again temporarily fixes the situation, but the behavior returns after a while, e.g., when the chunk reloads. This behavior is most obvious when building efficient sugarcane farms, where two pistons are used for each reed (while only one piston in the middle of the reed is requires to harvest sugarcane, two pistons are used to increase the yield because doing so causes almost all reeds fall into the collection area). --Inertia 16:47, 12 August 2012 (UTC)

[X] [MP] Command Blocks are broken in Multiplayer. They work fine in Singleplayer, but when you press the "Done" button in Multiplayer, the server displays "Command blocks are not enabled on this server." and the command box is reset. Caleb Sander 16:21, 12 August 2012 (EST)

  • Are you an op'd player in creative mode? LB(T|C) 23:05, 12 August 2012 (UTC)
    • You need to have enable-command-blocks:true (or similar) in server.properties justcool393

Annoyances

[A] [Cr] The bug where you can't fly as fast through water and lava was fixed, but cobwebs still slow you down while flying in Creative mode. TorchicBlaziken 20:07, 14 July 2012 (UTC)

  • I feel it should be like that because its realistic. 122.106.191.67 06:06, 14 August 2012 (UTC)
  • Isn't non-realism the whole point of Creative Mode? This is definitely annoying for anyone building with cobwebs. --Fperson1 06:37, 18 August 2012 (UTC)

[A] When placing Mushroom blocks of a damage value greater than 0, it will revert to 0 upon placing. This used to happen with Monster Eggs, before they were tweaked in 12w17a to prepare them for inclusion in the Creative Mode inventory. This should be changed because the damage values of mushroom blocks are now available using cheats. We should not have to rely on pistons to place these blocks in Creative. TorchicBlaziken 23:59, 2 June 2012 (UTC)

[A] The new Command Block doesn't allow commands such as: /kill and /toggledownfall.

  • But there is the new, even better command /weather <clear/rain/thunder> --Kumasasa 06:22, 10 August 2012 (UTC)
  • The /kill command kills the person who types it. It wouldn't make sense to kill a command block. Perhaps the annoyance should be that op'd players cannot use a parameter for the /kill command to specify a player. LB(T|C) 23:07, 12 August 2012 (UTC)
  • TDF does work for me, however /kill is broken because of the way it works. I'll put that in the suggestions thread I'm working on. --Nathan2055 15:38, 20 August 2012 (UTC)

[A] WIP Blocks randomly stop shooting their light beams. It is impossible to make them work again. Yoshidude56 00:38, 11 August 2012 (UTC)

[A] When I tried to use the beacon block's buff called 'Jump Boost', it completely messed up the world. Now whenever I try to go on it, it says 'Internal Server Error'. Do I have to wait until the next snapshot for this to be resolved?

  • I think you built a full power pyramid and didn't activate Regeneration. Try again on a different world and report the results Yoshidude56 18:38, 10 August 2012 (UTC)
  • I have used a pyramid with Jump Boost and it seems just fine. Caleb Sander
  • Moved to annoyances. --Nathan2055 15:38, 20 August 2012 (UTC)

[A!] [Cr] The mob in the spawner still can't be modified.--90.178.255.155 15:55, 20 August 2012 (UTC)

Fixed/Skipped

Items

Bugs

[X] Sometimes when eating food in a stack, you will involuntarily eat another unless you quickly switch to another item. TorchicBlaziken 18:21, 9 August 2012 (UTC)

  • Are you saying it skips the animation? --Moxxy 06:13, 10 August 2012 (UTC)
  • That does sound to me like a better way of putting it, and matches well with what I see. Quickly switching to another item is my workaround too, but sometimes I'm not quick enough. --82.69.54.207 22:47, 10 August 2012 (UTC)
  • The animation doesn't player (because you're not holding the mouse down) but the sound plays and the server forces you to eat it. This often happens when you release the mouse button after eating with an odd timing and the server didn't notice you released the mouse. LB(T|C) 23:09, 12 August 2012 (UTC)
  • It is also not directly a lag-related issue. In 1.3.2, I ate two grilled porkchops when I clearly did NOT hold down the right-click button, and has also happened at least twice, proving quite annoying when conserving food. I believe I was on LAN, but I don't think that factor matters. There may have been a super-quick lag spike that caused this, but it is too insignificant to be noticed. --Wormy14 19:44, 19 August 2012 (UTC)
  • I think this is a symptom of an issue not directly related to eating food - I have also seen something similar occur when placing blocks (right click once, two blocks are placed) and when digging with a high-efficiency tool (left click once, two blocks are dug out). In all cases, the effect is intermittent; I haven't found a way to reproduce it reliably. --Exasperation 19:28, 21 August 2012 (UTC)
  • This always happens when eating apples (I thought it might be the trackpad on my mac). If I am still hungry, I will consume another piece of food until the character is full. Androo123 04:12, 22 August 2012 (UTC)

[X] Leggings model is shrunken and doesn't show up correctly.

  • Once I got on with full gold armor, and my leggings were invisible. Unsure if it was 1.3.2 or 12w32a. When I removed and reapplied my pants several times, with no result. When I removed by boots, however, they reappeared, and stayed that way when I reapplied. --Wormy14 19:44, 19 August 2012 (UTC)

[X] When a door is damaged by a zombie, the graphic for a cracked door will be stuck at that location, if you remove the door, the crack remains regardless of what is placed in that location.--Sathw

[X] Sometimes you can see an item on the ground before it actually falls. For example, if I chop down a tree, sometimes I'll go to grab a sapling that falls out of the canopy but I can't because it's actually still on top of some remaining leaves, just right on the edge it seems. I have confirmed this several times. Just stand next to the item you can't pick up and destroy the blocks directly above you. The item will disappear from the ground and fall into your hand.

[X] Cows (and I would assume other mobs as well) sometimes spawn INSIDE the canopy of a tree if the canopy is covering the ground.

  • This is of high occurrence in jungles, and is the same for any spawn-able mob. --Wormy14 19:44, 19 August 2012 (UTC)

[X] The map item becomes increasingly unusable as more exist in a world. There are no issues for a map with a low number, such as map_0. However, around map_50 issues start occurring, and these issues seem guaranteed at around map_100. Maps higher than 150 tend to be entirely useless. The issue in question? The client fails to display the correct map, instead displaying an arbitrary number and blank map. This number will increment when the player drops and picks it back up, or attempts to use a crafting table or other form of GUI except the inventory. Once the map has hit the correct number, it may be used, but the client fails to properly display any regions which have already been mapped. At low map numbers, this manifests as vertical streaks across mapped areas. At around 150 or so, these areas are simply blank, and will only display content which has appeared since the last time the map was viewed. When new areas are mapped, or existing areas are updated, only the changed pixels will display to the client; all else will remain blank. On large servers, this makes the map item essentially unusable: once a map is 100% complete, it will only display as a blank map to players. This issue has been present on servers for a long time, although I personally have usually only experienced maps where half of the vertical columns of pixels failed to load; as a server I play on has 150+ maps now, they have become utterly unusable blank rectangles. The issue is now present in singleplayer as well. --WolfieMario 01:47, 4 August 2012 (UTC)

  • [Previous bug description] Maps do not work, there is no image that shows where you are. I never had this in 1.2.5 but now it's a bug I just started a singleplayer world and I took a map and there was no image. I had full health. But when I tried to restart minecraft it didn't work either. Then later I tried to make an new world and that didn't work, it only shows map_1. I made this. 10.09, 3 August (UTC) User:badvett
  • I had this same issue, after creating a map, it would have non updated vertical streaks across mapped areas. This was however with a lower number of map, namely map_18. After exploring parts of the map those parts displayed as normal, logging out and in of the game would ruin those parts as well. --Ehekky 19:41, 4 August 2012 (UTC)
  • Are you sure you aren't holding down shift when you make the map? Also, if you create a map, and travel for a bit, then open up the map, the map will be rendered at the point it was crafted, this is an intended feature. Also, fixed grammar. --Wormy14 19:44, 19 August 2012 (UTC)
  • This is definitely not what is happening. If the map were created by shift-click, inventory editors would identify its damage value as 0 - in addition, this applies equally to maps which have been naturally created, found in chests placed by other players, spawned using commands, and added using inventory editors. Also, what Ehekky is describing can be seen here (streaked areas were mapped on a previous login), and is most certainly not a feature. --WolfieMario 12:07, 20 August 2012 (UTC)

Annoyances

[A] The Golden Block Apple is supposed to be like the old Golden Apple, but it does not restore 5 hunger bars and 24 saturation like it used to. TorchicBlaziken 06:14, 3 August 2012 (UTC)

  • This would make it too overpowered. You get Regeneration IV, Resistance, and Fire Resistance.

[A] [Cr] Ender Pearls cannot be thrown --Queegey 21:01, 9 August 2012 (UTC)

  • Not a bug. This has existed since the pearls were introduced. Jaredjeya 01:15, 12 August 2012 (UTC)
  • OP didn't say it was a bug. I do agree that they should work in creative.

[A] The fishing rod's texture looks when moving the rod --Gingerpain 17:16, 10 August 2012 (UTC)

  • Pardon my asking but... what? Plet53 17:13, 12 August 2012 (UTC)
  • I believe he meant to say that the rod looks wrong when moving it, and when I move a rod that has been cast, the tip is sometimes detached from the string. --Wormy14 19:44, 19 August 2012 (UTC)
  • Set your FOV to more then 105, you will see.

Fixed/Skipped

World Generator

Bugs

[!] When respawning to a new spawnpoint (/spawnpoint), most of the time you will fall through an unloaded chunk even if the chunk is loaded. You will keep falling through the void and you will keep dieing until you reload above the chunk or wait until the chunk loads.

[!] It seems that sometimes in large biomes mode, it is possible for some chunks to generate completely differently than the rest of the world, i.e. a rectangle of ocean generating in the middle of a mountains biome. I've had this problem in both the current version, 1.3.1 and this snapshot. --anonymous 19:12, 12 August 2012 (UTC)

[X] Just like abandoned mineshafts were before the floors were implemented, strongholds generate weirdly when they cross a ravine. The seed -623160645725253637 is a good example of this with a stronghold in a hole close to spawn which crosses an underground ravine. TorchicBlaziken 22:00, 4 May 2012 (UTC)

  • I think this is because strongholds generate before ravines so when the ravine generates it overwrites the stronghold blocks with air.
  • I still find this issue annoying, regardless of any intention. NetherrackCreeper (talk|contributions) 22:33, 19 August 2012 (UTC)

[A] The Enchanted Golden Apple might not spawn in dungeon chests. According to the Minecraft Wiki page on dungeons it's still just the normal Golden Apple that spawns there. I don't actually know for sure though since I haven't checked the code. TorchicBlaziken 15:30, 18 August 2012 (UTC)

  • They do not. However that might be helpful if it had a low chance to spawn.

Annoyances

[A!] On an old map (I have had this map since Beta 1.6.6 and have made so much progress on it I don't want to delete it) when I throw eyes of ender to bring me to a stronghold, they take me to a place where there aren't just no strongholds, I used a the zombe mod to see through walls and there aren't any underground occurrences at all (ravines, mineshafts, dungeons, caves, etc.) I think that to prevent this there could be a tag added to the level.dat like end_location or something that contains the coords of the end portal similar to how it contains the location of the original spawnpoint. --Caucow 03:50, 10 August 2012 (UTC)

  • This is probably because since you have had this map since 1.6.6, there may not be a stronghold, as they were not completely implemented until 1.0.0. If an eye of ender does not lead to a stronghold, it leads to where the stronghold is supposed to be. I recommend using MCEDIT to transfer all of your progress onto a new map if you really want to keep it. --107.2.255.13 04:36, 10 August 2012 (UTC)
  • You can use MCEdit on the chunks around where the eye of ender leads you and, without deleting the chunks, tick the option to repopulate the chunks. Minecraft will regenerate the stronghold in those chunks. LB(T|C) 23:13, 12 August 2012 (UTC)

[A!] Desert pyramids generate with an extra block which appears to be misplaced around the 'back' (see http://imgur.com/a/HKm3y ) --ABrightmoore

Fixed/Skipped

Mobs/NPCs/Animals

Bugs

[!] Mobs spawn one block lower than ground level. This is especially bad when they are hostiles as they can attack you but you can't attack them. Spiders seem to be affected mostly, however here's a pic of pigs that spawned under jungle leaves http://i36.photobucket.com/albums/e21/cretinbob/2012-08-13_001530.png -Porrohman

[X] [CUS] If you make a Zombie Pigman hold something, it will still render as a Golden Sword. Block headgear also floats above baby zombies' heads instead of rendering on their heads. TorchicBlaziken 22:53, 13 August 2012 (UTC)

[X] While creepers' AI makes them run away from cats, it does not specifically prevent them from exploding when near a cat. So, sometimes creepers explode near cats. TorchicBlaziken 13:42, 18 August 2012 (UTC)

[X] Iron Golems sometimes attack a creeper. Then when the creeper explods, it walks back to where the creeper would be and attacks. --QQII 10 Aug

  • I have tested it and confirmed it. That is a bug. Spencer10APSC 15:42, 12 August 2012 (UTC)

[X] Zombies fail to burn in sunlight, while skeletons do. KrisYeager

  • Confirmed, I was thinking this may be intended behavior for infected villagers, but the point remains that regular zombies don't burn either. Pteprocks 18:50, 10 August 2012 (UTC)

[X] Something just happened... I found an enderman who was in his aggressive state, but wasn't attacking (I was in creative, but I don't know if it's just that mode). 50.46.250.128 18:07, 9 August 2012 (UTC)

  • I have noticed that since the 1.3 update, if you attack a creeper or skeleton, it will not chase you, but will still attack if within its attack distance. If you are within the attack range (8 for a skeleton, 4 for a creeper) they will attack. If you move outside the range that they are able to see you (16 for most mobs, not sure for enderman) they will go back into their peaceful state and not attack you even if you come back within their attack range. If you leave their attack range but not their player vision range, then come back into their attack range, they will attack again (very obvious with creepers, I have only noticed this while flying away from the mob). --caucow 9 August 2012
  • The weird thing is, I don't think I attacked any endermen (or at least, didn't let them live afterwards). I was just wandering around after destroying a village with zombies (and yes, I had fun :P) and came across a shaking/open-jawed enderman. I don't know why I was stupid enough not to take a screenshot >.< And it wasn't doing anything. I flew into it a few times, even. Just weird... 50.46.250.128 04:40, 12 August 2012 (UTC)
  • NO, I don't think that's a bug (If you are in creative). It should do that, because that's intentional. Hope this helps. Spencer10APSC 15:42, 12 August 2012 (UTC)
  • Even though I didn't attack it? 50.46.250.128 23:54, 12 August 2012 (UTC)

[X] Graphical glitch on the right side of creeper's head when hit (turns white). This also happens with villagers.

[X] Villagers spawn on "hostile mob" spawning conditions (dark mob farm) (Edit: That happened only once, just after upgrading from 1.3.1 to 12w32a --Kumasasa 08:18, 12 August 2012 (UTC)) --Kumasasa 18:21, 9 August 2012 (UTC)

  • Possibly confirmed. In a Let's Play World, I just spent an episode looking for a village because there were villagers running towards my house from all directions. --KeOS 4:51, 12 August 2012 (UTC)
  • Found Villagers in an underground ravine
  • (Merged duplicate) Villagers spawn very frequently in the nether.
  • Villagers also spawn outside Nether Portals, like Zombie Pigmen. Edmachine 18:48, 11 August 2012 (UTC)
  • (Merged duplicate --Kumasasa 08:29, 12 August 2012 (UTC))

[X] Skeletons drop slightly damaged to nearly fully damaged bows. Intended ? --Kumasasa 18:24, 9 August 2012 (UTC) (edited --Kumasasa 21:12, 9 August 2012 (UTC))

  • probably because they use the bows before they drop them but i could be wrong can anyone correct me if I'm wrong?
  • The Skeletons were "freshly" spawned in a mob farm and they hadn't the slightest chance to fire a single shot. --Kumasasa 21:12, 9 August 2012 (UTC)
  • It's basically just to add an affect to the skeleton. It's not supposed to be taken literal that they used the bow before. Obviously in single player if they didn't attack you then their bow is fresh. Jeb just wanted to add some diversity into it. –Preceding unsigned comment was added by 71.125.132.5 (talk) at 00:38, 10 August 2012‎ (UTC). Please sign your posts with ~~~~
  • Is that knowledge or speculation ? I was assuming something similar, but that makes the dropped enchanted tools (and armor ?) less usesful, because they will lose the enchanting when repaired.--Kumasasa 06:31, 10 August 2012 (UTC)

[X] Mobs, including the player outside of Creative Mode, can breathe under lava. TorchicBlaziken 23:22, 21 June 2012 (UTC)

[X] Spider Jockeys don't hold bows

  • So do skeletons spawned from mob spawners. Redstonehelper 19:56, 9 August 2012 (UTC)
  • I have seen bow-less Skeletons spawned under normal conditions as well. Pteprocks 18:50, 10 August 2012 (UTC)

[X] Villagers spawned using mob eggs don't get the "like/dislike" particles when hit or traded with. Intended?

  • Only villagers in villages like/dislike players. Give them a few houses and it should be fixed. Redstonehelper 19:56, 9 August 2012 (UTC)
  • Lets give the person who made this comment some time to read Redstone's response then remove this as it isn't a bug --Moxxy 06:16, 10 August 2012 (UTC)

[X] As soon as one zombie pigman with an enchanted sword spawns, all other zombie pigmen hold enchanted swords. Redstonehelper 19:56, 9 August 2012 (UTC)

[X] the zombie spawn egg will spawn a villager zombie, but realistically this should only occur when a normal zombie comes into contact with a villager.

  • I definitely agree with the bug, but I don't think the 'realism' is a very good justification. But for adventure mode in particular it would be really useful if every variant of every mob was spawnable from its own mob egg, including golems, spider jockeys, lightning creepers, child variants of every villager type and baby as well as adult mobs. Some way (any way!) of achieving that kind of precise control is really useful when you're designing a scenario. Popping a bunch of eggs in a dispenser until the player comes by is just such an easy way to manage mobs. So I'd prefer the OP's bug as reported to be fixed by reverting zombie eggs to ordinary zombies, and making Testificate zombies available separately. [See talk re dealing with enchanted items and pre-aggroed mobs] --82.69.54.207 12:16, 10 August 2012 (UTC)
  • Agreed, but if so, there should be a new tab in creative of spawn eggs because there's so many possibilities. Partonetrain

[X] Ghast fireballs destroy terrain even with mobGriefing turned off. SethBling 20:55, 10 August 2012 (UTC)

  • This may be because the ghast fireball itself is technically an entity. Partonetrain

[X] A lot of mobs on higher platforms and in enclosed spaces are having out-of-soul experiences. Example: I have a big sky spawner with a giant platform, and they spawn on this but their souls are walking across my yard. When I get too close or hit them etc. they shoot back up to their real bodies.

[X] In my world there is a village, but the inhabitants have died before this snapshot, so with the cheats i gave myself two villager spawn eggs. They don't breed anymore, also if there are 20 doors... --79.6.155.23 16:20, 11 August 2012 (UTC)

[X] It's possible for a villager with one offer to run out of stock but not add any new offers (presumably because the new offer had the same item as the old), making further trades impossible. --Thorny 22:38, 13 August 2012 (UTC)

Annoyances

[A] Rarely, zombie pigmen don't have their "head" part of their skin. Only the second (3D) head texture appears. If you need proof, I have a screenshot. Partonetrain

  • Can confirm this, was about to post this bug myself. 122.151.153.85 09:32, 10 August 2012 (UTC)

i just dont know what to say except look at this screenshot and see for yourself? screenshot: file:///C:/Users/Owner/appdata/Roaming/.minecraft/screenshots/2012-08-09_18.20.54.png

*sigh* We cannot see the screenshot on your computer. Upload it to the image hosting websites like Photobucket or Majhost please.112.120.156.53
Zombie Pigmen without heads can be cured into villagers too.

[A] Endermen drop Ender Pearls EXTREMELY rarely, not sure if this is new but I noticed this now. Killed about 9, one dropped one pearl. Killed another 10, didn't get a single one.

  • I agree this is rather annoying. Especially since you need so many Eyes of Ender to legitimately find a stronghold. --Keithicus420 17:04, 13 August 2012 (UTC)

[A] If you build an Iron Golem near a Village, exit Minecraft, reload the world, then attack it (or a nearby Villager while on Survival/Hardcore), the Iron Golem will attack you. [This bug has been present since Minecraft 1.2.5.] --Anonymous

Fixed/Skipped

Graphical/Lighting

Bugs

[X] villagers, mobs and other players still sink through the ground half of the time.--League 17:44, 16 August 2012 (UTC)

[X] Villagers turn invisible when stopping in a Minecart.

[X] Chest's texture is glitched.

  • Are you using the completely unmodified snapshot? Some mods like the common wallhack let you see through entites such as chests.Caucow 03:07, 10 August 2012 (UTC)
  • I am not sure what the first person means, but I have placed an ender chest, and the top and lock was translucent. Here is my screenshot from what is supposed to be the front, and I did confirm that. Sorry for the broken link, just remove the space between the "h" and the "t" because the ASIRRA will not let me submit my completed results. h ttp://imgur.com/EqvbQ --107.2.255.13 04:49, 10 August 2012 (UTC)
  • I can confirm this and I'm not using any mods or texture packs. --☺ Sven ? ! 14:46, 10 August 2012 (UTC)
  • I can confirm with a screenshot - almost like the model is inverted... --Queegey 19:39, 10 August 2012 (UTC)
  • (Merged duplicate) when you place the beacon block and the chest block in the same world the chest texture appear very strange... --Raffox97 19:45, 11 August 2012 (UTC)
  • (Merged duplicate) Sometimes, a chest will glitch out (or bug out), and it will seem like that there are two chests, but it is the inside of the chest, this can occur to both chest sizes. jozzamay Screenshot ~~ Screenshot 2 ~~
  • (Merged duplicates --Kumasasa 08:26, 12 August 2012 (UTC))

[X] Enchantment tables book is glitched

  • Like above, are you using the unmodified snapshot?Caucow 03:07, 10 August 2012 (UTC)
  • meaning the hitbox marker (or whatever) lines through the book. Very distracting. Edit- now my books are doing the transparent texture thing on the covers! --Queegey 19:42, 10 August 2012 (UTC)

[X] When a piston is transitioning between its on and off states the texture becomes glitched (similar to chests).

[X] When in third person mode (f5 hit once) and under a block looking down, so your view is very close to the back of your skin's head,if the inventory is opened your head glitches around and spazzes

[X] When you create a new world, make a server, even sometimes logging in and out, these will change your skin back to Steve ~~ jozzamay. But this mostly happens in Creative

[X] [Cr] Boating Invisibility. In creative mode, it is possible to have an out of body experience in boats. This can be reliably recreated by building a 3x3x1 launch platform in a flatworld, high above the surface. Place a boat on this platform then nudge the boat a little. Then get into the boat. At this point, you fall through the platform and appear to be in a boat on the surface below the platform, but in reality, you are above, in the boat on the platform. If you shoot an arrow or throw a splash potion, they all come from the platform. If the surface is a body of water, you are able to move quite a distance, albeit with a lot of glitchness. If you move too quickly, you fall off the platform with additional glitchness. If you exit the boat, your view instantly reverts to the platform. This glitch is fun to use on SMP to spy on players. If your launch platform is at 256, most players are unaware of your presence. I rather like this glitch to spy with, but it does interfere with testing boat mechanics in creative mode (like EATS road design and such). --Inertia 16:35, 11 August 2012 (UTC)

[SP] The boats direction icon on a map is reversed--Sathw

[X] If you shift-click an item the just got smelted in a furnace quick enough it will appear like you're smelting a smelted item. (Been noticing this for a while now) --Kabbage318 August 11 2012, 10:58 PM (UTC-05:00)

Annoyances

[A!] The reordered Zombie textures break compatiblity to exisisting texture packs. Zombies are looking really weird and are sometimes invisible. [1] --Kumasasa 18:51, 13 August 2012 (UTC)

Fixed/Skipped

Sounds

Bugs

[X] the normal nether portal sound is fixed. the one you hear when you are near the nether portal. but there is still 1 sound missing. it's the sound you heard when the screen said: entering the nether. for clarity, here is the sound I mean--League 17:37, 16 August 2012 (UTC)

Annoyances

Fixed/Skipped

Menus

Bugs

Annoyances

Fixed/Skipped

In-Game Interfaces/HUD

Bugs

[X] [Cr] The Splash Potions of Healing/Harming I/II appear among the normal potions in the Potions menu, and the normal potions of Healing/Harming I/II do not appear at all. I'm not sure whether this is a bug or it was an intentional choice because they would have no use in Creative, but either way it actually WOULD be useful for placing in chests for adventure maps. TorchicBlaziken 18:05, 9 August 2012 (UTC)

  • This is a bug, definitively not intentional. The original potions can be obtained with the give command and using the proper damage value. Androo123 04:09, 22 August 2012 (UTC)

[X] Pants fail to render sometimes. ScreenshotxPaw at 11:20, 11 August 2012 (UTC)

  • The same applies (at least) to helmets and leggins and in [MP] the missing armor parts are also not visible for the other players. --Kumasasa 12:10, 12 August 2012 (UTC)
  • I can confirm this for gold leggings, reapplying the leggings doesn't work, but when I reapplied the boots, it appeared. Only witnessed in the inventory screen. --20:20, 19 August 2012 (UTC)

[X] When using a Book and Quill on a Mac, the interface does not render and instead shows "Missing..." on a white square. (No GUI.) --Wormy14 20:20, 19 August 2012 (UTC)

[X] Possible bug (unknown if intentional), when enchanting in the Enchanting GUI, the last enchantment is always the highest possible enchantment level (If the bookcases make level 22 the highest possible enchantment, the last enchantment is always a level 22). Androo123 04:19, 22 August 2012 (UTC)

Annoyances

[A!] Pressing 'Esc' Button on Command Block Interface [block #137] will hide the "Done" button and not exit the Command Block Interface

  • I can confirm that the interface does not close, but I cannot confirm the Done button going away. LB(T|C) 23:23, 12 August 2012 (UTC)

[A!] When Using Shift-Click to buy a lot of items at once from a villager in creative mode, filling the player's "Survival" inventory, Using the shift-destroy all button will not remove all of the items that have just been traded.

[A!] Creative-shift-click is OP in all situations.

[A] When hiding the normal GUI with F1 it reappears behind the Commmand block GUI (and vanishes when closing the command block gui). --Kumasasa 12:21, 12 August 2012 (UTC)

  • The GUI also reappears when pausing the game with ESC.

[A] Installing a texture pack does not override title/win.txt. It is ignored if present.

[A!] When you are writing a book and notice that a few lines back you made an error, you need to delete everything in order to undo the error.--League 17:42, 16 August 2012 (UTC)

  • Agreed, this is annoying. Also, it is not possible to add a space (or spaces) unless there is at least one character in the row. This also goes for line breaking. Androo123 04:23, 22 August 2012 (UTC)

[A] You cannot name unsigned books. One needs to be able to keep track of their books before they lock them. --Wormy14 13:53, 23 August 2012 (UTC)


Fixed/Skipped

Chat/Commands

Bugs

[X] I have not been able to reproduce this, but when I opened the snapshot for the first time and tried to use some basic commands like /publish, /give and /gamemode in a Beta 1.6.6 singleplayer map it said I did not have permission to. I used the Open to LAN button in options and it worked fine. Still, the commands wouldn't though even after starting the LAN server. This would not happen after restarting my client.

  • No, this is intended -- cheats are disabled by default, and only work if the world was created with them turned on. If you want them, find a world editor to change the flag. --109.186.18.80 01:01, 12 August 2012 (UTC)

[X] The /me command is not being logged, even though it shows on the client. --Inertia 23:03, 9 August 2012 (UTC)

[!] Most of chars above 128 still can't be written via minecraft. It writes another char insteread (eg. ï insteread of ď). Alt codes doesn't working too.--90.178.255.155 16:07, 20 August 2012 (UTC)

Annoyances

[A] /list only lists online players; I feel you should be able to use this to see all ops (/list ops) or all people with a certain gamemode, etc. --Keithicus420 16:56, 11 August 2012 (UTC)

Fixed/Skipped

Language/Text Files

Bugs

[X] The "Snooper Settings..." text is not translated. --91.147.251.232 20:55, 10 August 2012 (UTC)

  • That's because it's new to the game, and translations are mostly added shortly before the full release. --RedMser 17:17, 12 August 2012 (UTC)

[X] Command /help doesn't return translated text.--90.178.255.155 16:13, 20 August 2012 (UTC)

Annoyances

[A] While this is not technically in the text files of the game, the names of some of the biomes (particularly the hills biomes and mushroom island biomes) are in CamelCase instead of using spaces. "Ice Mountains" and a few others prove that CamelCase is unnecessary and that it is perfectly possible to use spaces in those names. TorchicBlaziken 17:22, 7 August 2012 (UTC)

  • I'm just being picky, but that is PascalCase. This is camelCase. ;) Elite6809 (talk) (forum) 11:54, 13 August 2012 (UTC)
  • You're wrong, CamelCase and PascalCase are synonyms. What you describe is appleCase ... --80.134.13.237 12:42, 13 August 2012 (UTC)

[A] Wheat Seeds are known as just "Seeds". TorchicBlaziken 17:22, 7 August 2012 (UTC)

  • When Wheat was added to Minecraft and the ability to plant tall grass with seeds was removed, the name was never changed. This has been like this since I first got the game (Beta 1.6.6)Caucow 03:00, 10 August 2012 (UTC)
    • I don't know about you, but you could never plant tall grass with seeds. Wheat and seeds were added long before tall grass was. ;) LB(T|C) 23:26, 12 August 2012 (UTC)
  • Agreed, but if it's going to be changed 'grain' might be a better alternative term.--82.69.54.207 15:51, 10 August 2012 (UTC)
  • The reason for my adding this is that in 1.3 specific forms of things were given specific names, like Oak Wood Planks and Chiseled Stone Bricks. Also, Pumpkin Seeds and Melon Seeds have specific names. TorchicBlaziken 15:32, 18 August 2012 (UTC)

[A] The Clay block and the Clay ball use the exact same name: "Clay". They should have different names. TorchicBlaziken 17:22, 7 August 2012 (UTC)

  • Agreed, maybe "Clay," or "Clay Block" and "Clay Ball" or "Clay Chunk."
    • Not "Clay Chunk", I don't think it would be appropriate to place 65536 blocks with one click ;) -- Featherwinglove 05:17, 12 August 2012 (UTC)

Fixed/Skipped

References

Theres a bug with the skins and sometimes your skin wont show up its steve skin. and theres a bug were your minecraft randomly crashes in a server or singal player. also minecraft is laggy as hell when you have a computer with 1gb of ram. :'( Also! i have a idea for minecraft stone armor! its not as good as iron but its better then gold. my email is brunos1buddy@yahoo.com so if anyone needs to conact me. just email! and the bug is for 1.3.1 to the snapshot