Czech, Thai, and Turkish language wikis are now available. Please help with translating!

Issues/1.4.2

From Minecraft Wiki
Jump to: navigation, search
Read this
Mojang has an official bug tracker and does not track bugs for any editions of Minecraft on this wiki. Please use the appropriate bug tracker to report and view current bug reports.

PC: bugs.mojang.com/browse/MC.
Pocket Edition: bugs.mojang.com/browse/MCPE.
Console Edition: bugs.mojang.com/browse/MCCE.


For further info, see the issues notice page.
Do not delete this page, any issues currently being recorded are purely for archiving purposes.
Issues
Full releases
Pre-releases
Weekly releases

Crashing/system[edit | edit source]

Bugs

[!!] macOSWindows Make creative world named 8192, seed 8192, shows "Creating world, Converting World" then hangs –Preceding unsigned comment was added by 86.170.141.215 (Talk) 23:42, 26 October 2012 (UTC). Please sign your posts with ~~~~

  • What classification of bug/annoyance is this? Major, minor, can't tell. Please put the classification before the OS type. --Blackbird626 12:48, 28 October 2012 (UTC)
  • If it crashes the client, it's a critical bug. E-102 Gamma 15:33, 28 October 2012 (UTC)

--99.188.188.213 21:59, 16 November 2012 (UTC)

  • I tried to reproduce the problem on my Windows OS (No mods to the game), and it loaded, but i was stuck in the spawn point.

[!] [SMP] Unmodded MC 1.4.2 server crashing when any player connects. Ubuntu 12 server only hosting MC - no other services.

[MOD] [SP] [Su] Crashes when opening inventory/chest/crafting box etc.

  • Did anyone notice that "Is Modded" says "Very Likely"? --Blackbird626 01:29, 1 November 2012 (UTC)

[SP] [Su] Same problem as above user, only with completely standard app. Mac OS X 10.8.2

  • I've had 3 crashes so far with the same stack trace, always when opening some kind of dialog. Appended my crash latest report, Mac OS X 10.8.2, my app is not modded in any way -- zenmumbler
  • I had another Java process running, a local Scala web server instance running in SBT. When I exited the SBT process the problem went away in Minecraft and restarting the site afterwards did not make the crash come back. The server process is headless so why these 2 processes would clash I don't know. --zenmumbler

Whenever I try to go on a server, my game crashes. Whenever I try to start a single player world, it never actually loads the world, it just freezes on "Converting whatever." Here's the server crash report:


     Minecraft has crashed!      
     ----------------------      

--- BEGIN ERROR REPORT 79371bf1 -------- Generated 11/3/12 8:20 PM

- Minecraft Version: 1.4.2 - Operating System: Mac OS X (x86_64) version 10.6.8 - Java Version: 1.6.0_33, Apple Inc. - Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Apple Inc. - Memory: 517645368 bytes (493 MB) / 554369024 bytes (528 MB) up to 1069416448 bytes (1019 MB) - JVM Flags: 3 total; -Xbootclasspath/a:/System/Library/PrivateFrameworks/JavaApplicationLauncher.framework/Resources/LauncherSupport.jar -Xms512M -Xmx1024M - AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used - LWJGL: 2.4.2 - OpenGL: NVIDIA GeForce 320M OpenGL Engine GL version 2.1 NVIDIA-1.6.36, NVIDIA Corporation - Is Modded: Probably not - Type: Client - Texture Pack: Default - Profiler Position: N/A (disabled) - Vec3 Pool Size: ~ERROR~ NullPointerException: null

java.lang.NoClassDefFoundError: io at java.lang.ClassLoader.defineClass1(Native Method) at java.lang.ClassLoader.defineClassCond(ClassLoader.java:631) at java.lang.ClassLoader.defineClass(ClassLoader.java:615) at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141) at java.net.URLClassLoader.defineClass(URLClassLoader.java:283) at java.net.URLClassLoader.access$000(URLClassLoader.java:58) at java.net.URLClassLoader$1.run(URLClassLoader.java:197) at java.security.AccessController.doPrivileged(Native Method) at java.net.URLClassLoader.findClass(URLClassLoader.java:190) at java.lang.ClassLoader.loadClass(ClassLoader.java:306) at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301) at java.lang.ClassLoader.loadClass(ClassLoader.java:295) at java.lang.ClassLoader.loadClass(ClassLoader.java:247) at xz.a(SourceFile:97) at xz.<init>(SourceFile:75) at yn.<init>(SourceFile:6) at xz.<clinit>(SourceFile:18) at ye.<init>(SourceFile:20) at ye.<init>(SourceFile:30) at ye.<init>(SourceFile:38) at zr.b(SourceFile:44) at zr.a(SourceFile:27) at xe.<init>(SourceFile:126) at awz.<init>(SourceFile:39) at awr.a(SourceFile:148) at do.a(SourceFile:71) at bx.b(SourceFile:341) at awr.d(SourceFile:98) at awu.c(SourceFile:69) at net.minecraft.client.Minecraft.l(SourceFile:1080) at net.minecraft.client.Minecraft.J(SourceFile:582) at net.minecraft.client.Minecraft.run(SourceFile:534) at java.lang.Thread.run(Thread.java:680) Caused by: java.lang.ClassNotFoundException: io at java.net.URLClassLoader$1.run(URLClassLoader.java:202) at java.security.AccessController.doPrivileged(Native Method) at java.net.URLClassLoader.findClass(URLClassLoader.java:190) at java.lang.ClassLoader.loadClass(ClassLoader.java:306) at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301) at java.lang.ClassLoader.loadClass(ClassLoader.java:247) ... 33 more --- END ERROR REPORT abd1d9aa ----------

[!!] WindowsWhen I log into my own sever, the game runs for about 3 seconds then closes with no error message, please help me! There isn't even a crash report in the .minecraft folder. 68.10.66.162 02:05, 2 December 2012 (UTC)Len

Annoyances

For some reason whenever i play a world in single player or multiplayer it freezes after playing for a minute ive updated my drivers and everything it started happening a week after 1.4 hit please help :(

Don't forget to sign your posts! It doesn't take much time, just type four tildes (~~~~), you do not need an account to do so. To the point, does the game crash? Or does it just freeze for a few seconds and then is fine afterwards? If it crashes please provide a crash report, they can be found in the .minecraft folder in a folder called 'crash reports.' #trigger_hurt(I|T|C) Check out my project! 12:32, 14 November 2012 (UTC)



Fix for the map crash after going through end portal------------------------

Figured out how to fix my own map and I wanted to let people know how to fix it since I'd heard some other people had been having the same problem. I don't know where to put this so I put it here IF YOU KNOW A BETTER PLACE FOR THIS PLEASE HELP ME AND MOVE IT. 1. Go to start menu and type %appdata% 2. select roaming 3. select .minecraft 4. click saves 5. find the map that crashed in the list (if you renamed the map it will be saved under the original name) 6. click the crashed map 7. click players 8. find you name in the list (if you are the only one to play on the map it will be the only name) 9. delete your account from the list 10. open minecraft and craft away!!!

your placement, levels, items, and all your stats will be saved

Gameplay[edit | edit source]

Bugs

[!] The following types of damage cause downward knockback:

  • Players/mobs hurting you
  • Fire damage
  • Starvation
  • Lava
  • Laggy fall damage
  • Observed while playing FVDisco's Sonic the Hedgehog racetrack

Get this fixed, as this ruins some maps that were created by other players. --Blackbird626 17:28, 23 November 2012 (UTC)

[!!] [MP] Putting any type of anvil in your inventory will crash a newly updated server. --Blackbird626 12:57, 28 October 2012 (UTC)

[!] Achievement "The End ?" is currently NOT obtainable in vanilla 1.4.2 - should also be postet on official bug-tracker

  • I got it by entering the Nether. Really strange. HotdogPi ⑬㊲ 01:26, 1 November 2012 (UTC)
  • I got "we need to go deeper" by going into the end. pojdotcom
    • Only tested vanilla 1.4.2 WIN SSP + CSP (Windows 7 Ultimate x64 SP1 - Java7 Update9 x64)

[!] [MP] Saplings don't grow in MP even with bonemeal.

  • For me, they do. HotdogPi ⑬㊲ 01:26, 1 November 2012 (UTC)
  • I see no issue, saplings growing normally. You are probably not waiting long enough, for on servers plants take longer to grow for some reason, probably lag. #trigger_hurt(Talk)(Contribs)(Ideas Page) 19:43, 7 November 2012 (UTC)

[!] [MP] Placing an item frame in a newly updated server will erase the frame, and delete the entire stack of item frames. --Blackbird626 12:57, 28 October 2012 (UTC)

[!] [MP] Doing /give <player> <any block/item id that was added in 1.4.2> throws Error: Block ID ___ cannot be found. --Blackbird626 12:57, 28 October 2012 (UTC)

  • Do you mean any 1.4 snapshot? HotdogPi ⑬㊲ 03:41, 3 December 2012 (UTC)

[!] In-game, 2 block heights sometimes do damage to you if you fall down them, regardless of the type of terrain you land on. Quite crippling when running from mobs at half a heart and the mobs aren't subject to the same effects. 99.119.131.109 01:20, 28 October 2012 (UTC)

I can't wait for the release to come out, supposedly they fixed this. #trigger_hurt(Talk)(Contribs)(Ideas Page) 19:43, 7 November 2012 (UTC)
Fixed in 1.4.4 HotdogPi ⑬㊲ 03:41, 3 December 2012 (UTC)

[!] When running and jumping, sometimes you take half a heart of damage randomly, even across flat surfaces. 99.119.131.109 01:20, 28 October 2012 (UTC)

[!] While riding a pig, Being splashed by an invisibility potion has no effect. [Don't ask how I found this out.]

[!] [MP] We are having a problem with our server when updating from 1.3.2, every time we enter we can chat, we can move but when we break blocks it does not give the drop only breaks the block, when we move around then relog we move back to our original spot we cant open chests or interact with anything. We can not update or else our nether and end are destroyed and it generates a new one please help me with this issue!99.237.176.48 02:31, 29 October 2012 (UTC)Stud158

  • First of all use correct tags next time you post, second what your experiencing is extreme lag,and finally you must be using bukkit with the multiverse plugin, wait for bukkit and multiverse to update then update the server -- ashgrayson

[!] [MP] While playing on a LAN server, the non-host's inventory, when removed from a chest, repeatedly returns to the chest a few seconds later, even as items are being used in the world, disappearing from the player's hands or the world. This seems to happen especially if the host and the LAN player access a chest or the inventory at the same time. The host's inventory is always unaffected.

[X] When removing blocks like torches or placing two patches of seeds directly next to each other, the seeds pop out.

  • Upgraded to minor bug. E-102 Gamma 01:06, 30 October 2012 (UTC)
This isn't a bug, you need to supply sufficient light underground to keep farms going. Sometimes if there is some light you can plant one seed but planting one diagonal to it causes both to pop out. But in order for the seeds to stay in, you need to put torches or some other light source within a few blocks away from it. #trigger_hurt(I|T|C) Check out my project! 12:37, 14 November 2012 (UTC)

[X] If placing an item frame in an item frame, then breaking the frame, only one is dropped, instead of both. [SSP]

Since items stack together automatically, are you sure they did not just stack together? Now unless they actually only returned 1, then that would be a bug, but so far i have not experienced this. #trigger_hurt(Talk)(Contribs)(Ideas Page) 19:43, 7 November 2012 (UTC)

[A!] Sittuation: Riding a singeltrack minecartrail on the ground that is surrounded by a fenceline on both sides.

Problem: When you right click to leave the minecart, you get placed outside of the fenceline AND the minecartrail. No chance to get back in there and continue the ride.

EmbedVideo was given an illegal value for the alignment parameter "Minecraft - v1.4.2 - Minecart Bug". Valid values are "left", "center", or "right".

Not in english, but it shows exactly the problem in the first 5 min.

KleineMax 15:35, 2 November 2012 (UTC)


[A!] Prior to 1.4 when a boat was hit by a stream of water it would rise. This allowed for effects like http://www.youtube.com/watch?v=ronO7a_XIvc Now boats struck with water in this manner graphically glitch down into the ground and disappear. They do not lift off the pressure plate. If you enter the space they once were visible in, they reappear. This breaks many styles of boat based elevators and redstone circuits. --Theant 04:13, 18 November 2012 (UTC)

[X] Powered Rails do not update correctly. If you power a powered rail again (like, if it is already powered over attached powered rails) it will not update the rest of the track if the next rail is already powered. (Since this bug is somewhat hard to explain, ill attach a screenshot to the bugreport: http://imgur.com/6QIwM)

This bug has been existent pretty much since they added these, and it's very annoying. #trigger_hurt(Talk)(Contribs)(Ideas Page) 19:43, 7 November 2012 (UTC)

[X] For some reason, seemingly random, i receive a random item duplicate in [X] of something i've just worn, say i put on a full set of diamond armor, then moments later after entering the inventory i receive a random diamond helmet in a completely random position. Any ideas why this is happening? It is not connection lag, this is [SP] , not [MP] .Trigger hurt 19:54, 5 November 2012 (UTC)

[X] Not quite sure what happened here, but i keep getting this error trying to log into my server, tried different servers and versions, tried restarting, tried force update, tried new server, no matter what i can't get in, and i get this error:


Failed to login: java.io.IOException: Server returned HTTP response code: 503 for URL: http://session.minecraft.net/game/joinserver.jsp?user=triggerhurt&sessionId=-6045792992079893581&serverId=-2d049138db2a755d4c14c48c9c7111a6564b064a


What? This has happened before but i can't fix it! Someone please help me if you can! #trigger_hurt(I|T|C) Check out my project! 18:51, 17 November 2012 (UTC)

{{bl|ad}[X] You can destroy Glowstone in Adventure Mode. 209.181.87.11 20:21, 25 November 2012 (UTC)

Annoyances

[A] Minecart flipping out when riding on the rails. Looks like it's glitching after you get in and start moving. -Glassmonkeyface (UTC)

  • Sign with ~~~~. HotdogPi ⑬㊲ 03:41, 3 December 2012 (UTC)

[A!] Creative mode Destroying and building speeds DO NOT match up with the flying speed, making it harder to build. The Xbox edition is easier to build in because this is acted upon. An annoyance, yes, but if this IS acted upon, building would be much better. 209.181.87.11 01:27, 27 November 2012 (UTC)

[A] [SP] macOS Whenever I open any world on my Macbook Pro running Lion v10.7.5 and place a block, the game doesn't let me move around or jump or anything. I have to click on the window like 3 times to get it to let me move around. Minor annoyance. 76.175.74.116 22:19, 24 November 2012 (UTC)

[A] Windows When clicking the key ALT, the game will freeze, and the player will stop moving even if it is in the air. On multiplayer, other people will see you hanging in the air until you click on the screen, which will make you start falling again. The keys you held down when you clicked ALT, will freeze, making you for example jumping forward, if you held down W key and SPACE key. --gatoo20

Blocks[edit | edit source]

Bugs

[!] When you use pick block on ANY Double slab block, It will give you the item called "(block) slab", the same name as the slab, not the full block. When you place that block, a double STONE slab will appear, instead of the Full block you need. 209.181.87.11 01:00, 27 November 2012 (UTC)

[!] Sticky pistons can push rails, but not pull them. I powered the sticky piston with a redstone torch that was on continuously. --Blackbird626 22:28, 1 December 2012 (UTC)

[X] You can stand on a block that a chest is occupying. Not sure if this is a bug or not. --Poolala 23:56, 18 November 2012 (UTC)--Poolala 23:56, 18 November 2012 (UTC)

  • Chests are slightly less than 1 block tall and wide now. HotdogPi ⑬㊲ 03:41, 3 December 2012 (UTC)

[X] When you go from the ground to on top of a bed you need to jump. When you go from there to the top of a block, you don't need to.

[X] When you drink an invisibility potion, any mob heads you have on are pointed the wrong direction. 75.143.98.201 00:54, 27 October 2012 (UTC)Hi_910

[X] When a compass is places in an item frame, it tells the location of the spawn point relative to the player, not the item frame.

[!] When a redstone torch burns out, it might stay burnt out permantly. Replacing the torch, then after one powering, the torch burns out. --Blackbird626 13:04, 28 October 2012 (UTC)

I've seen this bug in all versions of the game with that in existence, it really gets annoying when your fast pulser keeps dying. Trigger hurt 11:37, 31 October 2012 (UTC)

[X] While in Creative, enchantment tables do not take bookcase knowledge. (Not tried in survival) Minec4rt 07:50, 29 October 2012 (UTC)

[!] In both creative and survival, placing repeaters and torches(possibly other "attached" blocks, untested) can sometimes make the host block disappear. Seems to be limited to a certain area when it does happen. CorduraCavalier 04:14, 4 November 2012 (UTC)

[!] In Survival mode, collecting an item while breaking a block will reset the block damage to zero (i.e. the crack will disappear and you will take longer to break the block).86.185.189.55 16:58, 17 November 2012 (UTC)

Annoyances

[X] When doing a setup like halfslab, anvil, halfslab, anvil, etc. when stepping from the halfslab to the anvil, it will cause the player to glitch down a little bit before going onto the anvil. As demonstrated in this video

EmbedVideo was given an illegal value for the alignment parameter "Minecraft Anvil Bug In 1.4.2". Valid values are "left", "center", or "right".

S1kBruZZ

  • Caused by anvils being 3/4 blocks high. It should also happen with enchantment tables. HotdogPi ⑬㊲ 01:26, 1 November 2012 (UTC)

[X] When doing a bed, chest, bed, chest setup it glitches like the anvil bug.

It's caused by it not being a full block. Chests aren't a full block tall anymore. HotdogPi ⑬㊲ 03:41, 3 December 2012 (UTC)

[A!] If you put a block down and put half-slabs on the front, back, left and right of it and you sneak off the corner of the block, it is still possible to fall off the block. (I think this is major because you can do the same setup like, 200m in the air and you will fall down and die even though you are holding shift.) --KrapTV 22:18, 6 November 2012 (UTC)

NOT a bug. The shift method ignores any fall less than 1 block. It still works when the fall is 1 block or more. --hakr14 01:50, 12 November 2012 (UTC)

[A] If you push an ender egg with a piston, the Ender Egg moves over, not falling into the block (item).

  • I found this bug by using an Ender Egg destroyer, but when I place a block beside it, it stops.

Epicest_Gamer, 09:02, November 10, 2012.

[A] [Cr] When you're in your inventory and you move your mouse over an item, any signs' fronts and backs you can see will look brighter.

[A] You can shift-walk off of chests now. (EG. standing on chest, walk off while crouching).

  • Chests aren't a full block. HotdogPi ⑬㊲ 03:41, 3 December 2012 (UTC)

Items[edit | edit source]

Bugs

[X] macOSIf you use the command: /give (insert player name here) 358, it gives you a map, but it is empty, and does not load when you walk around.--AlbertRutter 6:12, 20 November 2012 (UTC)

[X] Sometimes, in survivalmode, you can't expand maps(item).

  • Can too, --Blackbird626 12:50, 28 October 2012 (UTC)
  • Confirming this bug. Sometimes after expanding, the newly generated item is not expanded. Have tried one map a few times, never expands. Another of my maps expands as expected. --[Tom T.]
  • Get an account, and sign your posts like --~~~~ instead of --<insert would-be-username here>. --Blackbird626 01:32, 1 November 2012 (UTC)
  • He does not need an account to sign posts, he just needs to type four tildes and it will sign it for his IP address. As far as the bug is concerned, earlier yesterday on my survival village i made a map, then decided to expand it, it worked once, twice, but on the third time it did not expand, only wasted my paper (which since i had a sugar cane farm i had plenty of sugar canes for paper). I tried again and it worked correctly, i had no further problems with the map after that. Any clues? Trigger hurt 19:50, 5 November 2012 (UTC)

[X] When Expanding map, it shows blank paper. When generating new map it does not start in center, but upper left corner of map. 76.228.69.223 22:31, 28 October 2012 (UTC)a1000wtp

Added bug tag, please use [X] ({{bl}}) to classify regular bugs. Glad you bothered to sign your post! Trigger hurt 19:50, 5 November 2012 (UTC)

[!] [MP] Map (item) doesn't expand when I walk into unexplored territory. Further more, my icon on the map showing me where my character is doesn't rotate when I rotate, and instead changes into different colors and so forth, so I never know which way I'm heading until the icon moves after I've started walking. Everyone on my server is having the same problem. Haven't attempted to duplicate on single player.

  • Maps are not supposed to expand automatically when you go into unexplored territory. Sign your posts like --~~~~. --Blackbird626 01:39, 1 November 2012 (UTC)

[X] Hoes do not take damage from tilling, i tilled an entire plains biome with my diamond hoe and it took no damage whatsoever, still left in the untouched state. Feature or bug? I don't think hoes are not supposed to take damage... Map modded once before with toomanyitems, but the hoe is an old hoe that has been sitting in a chest for about 3 months now (real time). Trigger hurt 04:28, 4 November 2012 (UTC)

Nevermind, i used TooManyItems mod and discovered the hoe had negative data values, such as -32000, which gives that item 32000 uses before it actually takes damage. I probably had spawned a hoe holding shift+click with toomanyitems mod, which gives one an infinite stack/infinite damage tool/block/item and just don't remember doing so. Trigger hurt 19:50, 5 November 2012 (UTC)

[X] Exiting the game while an item is in an Anvil will cause the item to be lost on entering the game again. 75.71.225.15 19:33, 5 November 2012 (UTC)

Added bug tag to the front, please use [X] ({{bl}}) to classify ordinary bugs. Trigger hurt 19:50, 5 November 2012 (UTC)

[X] When using a map on multiplayer, the symbol for where the player supposed to be isn't always on the map, despite that the player should be at the center of the map --96.51.153.54 02:10, 11 November 2012 (UTC)

[X] If there's a block in front of a dispenser, it won't turn arrows, eggs, snowballs, fire charges, splash potions, exp bottles, or spawn eggs (you could actually suffocate mobs) into items. They will, however, still turn water/lava buckets and minecarts/boats into items.

[X] Villagers who trade coal for emeralds also accept charcoal, but the last trade before they stop accepting them turns some leftover charcoal into coal. 67.8.82.124 17:48, 2 December 2012 (UTC)

[!] Minecarts left on rails will randomly disappear/vanish after exiting the game. 67.8.82.124 17:48, 2 December 2012 (UTC)

Annoyances

[A] When two or more items, i.e. diamonds, are near each other, some of the items may randomly become invisible, but are still there when you go to pick them up. I tried this with redstone dust as well, and some of the items were still invisible. It would look like there are maybe 10 or so items on the ground, but there might be a full stack. Note that this only happens when the items are thrown down individually. --Agent A 04:38, 6 November 2012 (UTC) (The items are supposed to stack, this is a new feature, not a bug)

[A] Putting a pumpkin, sugar, and an egg anywhere in a crafting table produces pumpkin pie. But putting an apple, sugar, and an egg doesn't produce apple pie.

*Since when apple pies exist? Go to items, search the list and find me an apple pie. 89.228.147.19 14:10, 17 November 2012 (UTC)
  • Apple pies are not in the game. This is just cluttering up the wiki by putting a suggestion for apple pie. --Blackbird626 17:07, 23 November 2012 (UTC)

[A] Breaking sand (non-shovel) will glitch and reset when picking up the last sand block. Example: Breaking two blocks of sand (with fist speed), first one drops and I'm currently breaking the second, but after the *pop* of picking up the first it resets my breaking action to the second. 67.8.82.124 17:48, 2 December 2012 (UTC)

[A] Hostile mobs (like pig zombie) can kill players before they even finish loading from portal travel. In other words, if you're running from a pig zombie in the Nether and jump into the portal, chances are it went with you and either ate a chunk of you or killed you before you had a chance to defend yourself. 67.8.82.124 17:48, 2 December 2012 (UTC)

World generator[edit | edit source]

Bugs

[X] The Nether is very laggy. To such a point that it is dangerous just to be there. 184.208.238.230 05:34, 3 November 2012 (UTC)

[!!] [SMP] Unexpected Extreme Client-Side lag occurring upon entering unloaded chunks or chunks loading extremely slowly. Freezes and/or crashes if remained in chunks for a long period of time. Also occurs in 1.4.2 Bukkit servers with the recommended build.

Annoyances

desert temples are spawning in the swamp as well as the desert.

  • It would be a swamp hut, except it's in the edge of another biome, making it a desert temple. HotdogPi ⑬㊲ 01:26, 1 November 2012 (UTC)

[A] Entering an underground nether portal and then coming back out of an above ground portal that was not there before(portal duplication)

Added proper tag to front, please use {{bl|a}} to classify annoyances. Trigger hurt 04:30, 4 November 2012 (UTC)

[A] Even though corner stairs now exist, 'L' shaped houses in villages are still built with full blocks in the corners on their roofs.

  • Be sure to sign your post! --Blackbird626 17:31, 23 November 2012 (UTC)

[X] When generating a superflat world, it makes a part of the world Default, and spawning you on that area of Default. This is bad if you're not using cheats and playing on survival. It might not happen to you, because it is rare. Epicest_Gamer 06:53, 7 November 2012

Me and my freind were walking around looking around in a desert seeing aleast 5 villages and 3 pyrimads then it lagged so bad then My PC froze then said Minecraft had ran out of memory. I have no clue why this happened. I exited out of Minecraft and looked for the server, but it lagged so bad it exited the host, and he said when he leaves, the server is deleted. So it probably lagged so bad it drained all memory of all players. Epicest_Gamer 05:03 7 November 2012

  • I'm not sure if this was a bug or it just was built. But it had to be on MC, no one could've build all of that. Epicest_Gamer, 09:23, November 10, 2012.

Mobs/NPCs[edit | edit source]

Bugs

My villagers keep going in and out only 2 doors and won't stop! (It go so annoying I killed them and respawned them but it still happened!)

[!] If several mobs are traveling in minecarts when a chunk is unloaded/loaded some of the mobs will freeze in place while others remain moving normally. Minecarts with frozen mobs will continue to travel while appearing empty but if you attempt to enter one the frozen mob will appear and pop out. Bug appeared in version 1.3.2 and is present in both SSP and SMP. --Theant 01:51, 4 November 2012 (UTC)


[A] Untamable Ocelots (When you feed them fish the hearts come out but they dont transform and you cant do anything with them. They act like ocelots even though you feed them)

  • Ocelots have a 1/3 chance of being tamed by each fish you give them (similar to wolves); this is not a bug. -- Orthotope 01:33, 28 October 2012 (UTC)
  • Rather an annoyance. --Blackbird626 12:59, 28 October 2012 (UTC)

[?] Witches despawn a split second after spawning them using a spawn egg. In addition, No witches found in the world as of yet, despite the fact that I found a witches hut. Durzan 14:38, 27 October 2012 (UTC) Durzan

  • Check you are on a hard enough setting, if on peaceful, witches will despawn
  • Change the difficulty from something other than Peaceful. --Blackbird626 12:50, 28 October 2012 (UTC)

[N] Pigs are unbreedable. You can't feed them with wheat, and they won't follow you.

  • Pigs are now led and bread by carrots; read the changelog. -- Orthotope 01:33, 28 October 2012 (UTC)
  • Similar feature goes for chickens, except instead of carrots they use seeds. Trigger hurt 11:41,
  • Whoever posted this "bug" needs to put their account name at the end, too. Epicest_Gamer

29 October 2012 (UTC)

[X] Slime when hopping around, sometime fall into ground and that again and again. This is a creepy bug! Jeb perhaps should fix this bug. Thanks, Broccoli19 18:18, 1 November 2012 (UTC)

[X] When you fly a bit high, and throw a potion of invisibility at a sheep it won't disappear, but its texture will be very weird. I'm not sure, if it's a minor or major bug, or my computer has the problem, but i think it should be noted. --217.197.177.255 19:35, 6 November 2012 (UTC)

[!] Wolves are still very glitchy. Sometimes they will get stuck in Angry mode and the only way to stop it is to punch them. To make it worse, if you disconnect from a server while they're Angry, they disappear. I've also had lots of problems with having my wolves turn invisible, but relogging can fix this usually. All witnessed in SMP. CorduraCavalier 03:51, 21 November 2012 (UTC)

[X] Hostile mobs do not burn when standing on bottom half slabs. The_PyroX_115 05:26, 1 December 2012 (UTC)


Annoyances

[A] Zombie and skeleton armor helmets take damage from the sun, while regular player helmets don't. This gets annoying when i'm using my custom texture pack and trying to make a group of gordon freeman zombies, but they helmets keep breaking. They should make a gamerule for this, such as /gamerule mobArmorDecay or something like that. Trigger hurt 11:41, 29 October 2012 (UTC)

[A] Zombies/Skeletons holding potions don't show the potion type. Only the bottle.

[A] (I didn't know where else to put this for entities) Minecarts don't have the correct collision box. Also, how come boats can be placed on dry land, but minecarts can only be placed on tracks?

[X] If you attack a wolf pack in creative, all the wolves appear to be passive, but after a few seconds they turn into hostile.This bug happens is Taiga biomes where wolves are easy to be found, also forests, too.Epicest_Gamer 07:06, 7 November 2012

[X] Not sure if this is a bug or not, but when a mob spawns after a while it appers to be on the block that it spawned on, but you can see it, but you can't touch it.

  • Such as Skeletons, Zombies, Creepers, and Spiders. Also, Skeletons still move their arms same with Wither Skeleton and Zombies. Epicest_Gamer 04:31, 7 November 2012.
  • If you are not sure if it is a bug, classify it by [?] . Do it by {{bl|?}}.

Graphical/lighting[edit | edit source]

Bugs

[X] When an anvil is placed in an item frame, the block is partially transparent on the bottom. 75.143.98.201 00:51, 27 October 2012 (UTC)Hi_910

[X] Potions of invisibility still don't show item animations right for a player, for example:
* Shooting a bow while invisible the bow does play animations as normal, but the bow is not wielded correctly, it therefor looks like it is shooting downward.
* Swinging any blocks or swords do break/place does not play animations.
* the item in hand does not swing with the normal rotation of the arm
Trigger hurt 11:35, 29 October 2012 (UTC)
[X] Skeletons don't wear armor correctly, the arms appear to be down while the skeleton's arms appear normal. Trigger hurt 11:35, 29 October 2012 (UTC)
[X] Block cracks while breaking blocks are not visible through the surface of water. CorduraCavalier 18:44, 30 October 2012 (UTC)
[X] Large, flat areas with in-set lighting are not always lit properly. Many areas become dark when the world reloads (starting game/exiting portals) and the player must walk over them to get the lighting to update properly. 24.253.107.34 01:47, 2 November 2012 (UTC)

Annoyances

[A] When you shoot an arrow, it renders as if it fell in front of you then teleport to its intended location.

This is an annoying bug that does not always happen, but they really need to fix this, even though it is uncommon. Also please sign your post, even if you don't have an account by typing four tildes (~~~~) Trigger hurt 11:35, 29 October 2012 (UTC)

[A] The fishing rod doesn't make the mobs fly as high as it used to :(

Added tag. This isn't really a big deal. Also, sign your posts with --~~~~. hakr14 02:01, 12 November 2012 (UTC)

Sounds[edit | edit source]

Bugs

On PowerPC Macs (Dual G5, iBook G4, probably others) the audio samples play as distorted noise which sounds very much like 16 bit byte-swapped samples (i.e. the data is being decoded to little-endian format, rather than the PPC and Mac convention of big endian samples).

The .ogg files play correctly via other Mac apps so this is almost certainly an endian problem in the library bundled with the update. It is a serious problem because it renders the game unlistenable-to.

Previous versions of Minecraft 1.x played fine on the same hardware.--78.105.156.144 15:21, 31 October 2012 (UTC)

[!] [MP] Many sounds don't occur on a newly updated server. --Blackbird626 13:10, 28 October 2012 (UTC)

[!] Major lag spike when unloading sounds from a large number of mobs. --92.99.102.46 07:20, 16 November 2012 (UTC)

[X] When stacking a lot of minecarts together, then releasing all of them at once, the minecart sound will begin to constantly play over and over again, resulting in extremely loud noises. --174.6.133.235 05:23, 21 November 2012 (UTC)

[X] Size 2 and 4 slimes make the sounds of magmacubes instead of their normal slime sounds. --Blackbird626 13:10, 28 October 2012 (UTC)

  • For those who don't know, 1 is small, 2 is medium, and 4 is large. HotdogPi ⑬㊲ 01:26, 1 November 2012 (UTC)
  • I think that Mojang wanted it to be like that due to the new sound updates. --KrapTV 23:47, 12 November 2012 (UTC)

[X] No sounds whatsoever except for fall damage. I have a HP ProBook Notebook.

Same, but I have a pc and there's no sound on minecraft. Could it be just 1.4.2? Are the files slightly incorrect? 175.37.212.138 12:32, 10 November 2012 (UTC)

Annoyances

Every time some people walk or do something there is a static noise like *crccccc* only applies to some!

That happens on my classroom's eMacs. Also please sign your post! Minec4rt 03:02, 30 October 2012 (UTC)

[X] macOS For the first ten seconds or so, you cannot hear any sounds whatsoever. If you can reproduce on Windows, comment. --KrapTV 23:39, 12 November 2012 (UTC) Same issue on Windows 7 64-Bits Pro. Minecraft ver 1.4.2. This issue occur, for me, only when I had not started Minecraft for a while. When restarting it, the issue does not occur. - 192.168.119.24 11:37, 20 November 2012 (UTC)

Constant Buzzing/Screeching noise when using headphones, changing pitch depending on menu, or vertical looking angle in-game, but no sounds are broken. --92.99.102.46 07:15, 16 November 2012 (UTC)

Menus[edit | edit source]

Bugs

Annoyances

When the creative menu is open pressing E (or any other key) will automatically go to search, like when I try and close my inventory with E it goes to search and i can't close it unless I hit Esc about 5 times. (EDIT BY 88.73.66.183: Please use ~~~~ to sign your text!)

  • Have you tried clicking something other than the search thingy and pressing E then? 88.73.66.183 17:38, 19 November 2012 (UTC)

[A] When using the creative inventory, if you toss things out to have your survival inventory pick up, and switch over after, it only shows the things you're currently picking up (in the place they should be if the other items were there), but the other slots are empty. The inventory needs to be refreshed by either opening a block with an inventory (E.G. chests, dispencers, etc.) or refreshing the world (exiting out and opening it back up again). Not enough to render the game totally "unplayable," but extremely annoying.

In-game interfaces/HUD[edit | edit source]

Bugs

[!] When I map my controls for right click to something else, I cannot right click to "take half" or "place one" item from my stack. I tried pressing x, the button I mapped place block to. It's glitched. It's when you map a control together then place block to "right click". This is a very bad bug, since I don't have a key map my "pick block" to anything better than "right click".209.181.87.11 21:51, 2 November 2012 (UTC)

Annoyances

Chat/commands[edit | edit source]

Bugs

[X] [MP] When going to run any command no response occurs. (Ex: /gm) = (Nothing) No reaction in-game or on console.

  • Same here, I'm not sure if it is a bug or a feature, because other players can see it. Trigger hurt 15:26, 31 October 2012 (UTC)
  • What bug classification is this? Also, sign your post! --Blackbird626 01:34, 1 November 2012 (UTC)
  • I believe this is a minor bug, there is no reason for the server not to tell a person when their gamemode has changed. Added minor bug tag and multiplayer tag. Trigger hurt 13:45, 2 November 2012 (UTC)

Annoyances

Language/text files[edit | edit source]

Bugs

Annoyances

[A] In Portuguese BR translation, leggings are called "calças" (pants)for all armors ,instead of "perneiras" (leggings), what is wrong, because leggings aren't pants (only for leather armor).

References[edit | edit source]