Hardware requirements

From Minecraft Wiki
Jump to: navigation, search

Any computer with the following hardware should suffice. However, for an enjoyable experience, we suggest looking at the recommended requirements, or even at the optimal requirements.

It is also worth noting, that due to the number of modifications available, Minecraft's exact hardware requirements can be unpredictable. If you have a lot of mods running, pinging each other and passing information around, then your needs are going to be higher than for the unmodified game; although even the vanilla Hopper, with its' extremely makeshift pipe network, recently added some inefficiency. The below guidelines should therefore be considered for the base, unmodified game; although with that said, even with mods, the game itself should never require more than four gigabytes of RAM.

  • Chromebooks running Chrome OS are not supported. However, a rooted Chromebook running a Linux variant will work.

Full game[1][edit | edit source]

  • JRE 6 (jre6u45) or up is required to be able to run the game. From Minecraft 1.12 Java 8 will be required, however Minecraft by default ships with its own version of Java.
  • Intel's GL960/GM965 Express chipset drivers do not support OpenGL 2.1 under Windows operating systems, but do under Linux (as of 1.8.8). This means that versions of Minecraft newer than 1.7.2 cannot be played by these chipsets with a Windows operating system.
Requirements CPU RAM GPU HDD Notes
Minimum Intel Pentium D or AMD Athlon 64 (K8) 2.6 GHz1 2GB Integrated: Intel HD Graphics or AMD (formerly ATI) Radeon HD Graphics with OpenGL 2.1
Discete: Nvidia GeForce 9600 GT or AMD Radeon HD 2400 with OpenGL 3.1
At least 200MB for Game Core and Other Files LAN connectivity is required for multiplayer gaming. If using an Integrated graphics chip, then upgrade or allocate more Video RAM.
Recommended Intel Core i3 or AMD Athlon II (K10) 2.8 GHz 4 GB GeForce 2xx Series or AMD Radeon HD 5xxx Series (Excluding Integrated Chipsets) with OpenGL 3.3 1GB

1 Any graphics card supporting OpenGL 1.3 API.

Classic[edit | edit source]

  • Java Runtime Environment is required to be able to run the game.
  • Note that these requirements are for the game only you will need to allocate more resources to the OS!
Requirements CPU RAM GPU HDD Notes
Minimum Intel P4/NetBurst architecture
or its AMD equivalent (AMD K7)
(Any CPU with MMX/SSE Instructions)
256 MB GeForce 256 or ATI Rage XL and up.
(any GPU with full OpenGL 1.2 support)
At least 8 MB for game data Internet connectivity for online multiplayer gaming.
Recommended Intel Pentium D or AMD K8-Based CPUs
and better
1 GB GeForce 4 or ATI Radeon 9600 and up 40 MB for game saves + sounds

References[edit | edit source]

  1. https://help.mojang.com/customer/portal/articles/325948